fixed problems with undefined symbols (rhbz#798517)

This commit is contained in:
Daniel Kopecek 2012-02-29 10:20:33 +01:00
parent b27e499e8f
commit 6b548c85a8
2 changed files with 7 additions and 4 deletions

View File

@ -48,7 +48,7 @@ diff -up sudo-1.8.3p1/plugins/sudoers/Makefile.in.sssd-support sudo-1.8.3p1/plug
$(incdir)/alloc.h $(incdir)/list.h $(incdir)/fileops.h \
diff -up sudo-1.8.3p1/plugins/sudoers/sssd.c.sssd-support sudo-1.8.3p1/plugins/sudoers/sssd.c
--- sudo-1.8.3p1/plugins/sudoers/sssd.c.sssd-support 2012-01-19 13:41:51.885154296 +0100
+++ sudo-1.8.3p1/plugins/sudoers/sssd.c 2012-02-17 09:38:27.195588846 +0100
+++ sudo-1.8.3p1/plugins/sudoers/sssd.c 2012-02-29 10:05:49.169875120 +0100
@@ -0,0 +1,1157 @@
+/*
+ * Copyright (c) 2003-2011 Todd C. Miller <Todd.Miller@courtesan.com>
@ -641,7 +641,7 @@ diff -up sudo-1.8.3p1/plugins/sudoers/sssd.c.sssd-support sudo-1.8.3p1/plugins/s
+ DPRINTF(2, "No result.");
+ return ret;
+ default:
+ DPRINTF(2, "sss_sudo_sudo_get_values: != 0");
+ DPRINTF(2, "sss_sudo_get_values: != 0");
+ return ret;
+ }
+
@ -895,7 +895,7 @@ diff -up sudo-1.8.3p1/plugins/sudoers/sssd.c.sssd-support sudo-1.8.3p1/plugins/s
+ user_args ? " " : "", user_args ? user_args : "");
+
+ if (sres != NULL)
+ sss_sudo_sudo_free_result(sres);
+ sss_sudo_free_result(sres);
+
+ return !found;
+}

View File

@ -1,7 +1,7 @@
Summary: Allows restricted root access for specified users
Name: sudo
Version: 1.8.3p1
Release: 5%{?dist}
Release: 6%{?dist}
License: ISC
Group: Applications/System
URL: http://www.courtesan.com/sudo/
@ -175,6 +175,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man8/sudo_plugin.8*
%changelog
* Wed Fed 29 2012 Daniel Kopecek <dkopecek@redhat.com> - 1.8.3p1-6
- fixed problems with undefined symbols (rhbz#798517)
* Wed Feb 22 2012 Daniel Kopecek <dkopecek@redhat.com> - 1.8.3p1-5
- SSSD patch update