update to 1.9.5 (#1400040, CVE-2016-8734)
Resolves: rhbz#1400040 Resolves: rhbz#1399871 Resolves: rhbz#888755
This commit is contained in:
parent
a2b9f7990d
commit
8b7160d5ae
2
sources
2
sources
@ -1 +1 @@
|
||||
29121a038f87641055a8183f49e9739f subversion-1.9.4.tar.bz2
|
||||
SHA512 (subversion-1.9.5.tar.bz2) = ff7241ffae2506e97f40011242b5d5c6fa665f5463743f9acc52136b59ad84b6db00b60e70c44a9060579db49b818db06da1d1352aaee78e5bfe6ce56f32a2cf
|
||||
|
@ -1,47 +0,0 @@
|
||||
diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
|
||||
--- subversion-1.8.0/build.conf.rpath
|
||||
+++ subversion-1.8.0/build.conf
|
||||
@@ -501,7 +501,7 @@ type = swig_lib
|
||||
lang = python
|
||||
path = subversion/bindings/swig/python/libsvn_swig_py
|
||||
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
|
||||
-link-cmd = $(LINK)
|
||||
+link-cmd = $(LINK_LIB)
|
||||
install = swig-py-lib
|
||||
# need special build rule to include -DSWIGPYTHON
|
||||
compile-cmd = $(COMPILE_SWIG_PY)
|
||||
@@ -524,7 +524,7 @@ type = swig_lib
|
||||
lang = ruby
|
||||
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
||||
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
|
||||
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
|
||||
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
|
||||
install = swig-rb-lib
|
||||
# need special build rule to include
|
||||
compile-cmd = $(COMPILE_SWIG_RB)
|
||||
--- subversion-1.8.0/build/generator/gen_base.py.rpath
|
||||
+++ subversion-1.8.0/build/generator/gen_base.py
|
||||
@@ -514,6 +514,10 @@ class TargetLib(TargetLinked):
|
||||
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
|
||||
self.msvc_export = options.get('msvc-export', '').split()
|
||||
|
||||
+ ### hmm. this is Makefile-specific
|
||||
+ if self.link_cmd == '$(LINK)':
|
||||
+ self.link_cmd = '$(LINK_LIB)'
|
||||
+
|
||||
class TargetApacheMod(TargetLib):
|
||||
|
||||
def __init__(self, name, options, gen_obj):
|
||||
--- subversion-1.8.0/Makefile.in.rpath
|
||||
+++ subversion-1.8.0/Makefile.in
|
||||
@@ -201,8 +201,8 @@ COMPILE_JAVAHL_JAVAH = $(JAVAH)
|
||||
# special compilation for files destined for cxxhl
|
||||
COMPILE_CXXHL_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=compile $(COMPILE_CXX) $(LT_CFLAGS) $(CXXHL_INCLUDES) -o $@ -c
|
||||
|
||||
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
|
||||
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||
+LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
|
||||
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||
LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
|
||||
|
@ -1,47 +0,0 @@
|
||||
|
||||
Fugly hack to fix build with SWIG 3.0.x. The pre-processor seems to
|
||||
expand the %define correctly with only the change to %{..%}, but
|
||||
%extend still breaks somehow.
|
||||
|
||||
https://github.com/swig/swig/issues/379
|
||||
|
||||
--- subversion-1.8.13/subversion/bindings/swig/include/proxy.swg.swigpython
|
||||
+++ subversion-1.8.13/subversion/bindings/swig/include/proxy.swg
|
||||
@@ -62,7 +62,7 @@
|
||||
|
||||
/* Default code for all wrapped proxy classes in Python */
|
||||
%define %proxy_pythoncode(TYPE)
|
||||
-%pythoncode {
|
||||
+%pythoncode %{
|
||||
def set_parent_pool(self, parent_pool=None):
|
||||
"""Create a new proxy object for TYPE"""
|
||||
import libsvn.core, weakref
|
||||
@@ -83,13 +83,10 @@
|
||||
|
||||
value = _swig_getattr(self, self.__class__, name)
|
||||
|
||||
- # If we got back a different object than we have, we need to copy all our
|
||||
- # metadata into it, so that it looks identical
|
||||
members = self.__dict__.get("_members")
|
||||
if members is not None:
|
||||
_copy_metadata_deep(value, members.get(name))
|
||||
|
||||
- # Verify that the new object is good
|
||||
_assert_valid_deep(value)
|
||||
|
||||
return value
|
||||
@@ -98,13 +95,10 @@
|
||||
"""Set an attribute on this object"""
|
||||
self.assert_valid()
|
||||
|
||||
- # Save a copy of the object, so that the garbage
|
||||
- # collector won't kill the object while it's in
|
||||
- # SWIG-land
|
||||
self.__dict__.setdefault("_members",{})[name] = value
|
||||
|
||||
return _swig_setattr(self, self.__class__, name, value)
|
||||
-}
|
||||
+%}
|
||||
%enddef
|
||||
|
||||
/* Define a proxy for wrapping an existing struct */
|
@ -1,13 +0,0 @@
|
||||
Index: subversion/bindings/swig/ruby/test/test_repos.rb
|
||||
===================================================================
|
||||
--- subversion/bindings/swig/ruby/test/test_repos.rb (revision 1671099)
|
||||
+++ subversion/bindings/swig/ruby/test/test_repos.rb (working copy)
|
||||
@@ -679,7 +679,7 @@
|
||||
dest_path = File.join(@tmp_path, "dest")
|
||||
Svn::Repos.create(dest_path) do |repos|
|
||||
assert_raises(NoMethodError) do
|
||||
- repos.load_fs(nil)
|
||||
+ repos.load_fs(Object.new)
|
||||
end
|
||||
end
|
||||
|
@ -19,8 +19,8 @@
|
||||
|
||||
Summary: A Modern Concurrent Version Control System
|
||||
Name: subversion
|
||||
Version: 1.9.4
|
||||
Release: 4%{?dist}
|
||||
Version: 1.9.5
|
||||
Release: 1%{?dist}
|
||||
License: ASL 2.0
|
||||
Group: Development/Tools
|
||||
URL: http://subversion.apache.org/
|
||||
@ -38,9 +38,6 @@ Patch2: subversion-1.9.0-pie.patch
|
||||
Patch3: subversion-1.9.4-kwallet.patch
|
||||
Patch4: subversion-1.8.0-rubybind.patch
|
||||
Patch5: subversion-1.8.5-swigplWall.patch
|
||||
Patch6: subversion-1.8.13-swigpython.patch
|
||||
# Revert one of Ruby 2.2 fixes which is necessary also for 1.9.4
|
||||
Patch7: subversion-1.9.4-ruby22-fixes.rb
|
||||
|
||||
BuildRequires: autoconf, libtool, python, python-devel, texinfo, which
|
||||
BuildRequires: libdb-devel >= 4.1.25, swig >= 1.3.24, gettext
|
||||
@ -184,8 +181,6 @@ This package includes supplementary tools for use with Subversion.
|
||||
%patch3 -p1 -b .kwallet
|
||||
%patch4 -p1 -b .rubybind
|
||||
%patch5 -p1 -b .swigplWall
|
||||
%patch6 -p1 -b .swigpython
|
||||
%patch7 -p0 -b .ruby22-fixes
|
||||
|
||||
%build
|
||||
# Regenerate the buildsystem, so that:
|
||||
@ -470,6 +465,9 @@ make check-javahl
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 2 2017 Joe Orton <jorton@redhat.com> - 1.9.5-1
|
||||
- update to 1.9.5 (#1400040, CVE-2016-8734)
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.4-4
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user