revert to 1.6.x for f16, 84ce3d5836

This commit is contained in:
Joe Orton 2012-04-30 09:43:05 +01:00
parent d882fd1d57
commit 6f3e81155c
8 changed files with 163 additions and 98 deletions

4
.gitignore vendored
View File

@ -5,7 +5,3 @@ subversion-1.6.12.tar.bz2
/subversion-1.6.15.tar.bz2
/subversion-1.6.16.tar.bz2
/subversion-1.6.17.tar.bz2
/subversion-1.7.0.tar.bz2
/subversion-1.7.0
/clog
/subversion-1.7.1.tar.bz2

View File

@ -1 +1 @@
8a4fa74385df85a9702141b6b68b8307 subversion-1.7.1.tar.bz2
81e5dc5beee4b3fc025ac70c0b6caa14 subversion-1.6.17.tar.bz2

View File

@ -0,0 +1,30 @@
--- subversion-1.6.0/build/ac-macros/apr.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/apr.m4
@@ -76,9 +76,9 @@ AC_DEFUN(SVN_LIB_APR,
dnl When APR stores the dependent libs in the .la file, we don't need
dnl --libs.
- SVN_APR_LIBS="`$apr_config --link-libtool --libs`"
+ SVN_APR_LIBS="`$apr_config --link-libtool`"
if test $? -ne 0; then
- AC_MSG_ERROR([apr-config --link-libtool --libs failed])
+ AC_MSG_ERROR([apr-config --link-libtool failed])
fi
SVN_APR_EXPORT_LIBS="`$apr_config --link-ld --libs`"
--- subversion-1.6.0/build/ac-macros/aprutil.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/aprutil.m4
@@ -77,11 +77,9 @@ AC_DEFUN(SVN_LIB_APRUTIL,
AC_MSG_ERROR([apu-config --prefix failed])
fi
- dnl When APR stores the dependent libs in the .la file, we don't need
- dnl --libs.
- SVN_APRUTIL_LIBS="`$apu_config --link-libtool --libs`"
+ SVN_APRUTIL_LIBS="`$apu_config --link-libtool`"
if test $? -ne 0; then
- AC_MSG_ERROR([apu-config --link-libtool --libs failed])
+ AC_MSG_ERROR([apu-config --link-libtool failed])
fi
SVN_APRUTIL_EXPORT_LIBS="`$apu_config --link-ld --libs`"

View File

@ -1,16 +1,24 @@
diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
--- subversion-1.7.0/build.conf.rpath 2011-08-04 21:18:50.000000000 +0100
+++ subversion-1.7.0/build.conf 2011-10-12 09:23:43.844525530 +0100
@@ -478,7 +478,7 @@ type = swig_lib
Libraries should be linked with -rpath $libdir but programs should not.
Doing so for the latter means that a redundant RPATH entry of $libdir
will end up in the binaries.
The redundant RPATH can also cause obscure build failures by causing
in-build binaries to pick up libraries from the system environment,
which libtool will otherwise avoid.
--- subversion-1.6.1/build.conf.rpath
+++ subversion-1.6.1/build.conf
@@ -472,7 +472,7 @@ type = swig_lib
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK)
+link-cmd = $(LINK_LIB)
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
@@ -501,7 +501,7 @@ type = swig_lib
@@ -495,7 +495,7 @@ type = swig_lib
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
@ -19,10 +27,9 @@ diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
install = swig-rb-lib
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
diff -uap subversion-1.7.0/build/generator/gen_base.py.rpath subversion-1.7.0/build/generator/gen_base.py
--- subversion-1.7.0/build/generator/gen_base.py.rpath 2011-06-22 17:44:54.000000000 +0100
+++ subversion-1.7.0/build/generator/gen_base.py 2011-10-12 09:23:15.368649375 +0100
@@ -506,6 +506,10 @@ class TargetLib(TargetLinked):
--- subversion-1.6.1/build/generator/gen_base.py.rpath
+++ subversion-1.6.1/build/generator/gen_base.py
@@ -455,6 +455,10 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = options.get('msvc-export', '').split()
@ -33,17 +40,15 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.rpath subversion-1.7.0/bu
class TargetApacheMod(TargetLib):
def __init__(self, name, options, gen_obj):
diff -uap subversion-1.7.0/Makefile.in.rpath subversion-1.7.0/Makefile.in
--- subversion-1.7.0/Makefile.in.rpath 2011-07-16 12:50:53.000000000 +0100
+++ subversion-1.7.0/Makefile.in 2011-10-12 09:24:36.165524732 +0100
@@ -203,8 +203,8 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
--- subversion-1.6.1/Makefile.in.rpath
+++ subversion-1.6.1/Makefile.in
@@ -184,7 +184,8 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
+LINK_LIB = $(LINK) -rpath $(libdir)
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
# special link rule for mod_dav_svn

View File

@ -1,7 +1,7 @@
diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/build/generator/gen_base.py
--- subversion-1.7.0/build/generator/gen_base.py.pie 2011-10-12 09:25:30.510524103 +0100
+++ subversion-1.7.0/build/generator/gen_base.py 2011-10-12 09:25:30.515650110 +0100
@@ -406,7 +406,7 @@ class TargetLinked(Target):
diff -up subversion-1.6.12/build/generator/gen_base.py.pie subversion-1.6.12/build/generator/gen_base.py
--- subversion-1.6.12/build/generator/gen_base.py.pie 2010-09-07 14:05:29.307274005 +0100
+++ subversion-1.6.12/build/generator/gen_base.py 2010-09-07 14:05:29.313274265 +0100
@@ -357,7 +357,7 @@ class TargetLinked(Target):
self.install = options.get('install')
self.compile_cmd = options.get('compile-cmd')
self.sources = options.get('sources', '*.c *.cpp')
@ -10,7 +10,7 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/buil
self.external_lib = options.get('external-lib')
self.external_project = options.get('external-project')
@@ -462,6 +462,11 @@ class TargetExe(TargetLinked):
@@ -413,6 +413,11 @@ class TargetExe(TargetLinked):
self.manpages = options.get('manpages', '')
self.testing = options.get('testing')
@ -22,7 +22,7 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/buil
def add_dependencies(self):
TargetLinked.add_dependencies(self)
@@ -507,8 +512,8 @@ class TargetLib(TargetLinked):
@@ -456,8 +461,8 @@ class TargetLib(TargetLinked):
self.msvc_export = options.get('msvc-export', '').split()
### hmm. this is Makefile-specific
@ -33,21 +33,24 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/buil
class TargetApacheMod(TargetLib):
diff -uap subversion-1.7.0/Makefile.in.pie subversion-1.7.0/Makefile.in
--- subversion-1.7.0/Makefile.in.pie 2011-10-12 09:25:30.511600030 +0100
+++ subversion-1.7.0/Makefile.in 2011-10-12 09:26:16.757524426 +0100
@@ -205,6 +205,9 @@ COMPILE_JAVAHL_JAVAH = $(JAVAH)
diff -up subversion-1.6.12/Makefile.in.pie subversion-1.6.12/Makefile.in
--- subversion-1.6.12/Makefile.in.pie 2010-09-07 14:05:29.308274305 +0100
+++ subversion-1.6.12/Makefile.in 2010-09-07 14:14:28.795274233 +0100
@@ -184,8 +184,11 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK_LIB = $(LINK) -rpath $(libdir)
LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
+LINK_LIB = $(LINK) -rpath $(libdir)
+LINK_TEST = $(LINK) -no-install
+LINK_TEST_LIB = $(LINK) -avoid-version
+LINK_EXE = $(LINK) -pie
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
@@ -657,7 +660,7 @@ schema-clean:
$(PYTHON) $(top_srcdir)/build/transform_sql.py $< $(top_srcdir)/$@
# special link rule for mod_dav_svn
@@ -600,7 +603,7 @@ schema-clean:
$(top_srcdir)/build/transform_sql.sh $< < $< > $(top_srcdir)/$@
.c.o:
- $(COMPILE) -o $@ -c $<

View File

@ -3,24 +3,23 @@ The first half of this is certainly upstream-worthy, but the second half is pres
some Fedora-specific KDE packaging thing. It's not obvious how to get
kde4-config to report the directory which contains the .so files.
--- subversion-1.7.0/build/ac-macros/kwallet.m4.kwallet 2010-11-01 19:29:16.000000000 +0000
+++ subversion-1.7.0/build/ac-macros/kwallet.m4 2011-10-12 09:32:55.129561537 +0100
@@ -64,15 +64,14 @@ AC_DEFUN(SVN_LIB_KWALLET,
--- subversion-1.6.6/build/ac-macros/kwallet.m4.kwallet
+++ subversion-1.6.6/build/ac-macros/kwallet.m4
@@ -47,14 +47,14 @@ AC_DEFUN(SVN_LIB_KWALLET,
fi
done
qt_include_dirs="`$PKG_CONFIG --cflags-only-I QtCore QtDBus QtGui`"
- kde_dir="`$KDE4_CONFIG --prefix`"
- kde_dir="`$kde4_config --prefix`"
- SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs -I$kde_dir/include"
+ kde_include_dirs="-I`$KDE4_CONFIG --path include`"
+ kde_include_dirs="-I`$kde4_config --path include`"
+ SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs $kde_include_dirs"
qt_libs_other_options="`$PKG_CONFIG --libs-only-other QtCore QtDBus QtGui`"
SVN_KWALLET_LIBS="$DBUS_LIBS -lQtCore -lQtDBus -lQtGui -lkdecore -lkdeui $qt_libs_other_options"
CXXFLAGS="$CXXFLAGS $SVN_KWALLET_INCLUDES"
LIBS="$LIBS $SVN_KWALLET_LIBS"
qt_lib_dirs="`$PKG_CONFIG --libs-only-L QtCore QtDBus QtGui`"
- kde_lib_suffix="`$KDE4_CONFIG --libsuffix`"
- LDFLAGS="$old_LDFLAGS `SVN_REMOVE_STANDARD_LIB_DIRS($qt_lib_dirs -L$kde_dir/lib$kde_lib_suffix)`"
+ LDFLAGS="$old_LDFLAGS `SVN_REMOVE_STANDARD_LIB_DIRS($qt_lib_dirs)` -L$libdir/kde4/devel"
- LDFLAGS="$old_LDFLAGS $qt_lib_dirs -L$kde_dir/lib`$kde4_config --libsuffix`"
+ LDFLAGS="$old_LDFLAGS $qt_lib_dirs -L$libdir/kde4/devel"
AC_LANG(C++)
AC_LINK_IFELSE([AC_LANG_SOURCE([[
AC_LINK_IFELSE([
#include <kwallet.h>

View File

@ -19,7 +19,7 @@ LoadModule authz_svn_module modules/mod_authz_svn.so
#
# # cd /var/www/svn
# # svnadmin create stuff
# # chown -R apache:apache stuff
# # chown -R apache.apache stuff
# # chcon -R -t httpd_sys_content_t stuff
#

View File

@ -2,7 +2,6 @@
%define make_check 1
%define with_java 1
%define with_kwallet 0
# set JDK path to build javahl; default for JPackage
%define jdk_path /usr/lib/jvm/java
@ -13,11 +12,13 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%global svn2cl_version 0.11
Summary: A Modern Concurrent Version Control System
Name: subversion
Version: 1.7.1
Release: 1%{?dist}
License: ASL 2.0
Version: 1.6.17
Release: 5%{?dist}
License: ASL 1.1
Group: Development/Tools
URL: http://subversion.apache.org/
Source0: http://subversion.tigris.org/downloads/subversion-%{version}.tar.bz2
@ -26,14 +27,20 @@ Source3: filter-requires.sh
Source4: http://www.xsteve.at/prg/emacs/psvn.el
Source5: psvn-init.el
Source6: svnserve.init
Patch1: subversion-1.7.0-rpath.patch
Patch2: subversion-1.7.0-pie.patch
Patch3: subversion-1.7.0-kwallet.patch
# http://bugs.debian.org/546990
Patch0: subversion-1.6.5-newlines.patch
Patch2: subversion-1.6.0-deplibs.patch
Patch3: subversion-1.6.1-rpath.patch
Patch6: subversion-1.6.11-pie.patch
Patch8: subversion-1.6.6-kwallet.patch
Patch9: subversion-1.6.12-disable-client-test.patch
Patch10: subversion-MakeMaker.patch
BuildRequires: autoconf, libtool, python, python-devel, texinfo, which
BuildRequires: db4-devel >= 4.1.25, swig >= 1.3.24, gettext
BuildRequires: apr-devel >= 1.3.0, apr-util-devel >= 1.3.0
BuildRequires: neon-devel >= 0:0.24.7-1, cyrus-sasl-devel
BuildRequires: sqlite-devel >= 3.4.0, file-devel
BuildRequires: sqlite-devel >= 3.4.0
BuildRequires: gnome-keyring-devel, dbus-devel, kdelibs-devel >= 4.0.0
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Provides: svn = %{version}-%{release}
Requires: subversion-libs%{?_isa} = %{version}-%{release}
@ -57,7 +64,7 @@ compelling replacement for CVS.
Group: Development/Tools
Summary: Libraries for Subversion Version Control system
# APR 1.3.x interfaces are required
Conflicts: apr%{?_isa} < 1.3.0
Conflicts: apr%{?_isa}< 1.3.0
%description libs
The subversion-libs package includes the essential shared libraries
@ -85,23 +92,19 @@ for developers interacting with the subversion package.
Group: Development/Tools
Summary: GNOME Keyring support for Subversion
Requires: subversion%{?_isa} = %{version}-%{release}
BuildRequires: gnome-keyring-devel, dbus-devel
%description gnome
The subversion-gnome package adds support for storing Subversion
passwords in the GNOME Keyring.
%if %{with_kwallet}
%package kde
Group: Development/Tools
Summary: KDE Wallet support for Subversion
Requires: subversion%{?_isa} = %{version}-%{release}
BuildRequires: kdelibs-devel >= 4.0.0
%description kde
The subversion-kde package adds support for storing Subversion
passwords in the KDE Wallet.
%endif
%package -n mod_dav_svn
Group: System Environment/Daemons
@ -151,11 +154,44 @@ Requires: ruby(abi) = 1.8
%description ruby
This package includes the Ruby bindings to the Subversion libraries.
%package svn2cl
Group: Development/Tools
Summary: Create a ChangeLog from a Subversion log
License: BSD
# -5: fake release for the Obsoletes to work
Provides: svn2cl = %{svn2cl_version}-5
Obsoletes: svn2cl < 0.11-4
BuildArch: noarch
Requires: libxslt
Requires: subversion = %{version}
%description svn2cl
svn2cl is a simple XSL transformation and shell script wrapper for
generating a classic GNU-style ChangeLog from a subversion repository
log. It is made from several changelog-like scripts using common XSLT
constructs found in different places.
%prep
%setup -q
%patch1 -p1 -b .rpath
%patch2 -p1 -b .pie
%patch3 -p1 -b .kwallet
cd contrib/client-side/svn2cl
%patch0 -p1 -b .newlines
cd ../../..
%patch2 -p1 -b .deplibs
%patch3 -p1 -b .rpath
%patch6 -p1 -b .pie
%patch8 -p1 -b .kwallet
%patch9 -p1 -b .disable-client-test
%patch10 -p1 -b .eemm
sed -i -e 's|^XSL="$dir/|XSL="%{_datadir}/svn2cl/|' \
contrib/client-side/svn2cl/svn2cl.sh
# Sanity check svn2cl_version
v=$(contrib/client-side/svn2cl/svn2cl.sh -V | sed -n '1{s/.* //;p;}')
if [ "$v" != "%{svn2cl_version}" ]; then
echo -n "ERROR: svn2cl_version not up to date in specfile: "
echo "'$v' <> '%{svn2cl_version}'"
exit 1
fi
mv tools/client-side/bash_completion .
@ -191,17 +227,15 @@ export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
--enable-javahl \
--with-junit=%{_prefix}/share/java/junit.jar \
%endif
%if %{with_kwallet}
--with-kwallet \
%endif
--with-berkeley-db || (cat config.log; exit 1)
make %{?_smp_mflags} all
make swig-py swig-py-lib %{swigdirs}
make swig-pl swig-pl-lib swig-rb swig-rb-lib
%if %{with_java}
# javahl-javah does not parallel-make with javahl
#make javahl-java javahl-javah
make javahl
make javahl-java javahl-javah
make %{?_smp_mflags} javahl
%endif
%install
@ -223,7 +257,7 @@ install -m 644 $RPM_SOURCE_DIR/subversion.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/h
# Install SysV init script
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
install -p -m 755 $RPM_SOURCE_DIR/svnserve.init \
$RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
$RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
# Remove unpackaged files
rm -rf ${RPM_BUILD_ROOT}%{_includedir}/subversion-*/*.txt \
@ -273,6 +307,14 @@ sed -i "/^dependency_libs/{
s,%{_libdir}/lib[^a][^p][^r][^ ']*.la, ,g;
}" $RPM_BUILD_ROOT%{_libdir}/*.la
# Install svn2cl
pushd contrib/client-side/svn2cl
install -Dpm 755 svn2cl.sh $RPM_BUILD_ROOT%{_bindir}/svn2cl
install -dm 755 $RPM_BUILD_ROOT%{_datadir}/svn2cl
install -pm 644 *.xsl $RPM_BUILD_ROOT%{_datadir}/svn2cl
install -Dpm 644 svn2cl.1 $RPM_BUILD_ROOT%{_mandir}/man1/svn2cl.1
popd
# Install bash completion
install -Dpm 644 bash_completion \
$RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/%{name}
@ -285,11 +327,7 @@ export LANG=C LC_ALL=C
export LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}
export MALLOC_PERTURB_=171 MALLOC_CHECK_=3
export LIBC_FATAL_STDERR_=1
if ! make check check-swig-pl check-swig-py CLEANUP=yes; then
: Test suite failure.
cat fails.log
exit 1
fi
make check check-swig-pl check-swig-py CLEANUP=yes
# check-swig-rb omitted: it runs svnserve
%if %{with_java}
make check-javahl
@ -305,8 +343,8 @@ rm -rf ${RPM_BUILD_ROOT}
%preun
if [ $1 = 0 ]; then
/sbin/service svnserve stop > /dev/null 2>&1
/sbin/chkconfig --del svnserve
/sbin/service svnserve stop > /dev/null 2>&1
/sbin/chkconfig --del svnserve
fi
%post libs -p /sbin/ldconfig
@ -329,10 +367,15 @@ fi
%files -f %{name}.lang
%defattr(-,root,root)
%doc BUGS COMMITTERS LICENSE NOTICE INSTALL README CHANGES
%doc tools mod_authz_svn-INSTALL
%doc BUGS COMMITTERS COPYING HACKING INSTALL README CHANGES
%doc tools subversion/LICENSE mod_authz_svn-INSTALL
%doc contrib/client-side/svn_load_dirs/{*.pl,*.example,*.README}
%doc contrib/client-side/svnmerge/*.{README,py}
%doc contrib/client-side/wcgrep
%{_bindir}/*
%exclude %{_bindir}/svn2cl
%{_mandir}/man*/*
%exclude %{_mandir}/man1/svn2cl.1*
%{_sysconfdir}/rc.d/init.d/svnserve
%{_datadir}/emacs/site-lisp/*.el
%{_datadir}/xemacs/site-packages/lisp/*.el
@ -342,13 +385,11 @@ fi
%files libs
%defattr(-,root,root)
%doc LICENSE NOTICE
%doc subversion/LICENSE
%{_libdir}/libsvn_*.so.*
%exclude %{_libdir}/libsvn_swig_perl*
%exclude %{_libdir}/libsvn_swig_ruby*
%if %{with_kwallet}
%exclude %{_libdir}/libsvn_auth_kwallet*
%endif
%exclude %{_libdir}/libsvn_auth_gnome*
%files python
@ -360,11 +401,9 @@ fi
%defattr(-,root,root)
%{_libdir}/libsvn_auth_gnome_keyring-*.so.*
%if %{with_kwallet}
%files kde
%defattr(-,root,root)
%{_libdir}/libsvn_auth_kwallet-*.so.*
%endif
%files devel
%defattr(-,root,root)
@ -401,23 +440,16 @@ fi
%{_javadir}/svn-javahl.jar
%endif
%files svn2cl
%defattr(-,root,root,-)
%doc contrib/client-side/svn2cl/NEWS contrib/client-side/svn2cl/README
%doc contrib/client-side/svn2cl/TODO contrib/client-side/svn2cl/authors.xml
%doc contrib/client-side/svn2cl/svn2html.css
%{_bindir}/svn2cl
%{_datadir}/svn2cl/
%{_mandir}/man1/svn2cl.1*
%changelog
* Mon Nov 28 2011 Joe Orton <jorton@redhat.com> - 1.7.1-1
- update to 1.7.1
- (temporarily) disable failing kwallet support
* Sun Nov 27 2011 Ville Skyttä <ville.skytta@iki.fi> - 1.7.0-3
- Build with libmagic support.
* Sat Oct 15 2011 Ville Skyttä <ville.skytta@iki.fi> - 1.7.0-2
- Fix apr Conflicts syntax in -libs.
- Fix obsolete chown syntax in subversion.conf.
- Fix use of spaces vs tabs in specfile.
* Wed Oct 12 2011 Joe Orton <jorton@redhat.com> - 1.7.0-1
- update to 1.7.0
- drop svn2cl (no longer shipped in upstream tarball)
* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.6.17-5
- Perl mass rebuild