- update to 1.5.0

This commit is contained in:
jorton 2008-06-26 13:44:29 +00:00
parent 8fbd40dc10
commit 149f44bb74
5 changed files with 67 additions and 262 deletions

View File

@ -1,184 +0,0 @@
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/uuids-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/uuids-table.c
@@ -47,7 +47,7 @@
BDB_ERR(db_create(&uuids, env, 0));
BDB_ERR(uuids->set_re_len(uuids, APR_UUID_FORMATTED_LENGTH));
- error = uuids->open(SVN_BDB_OPEN_PARAMS(uuids, NULL),
+ error = (uuids->open)(SVN_BDB_OPEN_PARAMS(uuids, NULL),
"uuids", 0, DB_RECNO,
open_flags, 0666);
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/strings-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/strings-table.c
@@ -44,10 +44,10 @@
BDB_ERR(db_create(&strings, env, 0));
/* Enable duplicate keys. This allows the data to be spread out across
- multiple records. Note: this must occur before ->open(). */
+ multiple records. Note: this must occur before (->open)(). */
BDB_ERR(strings->set_flags(strings, DB_DUP));
- BDB_ERR(strings->open(SVN_BDB_OPEN_PARAMS(strings, NULL),
+ BDB_ERR((strings->open)(SVN_BDB_OPEN_PARAMS(strings, NULL),
"strings", 0, DB_BTREE,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/changes-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/changes-table.c
@@ -51,10 +51,10 @@
BDB_ERR(db_create(&changes, env, 0));
/* Enable duplicate keys. This allows us to store the changes
- one-per-row. Note: this must occur before ->open(). */
+ one-per-row. Note: this must occur before (->open)(). */
BDB_ERR(changes->set_flags(changes, DB_DUP));
- BDB_ERR(changes->open(SVN_BDB_OPEN_PARAMS(changes, NULL),
+ BDB_ERR((changes->open)(SVN_BDB_OPEN_PARAMS(changes, NULL),
"changes", 0, DB_BTREE,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/lock-tokens-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/lock-tokens-table.c
@@ -43,7 +43,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&lock_tokens, env, 0));
- error = lock_tokens->open(SVN_BDB_OPEN_PARAMS(lock_tokens, NULL),
+ error = (lock_tokens->open)(SVN_BDB_OPEN_PARAMS(lock_tokens, NULL),
"lock-tokens", 0, DB_BTREE,
open_flags, 0666);
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/env.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/env.c
@@ -626,7 +626,7 @@
flags |= DB_THREAD;
#endif
SVN_ERR(convert_bdb_error
- (bdb, bdb->env->open(bdb->env, bdb->path_bdb, flags, mode)));
+ (bdb, (bdb->env->open)(bdb->env, bdb->path_bdb, flags, mode)));
#if SVN_BDB_AUTO_COMMIT
/* Assert the BDB_AUTO_COMMIT flag on the opened environment. This
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/copies-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/copies-table.c
@@ -43,7 +43,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&copies, env, 0));
- BDB_ERR(copies->open(SVN_BDB_OPEN_PARAMS(copies, NULL),
+ BDB_ERR((copies->open)(SVN_BDB_OPEN_PARAMS(copies, NULL),
"copies", 0, DB_BTREE,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/nodes-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/nodes-table.c
@@ -50,7 +50,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&nodes, env, 0));
- BDB_ERR(nodes->open(SVN_BDB_OPEN_PARAMS(nodes, NULL),
+ BDB_ERR((nodes->open)(SVN_BDB_OPEN_PARAMS(nodes, NULL),
"nodes", 0, DB_BTREE,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/locks-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/locks-table.c
@@ -44,7 +44,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&locks, env, 0));
- error = locks->open(SVN_BDB_OPEN_PARAMS(locks, NULL),
+ error = (locks->open)(SVN_BDB_OPEN_PARAMS(locks, NULL),
"locks", 0, DB_BTREE,
open_flags, 0666);
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/txn-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/txn-table.c
@@ -51,7 +51,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&txns, env, 0));
- BDB_ERR(txns->open(SVN_BDB_OPEN_PARAMS(txns, NULL),
+ BDB_ERR((txns->open)(SVN_BDB_OPEN_PARAMS(txns, NULL),
"transactions", 0, DB_BTREE,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/reps-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/reps-table.c
@@ -44,7 +44,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&reps, env, 0));
- BDB_ERR(reps->open(SVN_BDB_OPEN_PARAMS(reps, NULL),
+ BDB_ERR((reps->open)(SVN_BDB_OPEN_PARAMS(reps, NULL),
"representations", 0, DB_BTREE,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_fs_base/bdb/rev-table.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs_base/bdb/rev-table.c
@@ -40,7 +40,7 @@
BDB_ERR(svn_fs_bdb__check_version());
BDB_ERR(db_create(&revisions, env, 0));
- BDB_ERR(revisions->open(SVN_BDB_OPEN_PARAMS(revisions, NULL),
+ BDB_ERR((revisions->open)(SVN_BDB_OPEN_PARAMS(revisions, NULL),
"revisions", 0, DB_RECNO,
open_flags, 0666));
--- subversion-1.4.4/subversion/libsvn_ra/ra_loader.c.macropen
+++ subversion-1.4.4/subversion/libsvn_ra/ra_loader.c
@@ -291,8 +291,8 @@
session->pool = pool;
/* Ask the library to open the session. */
- SVN_ERR(vtable->open(session, repos_URL, callbacks, callback_baton,
- config, pool));
+ SVN_ERR((vtable->open)(session, repos_URL, callbacks, callback_baton,
+ config, pool));
*session_p = session;
return SVN_NO_ERROR;
--- subversion-1.4.4/subversion/tests/libsvn_ra_local/ra-local-test.c.macropen
+++ subversion-1.4.4/subversion/tests/libsvn_ra_local/ra-local-test.c
@@ -95,7 +95,7 @@
SVN_ERR(current_directory_url(&url, repos_name, pool));
/* Open an RA session into this repository. */
- SVN_ERR((*plugin)->open(session, url, cbtable, NULL, NULL, pool));
+ SVN_ERR(((*plugin)->open)(session, url, cbtable, NULL, NULL, pool));
return SVN_NO_ERROR;
}
--- subversion-1.4.4/subversion/libsvn_fs/fs-loader.c.macropen
+++ subversion-1.4.4/subversion/libsvn_fs/fs-loader.c
@@ -364,7 +364,7 @@
SVN_ERR(fs_library_vtable(&vtable, path, pool));
*fs_p = svn_fs_new(fs_config, pool);
- SVN_ERR(vtable->open(*fs_p, path, pool));
+ SVN_ERR((vtable->open)(*fs_p, path, pool));
return serialized_init(*fs_p, pool);
}
@@ -423,7 +423,7 @@
fs_library_vtable_t *vtable;
SVN_ERR(fs_library_vtable(&vtable, path, fs->pool));
- SVN_ERR(vtable->open(fs, path, fs->pool));
+ SVN_ERR((vtable->open)(fs, path, fs->pool));
return serialized_init(fs, fs->pool);
}
--- subversion-1.4.4/build/generator/swig/header_wrappers.py.macropen
+++ subversion-1.4.4/build/generator/swig/header_wrappers.py
@@ -103,7 +103,7 @@
self.ofile.write(
"static svn_error_t *%s_invoke_%s(\n" % (struct[:-2], name) +
" %s *_obj, %s) {\n" % (struct, params) +
- " return _obj->%s(%s);\n" % (name, param_names) +
+ " return (_obj->%s)(%s);\n" % (name, param_names) +
"}\n\n")
self.ofile.write("%}\n")

View File

@ -1,21 +0,0 @@
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=453166
# For some reason, rubyhead.swg is included without being needed (at least
# for the current swig 1.3.33 version). This leads to a redefinition of
# _mSWIG. The documentation of SWIG only talks about including just
# the external_runtime file, not any additional includes. Also, the other
# bindings do not include anything from SWIG apart from the external
# runtime. So I think this patch should suffice.
#
# -- Torsten Landschoff
Index: subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.c
===================================================================
--- subversion-1.4.4/subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.c.swig133
+++ subversion-1.4.4/subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.c
@@ -1,4 +1,3 @@
-#include "rubyhead.swg"
#include "swig_ruby_external_runtime.swg"
#include "swigutil_rb.h"
#include <st.h>

View File

@ -1,52 +1,26 @@
Build subversion executables as PIEs. Requires a slight jig to
ensure that executables in the test suite are *not* built using
-pie, since that doesn't work when main() is not itself an
object built with -pie.
--- subversion-1.4.0/build.conf.pie
+++ subversion-1.4.0/build.conf
@@ -416,7 +416,7 @@
--- subversion-1.5.0/build.conf.pie
+++ subversion-1.5.0/build.conf
@@ -452,7 +452,7 @@ type = swig_lib
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_subr libsvn_delta libsvn_wc aprutil apriconv apr
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
--- subversion-1.4.0/Makefile.in.pie
+++ subversion-1.4.0/Makefile.in
@@ -139,9 +139,10 @@
CPPFLAGS = @CPPFLAGS@ $(EXTRA_CPPFLAGS)
LDFLAGS = @LDFLAGS@ $(EXTRA_LDFLAGS)
-COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+BASE_COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+COMPILE = $(BASE_COMPILE) -fpie
COMPILE_CXX = $(CXX) $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(INCLUDES)
-LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE)
+LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(BASE_COMPILE)
# special compilation for files destined for mod_dav_svn
COMPILE_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(APACHE_INCLUDES) $(INCLUDES) -o $@ -c
@@ -156,8 +157,11 @@
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
-LINK_LIB = $(LINK) -rpath $(libdir)
+BASE_LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK = $(BASE_LINK) -pie
+LINK_TEST = $(BASE_LINK) -no-install
+LINK_LIB = $(BASE_LINK) -rpath $(libdir)
+LINK_TEST_LIB = $(BASE_LINK)
# special link rule for mod_dav_svn
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
--- subversion-1.4.0/build/generator/gen_base.py.pie
+++ subversion-1.4.0/build/generator/gen_base.py
@@ -411,6 +411,9 @@
@@ -475,7 +475,7 @@ type = swig_lib
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
install = swig-rb-lib
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
--- subversion-1.5.0/build/generator/gen_base.py.pie
+++ subversion-1.5.0/build/generator/gen_base.py
@@ -411,6 +411,9 @@ class TargetExe(TargetLinked):
self.manpages = options.get('manpages', '')
self.testing = options.get('testing')
@ -56,7 +30,7 @@ object built with -pie.
def add_dependencies(self):
TargetLinked.add_dependencies(self)
@@ -453,8 +456,11 @@
@@ -453,8 +456,11 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = string.split(options.get('msvc-export', ''))
@ -70,3 +44,41 @@ object built with -pie.
class TargetApacheMod(TargetLib):
--- subversion-1.5.0/Makefile.in.pie
+++ subversion-1.5.0/Makefile.in
@@ -2,7 +2,7 @@
# Makefile.in: template Makefile for Subversion
#
# ====================================================================
-# Copyright (c) 2000-2006 CollabNet. All rights reserved.
+# Copyright (c) 2000-2006, 2008 CollabNet. All rights reserved.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -150,9 +150,10 @@ CXXFLAGS = @CXXFLAGS@ $(EXTRA_CXXFLAGS)
CPPFLAGS = @CPPFLAGS@ $(EXTRA_CPPFLAGS)
LDFLAGS = @LDFLAGS@ $(EXTRA_LDFLAGS)
-COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+BASE_COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+COMPILE = $(BASE_COMPILE) -fpie
COMPILE_CXX = $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDES)
-LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE)
+LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(BASE_COMPILE)
# special compilation for files destined for mod_dav_svn
COMPILE_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(APACHE_INCLUDES) $(INCLUDES) -o $@ -c
@@ -167,8 +168,11 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
-LINK_LIB = $(LINK) -rpath $(libdir)
+BASE_LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK = $(BASE_LINK) -pie
+LINK_TEST = $(BASE_LINK) -no-install
+LINK_LIB = $(BASE_LINK) -rpath $(libdir)
+LINK_TEST_LIB = $(BASE_LINK)
# special link rule for mod_dav_svn
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)

View File

@ -1,5 +1,5 @@
# set to zero to avoid running test suite
%define make_check 0
%define make_check 1
%define with_java 1
@ -14,8 +14,8 @@
Summary: Modern Version Control System designed to replace CVS
Name: subversion
Version: 1.4.6
Release: 7
Version: 1.5.0
Release: 2
License: ASL 1.1
Group: Development/Tools
URL: http://subversion.tigris.org/
@ -25,11 +25,8 @@ Source3: filter-requires.sh
Source4: http://www.xsteve.at/prg/emacs/psvn.el
Patch2: subversion-0.20.1-deplibs.patch
Patch3: subversion-0.31.0-rpath.patch
Patch6: subversion-1.0.3-pie.patch
Patch6: subversion-1.5.0-pie.patch
Patch7: subversion-1.1.3-java.patch
Patch8: subversion-1.4.4-macropen.patch
Patch9: subversion-1.4.4-swig1333.patch
Patch10: subversion-1.4.6-javadir.patch
BuildRequires: autoconf, libtool, python, python-devel, texinfo, which
BuildRequires: db4-devel >= 4.1.25, swig >= 1.3.24, gettext
BuildRequires: apr-devel >= 0.9.7, apr-util-devel >= 0.9.7
@ -111,12 +108,10 @@ This package includes the Ruby bindings to the Subversion libraries.
%if %{with_java}
%patch7 -p1 -b .java
%endif
%patch8 -p1 -b .macropen
%patch9 -p1 -b .swig133
%patch10 -p1 -b .javadir
%build
./autogen.sh
# Regenerate after patches to build.conf et al
autoheader && autoconf && ./gen-make.py --reload
# fix shebang lines, #111498
perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
@ -133,12 +128,12 @@ export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
--with-ruby-sitedir=%{ruby_sitearch} \
--with-apxs=%{_sbindir}/apxs --disable-mod-activation \
--disable-static --disable-neon-version-check
# 1.3.0 tarball ships with generated swig sources
make extraclean-swig-headers
make %{?_smp_mflags} all
make swig-py swig-py-lib %{swigdirs}
make swig-pl swig-pl-lib swig-rb swig-rb-lib
%if %{with_java}
# javahl-javah does not parallel-make with javahl
make javahl-java javahl-javah
make %{?_smp_mflags} javahl
%endif
@ -278,6 +273,9 @@ rm -rf ${RPM_BUILD_ROOT}
%endif
%changelog
* Thu Jun 26 2008 Joe Orton <jorton@redhat.com> 1.5.0-2
- update to 1.5.0
* Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.6-7
- tests are randomly failing, unrelated to new perl, disabled tests

View File

@ -1 +1 @@
subversion-1.4.6.tar.gz
subversion-1.5.0.tar.gz