Revert unapproved commits

All gcc-11 false positive diagnostics must be fixed in gcc itself,
please don't push gcc bugs to innocent users.

This reverts the following commits:
5cf517f608 (Work around gcc-11 false positive diagnostic)
e4ee13ea3d (Work around more gcc-11 false positive diagnostics)
This commit is contained in:
Dmitry V. Levin 2020-12-11 08:00:00 +00:00
parent e4ee13ea3d
commit a2e76d2cbe
2 changed files with 1 additions and 57 deletions

View File

@ -1,42 +0,0 @@
diff --git a/tests/nlattr_tcamsg.c b/tests/nlattr_tcamsg.c
index e25e32a..d23715c 100644
--- a/tests/nlattr_tcamsg.c
+++ b/tests/nlattr_tcamsg.c
@@ -33,6 +33,8 @@ enum { TCA_ACT_USED_HW_STATS = 9 };
static void
init_tcamsg(struct nlmsghdr *const nlh, const unsigned int msg_len)
{
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Wstringop-overflow"
SET_STRUCT(struct nlmsghdr, nlh,
.nlmsg_len = msg_len,
.nlmsg_type = RTM_GETACTION,
@@ -43,6 +45,7 @@ init_tcamsg(struct nlmsghdr *const nlh, const unsigned int msg_len)
SET_STRUCT(struct tcamsg, msg,
.tca_family = AF_INET
);
+#pragma GCC diagnostic pop
}
static void
diff --git a/mmsghdr.c b/mmsghdr.c
index 3fede19..5db35d8 100644
--- a/mmsghdr.c
+++ b/mmsghdr.c
@@ -78,6 +78,8 @@ static void
save_mmsgvec_namelen(struct tcb *const tcp, kernel_ulong_t addr,
unsigned int len, const char *const timeout)
{
+#pragma GCC diagnostic push
+#pragma GCC diagnostic ignored "-Warray-bounds"
if (len > IOV_MAX)
len = IOV_MAX;
@@ -99,6 +101,7 @@ save_mmsgvec_namelen(struct tcb *const tcp, kernel_ulong_t addr,
data->count = i;
set_tcb_priv_data(tcp, data, free_mmsgvec_data);
+#pragma GCC diagnostic pop
}
static void

View File

@ -1,7 +1,7 @@
Summary: Tracks and displays system calls associated with a running process
Name: strace
Version: 5.9
Release: 3%{?dist}
Release: 2%{?dist}
# The test suite is GPLv2+, all the rest is LGPLv2.1+.
License: LGPL-2.1+ and GPL-2.0+
# Some distros require Group tag to be present,
@ -14,7 +14,6 @@ Group: Development%{?suse_version:/Tools}/Debuggers
URL: https://strace.io
%if 0%{?fedora} >= 12 || 0%{?centos} >= 6 || 0%{?rhel} >= 6 || 0%{?suse_version} >= 1200
Source: https://strace.io/files/%{version}/strace-%{version}.tar.xz
Patch0: gcc-11.patch
Patch1: 0001-noinline.patch
Patch2: 0002-ipc-xfail.patch
Patch3: 0003-tests-update-semtimedop-test.patch
@ -62,7 +61,6 @@ received by a process.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
@ -100,12 +98,6 @@ done
wait
%check
# The tests are riddled with an idiom that triggers a false positives
# from gcc-11. Out of bounds issues in the testsuite are not
# particularly important, so we just make them non-fatal
sed -i "s/-Werror$/-Werror -Wno-error=array-bounds -Wno-error=stringop-overread/" tests/Makefile
sed -i "s/-Werror$/-Werror -Wno-error=array-bounds -Wno-error=stringop-overread/" tests-m32/Makefile
sed -i "s/-Werror$/-Werror -Wno-error=array-bounds -Wno-error=stringop-overread/" tests-mx32/Makefile
%{buildroot}%{_bindir}/strace -V
%make_build -k check VERBOSE=1
echo 'BEGIN OF TEST SUITE INFORMATION'
@ -122,9 +114,6 @@ echo 'END OF TEST SUITE INFORMATION'
%{_mandir}/man1/*
%changelog
* Wed Oct 21 2020 Eugene Syromyatnikov <esyr@redhat.com> - 5.9-3
- Work around more gcc-11 false positive diagnostics
* Wed Oct 21 2020 Eugene Syromyatnikov <esyr@redhat.com> - 5.9-2
- Mark even more tests as XFAIL so the build succeedes
(references: #1886468, #1886480).
@ -132,9 +121,6 @@ echo 'END OF TEST SUITE INFORMATION'
* Mon Oct 05 2020 Eugene Syromyatnikov <esyr@redhat.com> - 5.9-1
- v5.8 -> v5.9 (resolves: #1035433).
* Wed Aug 19 2020 Jeff Law <law@redhat.com> - 5.8-2
- Work around gcc-11 false positive diagnostic
* Thu Aug 06 2020 Dmitry V. Levin <ldv@altlinux.org> - 5.8-1
- v5.7 -> v5.8.