Update to recent git snapshot.

This commit is contained in:
Jerry James 2016-02-20 20:17:01 -07:00
parent 6d10a40e68
commit 839df2385b
4 changed files with 43 additions and 11 deletions

2
.gitignore vendored
View File

@ -1,2 +1,2 @@
/stp-stp-44de620.tar.gz
/stp-stp-5405af4.tar.gz
/stp-stp-3785148.tar.gz

View File

@ -1 +1 @@
9cfefa8cda293105506e5a8f3ed7c6b2 stp-stp-5405af4.tar.gz
cbbfa73c2d4218b70a1b7b36934e62ec stp-stp-3785148.tar.gz

29
stp-format.patch Normal file
View File

@ -0,0 +1,29 @@
--- tools/rewrite_rule_gen/rewrite_rule_gen.cpp.orig 2015-11-22 12:32:02.000000000 -0700
+++ tools/rewrite_rule_gen/rewrite_rule_gen.cpp 2016-02-20 20:08:02.920074762 -0700
@@ -1228,7 +1228,7 @@
for (size_t i = 0; i < n.Degree(); i++)
{
char t[1000];
- sprintf(t, "%s[%d]", current.c_str(), i);
+ sprintf(t, "%s[%zu]", current.c_str(), i);
string s(t);
rule_to_string(n[i], names, s, sofar);
}
@@ -1247,7 +1247,7 @@
for (size_t i = 0; i < n.Degree(); i++)
{
char t[1000];
- sprintf(t, "%s[%d]", current.c_str(), i);
+ sprintf(t, "%s[%zu]", current.c_str(), i);
string s(t);
string r = containsNode(n[i], hunting, s);
if (r != "")
@@ -1477,7 +1477,7 @@
for (size_t i = 0; i < n.Degree(); i++)
{
char t[1000];
- sprintf(t, "%s[%d]", current.c_str(), i);
+ sprintf(t, "%s[%zu]", current.c_str(), i);
string s(t);
visit_all(n[i], visited, s);
}

View File

@ -1,18 +1,20 @@
# Upstream occasionally releases a git snapshot, but no "regular" releases
# since the 0.1 release.
%global gitdate 20150904
%global gittag 5405af464b79800b49a14f3151f082ff4ad714ba
%global gitdate 20151122
%global gittag 3785148da15919de445e476a6f20b06c881cf50c
%global shorttag %(cut -b -7 <<< %{gittag})
%global user stp
Name: stp
Version: 2.1.0
Release: 3.%{gitdate}git.%{shorttag}%{?dist}
Version: 2.1.2
Release: 1.%{gitdate}git.%{shorttag}%{?dist}
Summary: Constraint solver/decision procedure
License: MIT
URL: http://stp.github.io/
Source0: https://github.com/%{user}/%{name}/tarball/%{gittag}/%{user}-%{name}-%{shorttag}.tar.gz
# Fix some format specifier problems
Patch0: %{name}-format.patch
BuildRequires: bison
BuildRequires: boost-devel
@ -63,12 +65,10 @@ Python 2 interface to STP.
%prep
%setup -q -n %{user}-%{name}-%{shorttag}
%patch0
# We do not want to know about the order of member initializers, and add the
# minisat include directory
sed -e "s/-Wno-deprecated/-Wno-reorder/" \
-e 's,\${PROJECT_SOURCE_DIR}/lib/Sat,&\n %{_includedir}/minisat,' \
-i CMakeLists.txt
# We do not want to know about the order of member initializers
sed -i "s/-Wno-deprecated/-Wno-reorder/" CMakeLists.txt
# Prevent a clash between minisat and cryptominisat4 definitions
sed '/SATSolver.h/a#undef var_Undef\n#undef l_True\n#undef l_False\n#undef l_Undef' \
@ -109,6 +109,9 @@ fi
%{python2_sitelib}/%{name}/
%changelog
* Sat Feb 20 2016 Jerry James <loganjerry@gmail.com> - 2.1.2-1.20151122git.3785148
- Update to recent git snapshot
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-3.20150904git.5405af4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild