Update to recent git snapshot.

Drop upstreamed -undefined patch.
This commit is contained in:
Jerry James 2014-06-18 17:27:24 -06:00
parent 5094447754
commit 31e34f55e7
6 changed files with 82 additions and 1135 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/stp-stp-f8a392d.tar.gz
/stp-stp-44de620.tar.gz

View File

@ -1 +1 @@
2ec158d56d2189d07aa09e3e05c88ca2 stp-stp-f8a392d.tar.gz
3744bde4e5a1d5108506adf1c929563d stp-stp-44de620.tar.gz

View File

@ -1,16 +1,16 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc5bb76..169c064 100644
index a43eb68..c0db102 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,7 @@ endmacro()
@@ -109,6 +109,7 @@ endmacro()
if(BUILD_SHARED_LIBS)
message(STATUS "Building shared library currently broken due to mix of C++/C code")
add_cxx_flag_if_supported("-fPIC")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
endif()
check_cxx_compiler_flag("-std=gnu++11" HAVE_FLAG_STD_GNUPP11)
@@ -179,6 +180,7 @@ include_directories(${Boost_INCLUDE_DIRS})
check_cxx_compiler_flag("-std=gnu++11" HAVE_FLAG_STD_GNUCPP11)
@@ -219,6 +220,7 @@ include_directories(${Boost_INCLUDE_DIRS})
find_package(BISON REQUIRED)
find_package(FLEX REQUIRED)
@ -92,7 +92,7 @@ index 191711e..9a44acd 100644
class RunTimes : boost::noncopyable
{
diff --git a/src/libstp/CMakeLists.txt b/src/libstp/CMakeLists.txt
index eabc0d6..8cc3bc7 100644
index 8ad9ccb..045b8ac 100644
--- a/src/libstp/CMakeLists.txt
+++ b/src/libstp/CMakeLists.txt
@@ -13,7 +13,6 @@ set(stp_lib_targets
@ -103,7 +103,7 @@ index eabc0d6..8cc3bc7 100644
simplifier
constantbv
abc
@@ -58,7 +57,7 @@ set_target_properties(libstp PROPERTIES
@@ -74,7 +73,7 @@ endif()
# Clients of libstp that don't use CMake will have to link the Boost libraries
# in manually.
# -----------------------------------------------------------------------------
@ -122,7 +122,7 @@ index 4749a77..ffb169e 100644
add_library(sat OBJECT
diff --git a/src/sat/CryptoMinisat.cpp b/src/sat/CryptoMinisat.cpp
index 27f372d..93e9b85 100644
index 8646824..0d77ff5 100644
--- a/src/sat/CryptoMinisat.cpp
+++ b/src/sat/CryptoMinisat.cpp
@@ -7,15 +7,26 @@
@ -177,7 +177,7 @@ index 27f372d..93e9b85 100644
int CryptoMinisat::nVars()
diff --git a/src/sat/CryptoMinisat.h b/src/sat/CryptoMinisat.h
index 9c11c1d..50d55fc 100644
index 76e7a47..9ecb5b6 100644
--- a/src/sat/CryptoMinisat.h
+++ b/src/sat/CryptoMinisat.h
@@ -6,16 +6,13 @@
@ -201,7 +201,7 @@ index 9c11c1d..50d55fc 100644
public:
CryptoMinisat();
diff --git a/tests/api/C/CMakeLists.txt b/tests/api/C/CMakeLists.txt
index 99c1478..2a490ff 100644
index dcdcc3d..e0146a8 100644
--- a/tests/api/C/CMakeLists.txt
+++ b/tests/api/C/CMakeLists.txt
@@ -1,4 +1,6 @@

View File

@ -1,80 +0,0 @@
diff --git a/src/extlib-abc/aig/aig/aigPart.c b/src/extlib-abc/aig/aig/aigPart.c
index a4cc116..c486a11 100644
--- a/src/extlib-abc/aig/aig/aigPart.c
+++ b/src/extlib-abc/aig/aig/aigPart.c
@@ -871,10 +871,6 @@ Vec_Ptr_t * Aig_ManMiterPartitioned( Aig_Man_t * p1, Aig_Man_t * p2, int nPartSi
***********************************************************************/
Aig_Man_t * Aig_ManChoicePartitioned( Vec_Ptr_t * vAigs, int nPartSize )
{
- extern int Cmd_CommandExecute( void * pAbc, char * sCommand );
- extern void * Abc_FrameGetGlobalFrame();
- extern Aig_Man_t * Fra_FraigChoice( Aig_Man_t * pManAig, int nConfMax );
-
Vec_Ptr_t * vOutsTotal, * vOuts;
Aig_Man_t * pAigTotal, * pAigPart, * pAig;
Vec_Int_t * vPart, * vPartSupp;
@@ -898,8 +894,6 @@ Aig_Man_t * Aig_ManChoicePartitioned( Vec_Ptr_t * vAigs, int nPartSize )
Aig_ManForEachPi( pAig, pObj, k )
pObj->pNext = (Aig_Obj_t *)(long)k;
- Cmd_CommandExecute( Abc_FrameGetGlobalFrame(), "unset progressbar" );
-
// create the total fraiged AIG
vPartSupp = Vec_IntAlloc( 100 ); // maps part PI num into total PI num
Vec_PtrForEachEntry( vParts, vPart, i )
@@ -936,7 +930,7 @@ Aig_Man_t * Aig_ManChoicePartitioned( Vec_Ptr_t * vAigs, int nPartSize )
i+1, Vec_PtrSize(vParts), Aig_ManPiNum(pAigPart), Aig_ManPoNum(pAigPart),
Aig_ManNodeNum(pAigPart), Aig_ManLevelNum(pAigPart) );
// compute equivalence classes (to be stored in pNew->pReprs)
- pAig = Fra_FraigChoice( pAigPart, 1000 );
+ pAig = NULL;
Aig_ManStop( pAig );
// reset the pData pointers
Aig_ManForEachObj( pAigPart, pObj, k )
@@ -951,8 +945,6 @@ Aig_Man_t * Aig_ManChoicePartitioned( Vec_Ptr_t * vAigs, int nPartSize )
Vec_VecFree( (Vec_Vec_t *)vParts );
Vec_IntFree( vPartSupp );
- Cmd_CommandExecute( Abc_FrameGetGlobalFrame(), "set progressbar" );
-
// clear the PI numbers
Vec_PtrForEachEntry( vAigs, pAig, i )
Aig_ManForEachPi( pAig, pObj, k )
diff --git a/src/extlib-abc/aig/aig/aigShow.c b/src/extlib-abc/aig/aig/aigShow.c
index a88f493..34b26ef 100644
--- a/src/extlib-abc/aig/aig/aigShow.c
+++ b/src/extlib-abc/aig/aig/aigShow.c
@@ -328,7 +328,6 @@ void Aig_WriteDotAig( Aig_Man_t * pMan, char * pFileName, int fHaig, Vec_Ptr_t *
***********************************************************************/
void Aig_ManShow( Aig_Man_t * pMan, int fHaig, Vec_Ptr_t * vBold )
{
- extern void Abc_ShowFile( char * FileNameDot );
static int Counter = 0;
char FileNameDot[200];
FILE * pFile;
@@ -344,8 +343,6 @@ void Aig_ManShow( Aig_Man_t * pMan, int fHaig, Vec_Ptr_t * vBold )
fclose( pFile );
// generate the file
Aig_WriteDotAig( pMan, FileNameDot, fHaig, vBold );
- // visualize the file
- Abc_ShowFile( FileNameDot );
}
diff --git a/src/extlib-abc/aig/kit/kitGraph.c b/src/extlib-abc/aig/kit/kitGraph.c
index 1ae5891..f6ea2ca 100644
--- a/src/extlib-abc/aig/kit/kitGraph.c
+++ b/src/extlib-abc/aig/kit/kitGraph.c
@@ -20,6 +20,12 @@
#include "kit.h"
+Kit_Graph_t *Kit_SopFactor( Vec_Int_t * vCover, int fCompl, int nVars,
+ Vec_Int_t * vMemory )
+{
+ return NULL;
+}
+
////////////////////////////////////////////////////////////////////////
/// DECLARATIONS ///
////////////////////////////////////////////////////////////////////////

File diff suppressed because it is too large Load Diff

View File

@ -1,13 +1,13 @@
# Upstream occasionally releases a subversion snapshot, but no "regular"
# releases since the 0.1 release.
%global gitdate 20140402
%global gittag f8a392dea3e6942897e2213e13f23cf99d323ef4
%global gitdate 20140619
%global gittag 44de620db195122e812e81940c8edef947c18765
%global shorttag %(cut -b -7 <<< %{gittag})
%global user stp
Name: stp
Version: 0.1
Release: 22.%{gitdate}git.%{shorttag}%{?dist}
Release: 23.%{gitdate}git.%{shorttag}%{?dist}
Summary: Constraint solver/decision procedure
Group: Applications/Engineering
@ -20,8 +20,6 @@ Patch0: %{name}-unbundle.patch
# This patch has not yet been sent upstream. Fix a bunch of compiler warnings
# that may indicate miscompiled code.
Patch1: %{name}-warning.patch
# This patch has not yet been sent upstream. Eliminate undefined symbols.
Patch2: %{name}-undefined.patch
BuildRequires: bison
BuildRequires: boost-devel
@ -62,7 +60,6 @@ or automated prover). Provides a static library.
%setup -q -n %{user}-%{name}-%{shorttag}
%patch0 -p1
%patch1 -p1
%patch2 -p1
# Make sure nothing uses the shipped cryptominisat sources
rm -fr src/sat/cryptominisat2
@ -71,18 +68,18 @@ rm -fr src/sat/cryptominisat2
sed -i "s/-Wno-deprecated/& -Wno-reorder/" CMakeLists.txt
%build
%cmake
%cmake -DALSO_BUILD_STATIC_LIB=0
make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot}
# Fix up the libdir install on 64-bit targets
if [ %{__isa_bits} = "64" ]; then
mkdir %{buildroot}%{_libdir}
mv %{buildroot}%{_prefix}/lib/cmake %{buildroot}%{_libdir}
mv %{buildroot}%{_prefix}/lib/libstp.so %{buildroot}%{_libdir}
fi
%if %{__isa_bits} == 64
mkdir %{buildroot}%{_libdir}
mv %{buildroot}%{_prefix}/lib/cmake %{buildroot}%{_libdir}
mv %{buildroot}%{_prefix}/lib/libstp.so %{buildroot}%{_libdir}
%endif
%files
%{_bindir}/*
@ -94,6 +91,10 @@ fi
%{_libdir}/cmake/STP/
%changelog
* Wed Jun 18 2014 Jerry James <loganjerry@gmail.com> - 0.1-23.20140619git.44de620
- Update to recent git snapshot
- Drop upstreamed -undefined patch
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-22.20140402git.f8a392d
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild