Add -private-libs patch to fix bz 1981466.

This commit is contained in:
Jerry James 2021-07-14 09:17:18 -06:00
parent 66092f3f55
commit 10727056b6
2 changed files with 25 additions and 1 deletions

18
stp-private-libs.patch Normal file
View File

@ -0,0 +1,18 @@
--- lib/CMakeLists.txt.orig 2019-03-02 07:26:01.000000000 -0700
+++ lib/CMakeLists.txt 2021-07-14 09:03:32.415946180 -0600
@@ -139,9 +139,15 @@ if (USE_RISS)
${stp_link_libs} -lriss-coprocessor)
endif()
+if (STATICCOMPILE)
target_link_libraries(stp
LINK_PUBLIC ${stp_link_libs}
)
+else()
+target_link_libraries(stp
+ LINK_PRIVATE ${stp_link_libs}
+)
+endif()
install(TARGETS stp
EXPORT ${STP_EXPORT_NAME}

View File

@ -1,6 +1,6 @@
Name: stp
Version: 2.3.3
Release: 15%{?dist}
Release: 16%{?dist}
Summary: Constraint solver/decision procedure
License: MIT
@ -8,6 +8,9 @@ URL: http://stp.github.io/
Source0: https://github.com/stp/stp/archive/%{version}/%{name}-%{version}.tar.gz
# Fix some format specifier problems
Patch0: %{name}-format.patch
# Do not declare cryptominisat and minisat as public libs
# See https://bugzilla.redhat.com/show_bug.cgi?id=1981466
Patch1: %{name}-private-libs.patch
BuildRequires: bison
BuildRequires: boost-devel
@ -113,6 +116,9 @@ mv %{buildroot}%{_prefix}/man %{buildroot}%{_datadir}/man
%{python3_sitelib}/%{name}/
%changelog
* Wed Jul 14 2021 Jerry James <loganjerry@gmail.com> - 2.3.3-16
- Add -private-libs patch to fix bz 1981466
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.3.3-15
- Rebuilt for Python 3.10