Upstream update
This commit is contained in:
parent
24ba6f186a
commit
c31b80f01c
2
sources
2
sources
@ -1 +1 @@
|
||||
805c0e9614e25e455ae2fa081da6e0f9 stdair-1.00.2.tar.bz2
|
||||
SHA512 (stdair-1.00.5.tar.bz2) = 3299da94691a6eb20dfe5996a64608370710a9e8cbcc0929f4c7255cd1c1fab8839dc08d6237839c287d121c29c82d00089374a0c1dad26825e23fb897ae87da
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 0462594a6b3c23b96ec3a90d58f7c9db3f721162 Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Wakely <github@kayari.org>
|
||||
Date: Sat, 29 Aug 2015 13:38:07 +0100
|
||||
Subject: [PATCH] Fix for Boost 1.59.0 compatibility.
|
||||
|
||||
Boost.Test has major changes in 1.59.0 including renaming the XML enumerator to OF_XML.
|
||||
---
|
||||
test/stdair/StandardAirlineITTestSuite.cpp | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/test/stdair/StandardAirlineITTestSuite.cpp b/test/stdair/StandardAirlineITTestSuite.cpp
|
||||
index ce04aa5..892d922 100644
|
||||
--- a/test/stdair/StandardAirlineITTestSuite.cpp
|
||||
+++ b/test/stdair/StandardAirlineITTestSuite.cpp
|
||||
@@ -61,7 +61,11 @@ struct UnitTestConfig {
|
||||
/** Constructor. */
|
||||
UnitTestConfig() {
|
||||
boost_utf::unit_test_log.set_stream (utfReportStream);
|
||||
+#if BOOST_VERSION >= 105900
|
||||
+ boost_utf::unit_test_log.set_format (boost_utf::OF_XML);
|
||||
+#else
|
||||
boost_utf::unit_test_log.set_format (boost_utf::XML);
|
||||
+#endif
|
||||
boost_utf::unit_test_log.set_threshold_level (boost_utf::log_test_units);
|
||||
// boost_utf::unit_test_log.set_threshold_level (boost_utf::log_successful_tests);
|
||||
}
|
@ -1,66 +0,0 @@
|
||||
diff --git a/stdair/bom/FlightDate.hpp b/stdair/bom/FlightDate.hpp
|
||||
index cf031fd..f63d0b4 100644
|
||||
--- a/stdair/bom/FlightDate.hpp
|
||||
+++ b/stdair/bom/FlightDate.hpp
|
||||
@@ -194,6 +194,10 @@ namespace stdair {
|
||||
/**
|
||||
* Destructor.
|
||||
*/
|
||||
+ // (Bad) work-around for an issue with Boost 1.63 Serialization
|
||||
+#if BOOST_VERSION == 106300
|
||||
+ public:
|
||||
+#endif
|
||||
virtual ~FlightDate();
|
||||
|
||||
private:
|
||||
diff --git a/stdair/bom/Inventory.hpp b/stdair/bom/Inventory.hpp
|
||||
index 76253bd..f97a57b 100644
|
||||
--- a/stdair/bom/Inventory.hpp
|
||||
+++ b/stdair/bom/Inventory.hpp
|
||||
@@ -180,10 +180,15 @@ namespace stdair {
|
||||
* Constructor.
|
||||
*/
|
||||
Inventory (const Key_T&);
|
||||
+
|
||||
/**
|
||||
* Destructor.
|
||||
*/
|
||||
- ~Inventory();
|
||||
+ // (Bad) work-around for an issue with Boost 1.63 Serialization
|
||||
+#if BOOST_VERSION == 106300
|
||||
+ public:
|
||||
+#endif
|
||||
+ virtual ~Inventory();
|
||||
|
||||
private:
|
||||
/**
|
||||
diff --git a/stdair/bom/SegmentCabin.hpp b/stdair/bom/SegmentCabin.hpp
|
||||
index acf007e..62fa195 100644
|
||||
--- a/stdair/bom/SegmentCabin.hpp
|
||||
+++ b/stdair/bom/SegmentCabin.hpp
|
||||
@@ -278,6 +278,10 @@ namespace stdair {
|
||||
/**
|
||||
* Destructor.
|
||||
*/
|
||||
+ // (Bad) work-around for an issue with Boost 1.63 Serialization
|
||||
+#if BOOST_VERSION == 106300
|
||||
+ public:
|
||||
+#endif
|
||||
virtual ~SegmentCabin();
|
||||
|
||||
private:
|
||||
diff --git a/stdair/bom/SegmentDate.hpp b/stdair/bom/SegmentDate.hpp
|
||||
index 4220348..b7d1ca3 100644
|
||||
--- a/stdair/bom/SegmentDate.hpp
|
||||
+++ b/stdair/bom/SegmentDate.hpp
|
||||
@@ -285,6 +285,10 @@ namespace stdair {
|
||||
/**
|
||||
* Destructor.
|
||||
*/
|
||||
+ // (Bad) work-around for an issue with Boost 1.63 Serialization
|
||||
+#if BOOST_VERSION == 106300
|
||||
+ public:
|
||||
+#endif
|
||||
virtual ~SegmentDate();
|
||||
|
||||
private:
|
12
stdair.spec
12
stdair.spec
@ -2,8 +2,8 @@
|
||||
%global mydocs __tmp_docdir
|
||||
#
|
||||
Name: stdair
|
||||
Version: 1.00.2
|
||||
Release: 12%{?dist}
|
||||
Version: 1.00.5
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: C++ Standard Airline IT Object Library
|
||||
|
||||
@ -11,8 +11,6 @@ Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://%{name}.sourceforge.net
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
||||
Patch0: stdair-boost-1.59-log-format.patch
|
||||
Patch1: stdair-fix-protected-pointer-with-boost-archive.patch
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
BuildRequires: cmake, python-devel
|
||||
@ -61,9 +59,6 @@ online (http://%{name}.org).
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
%build
|
||||
%cmake .
|
||||
@ -149,6 +144,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Feb 26 2017 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.00.5-1
|
||||
- Upstream update
|
||||
|
||||
* Sat Feb 25 2017 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.00.2-12
|
||||
- Attempt to fix the FTBFS issue related to new Boost 1.63 serialization
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user