0a590e2830
Removed and obsoleted stb_perlin-devel due to possible patents Updated stb_truetype to 1.26 Bug fixes in stb_image (no new version number)
114 lines
3.6 KiB
Diff
114 lines
3.6 KiB
Diff
From f1fc796075dc6a3c41e67f0bb8a67585ff892435 Mon Sep 17 00:00:00 2001
|
|
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
|
Date: Wed, 8 Sep 2021 19:20:24 -0400
|
|
Subject: [PATCH] Remove stb_perlin from tests
|
|
|
|
---
|
|
tests/Makefile | 2 +-
|
|
tests/stb.dsp | 8 --------
|
|
tests/test.sbm | 1 -
|
|
tests/test_c_compilation.c | 3 +--
|
|
tests/test_cpp_compilation.cpp | 2 --
|
|
tests/test_perlin.c | 1 -
|
|
6 files changed, 2 insertions(+), 15 deletions(-)
|
|
delete mode 100644 tests/test_perlin.c
|
|
|
|
diff --git a/tests/Makefile b/tests/Makefile
|
|
index 1782ea6723..608e40fbcc 100644
|
|
--- a/tests/Makefile
|
|
+++ b/tests/Makefile
|
|
@@ -6,7 +6,7 @@ CPPFLAGS = -Wno-write-strings -DSTB_DIVIDE_TEST
|
|
#CFLAGS += -O -fsanitize=address
|
|
|
|
all:
|
|
- $(CC) $(INCLUDES) $(CFLAGS) ../stb_vorbis.c test_c_compilation.c test_c_lexer.c test_dxt.c test_easyfont.c test_image.c test_image_write.c test_perlin.c test_sprintf.c test_truetype.c test_voxel.c -lm
|
|
+ $(CC) $(INCLUDES) $(CFLAGS) ../stb_vorbis.c test_c_compilation.c test_c_lexer.c test_dxt.c test_easyfont.c test_image.c test_image_write.c test_sprintf.c test_truetype.c test_voxel.c -lm
|
|
$(CC) $(INCLUDES) $(CPPFLAGS) -std=c++0x test_cpp_compilation.cpp -lm -lstdc++
|
|
$(CC) $(INCLUDES) $(CFLAGS) -DIWT_TEST image_write_test.c -lm -o image_write_test
|
|
$(CC) $(INCLUDES) $(CFLAGS) fuzz_main.c stbi_read_fuzzer.c -lm -o image_fuzzer
|
|
diff --git a/tests/stb.dsp b/tests/stb.dsp
|
|
index ba13ba1371..af16faf354 100644
|
|
--- a/tests/stb.dsp
|
|
+++ b/tests/stb.dsp
|
|
@@ -150,10 +150,6 @@ SOURCE=..\stb_malloc.h
|
|
# End Source File
|
|
# Begin Source File
|
|
|
|
-SOURCE=..\stb_perlin.h
|
|
-# End Source File
|
|
-# Begin Source File
|
|
-
|
|
SOURCE=..\stb_rect_pack.h
|
|
# End Source File
|
|
# Begin Source File
|
|
@@ -218,10 +214,6 @@ SOURCE=.\test_packer.c
|
|
# End Source File
|
|
# Begin Source File
|
|
|
|
-SOURCE=.\test_perlin.c
|
|
-# End Source File
|
|
-# Begin Source File
|
|
-
|
|
SOURCE=.\test_sprintf.c
|
|
# End Source File
|
|
# Begin Source File
|
|
diff --git a/tests/test.sbm b/tests/test.sbm
|
|
index 9465605846..f1518672f0 100644
|
|
--- a/tests/test.sbm
|
|
+++ b/tests/test.sbm
|
|
@@ -53,7 +53,6 @@ main.c test_dxt.c
|
|
main.c test_easyfont.c
|
|
main.c test_image.c
|
|
main.c test_image_write.c
|
|
-main.c test_perlin.c
|
|
main.c test_sprintf.c
|
|
main.c test_vorbis.c ../stb_vorbis.c
|
|
main.c test_voxel.c
|
|
diff --git a/tests/test_c_compilation.c b/tests/test_c_compilation.c
|
|
index 11f60231e6..27be5d682c 100644
|
|
--- a/tests/test_c_compilation.c
|
|
+++ b/tests/test_c_compilation.c
|
|
@@ -17,7 +17,6 @@
|
|
#include "stb_herringbone_wang_tile.h"
|
|
#include "stb_image.h"
|
|
#include "stb_image_write.h"
|
|
-#include "stb_perlin.h"
|
|
#include "stb_c_lexer.h"
|
|
#include "stb_divide.h"
|
|
#include "stb_image_resize.h"
|
|
@@ -46,4 +45,4 @@ int quicktest(void)
|
|
char buffer[999];
|
|
stbsp_sprintf(buffer, "test%%test");
|
|
return 0;
|
|
-}
|
|
\ No newline at end of file
|
|
+}
|
|
diff --git a/tests/test_cpp_compilation.cpp b/tests/test_cpp_compilation.cpp
|
|
index fd8c5b6423..43ec5a2ba9 100644
|
|
--- a/tests/test_cpp_compilation.cpp
|
|
+++ b/tests/test_cpp_compilation.cpp
|
|
@@ -6,7 +6,6 @@
|
|
#include "stb_truetype.h"
|
|
#include "stb_image_write.h"
|
|
#include "stb_c_lexer.h"
|
|
-#include "stb_perlin.h"
|
|
#include "stb_dxt.h"
|
|
#include "stb_divide.h"
|
|
#include "stb_herringbone_wang_tile.h"
|
|
@@ -45,7 +44,6 @@ void my_free(void *) { }
|
|
#include "stb_rect_pack.h"
|
|
#include "stb_truetype.h"
|
|
#include "stb_image_write.h"
|
|
-#include "stb_perlin.h"
|
|
#include "stb_dxt.h"
|
|
#include "stb_divide.h"
|
|
#include "stb_herringbone_wang_tile.h"
|
|
diff --git a/tests/test_perlin.c b/tests/test_perlin.c
|
|
deleted file mode 100644
|
|
index de702c9bcc..0000000000
|
|
--- a/tests/test_perlin.c
|
|
+++ /dev/null
|
|
@@ -1 +0,0 @@
|
|
-#include "stb_perlin.h"
|
|
\ No newline at end of file
|