Update to 8b5f1f3
- The stb_perlin-devel subpackage has been restored, as upstream believes all relevant patents are now expired.
This commit is contained in:
parent
96db53602f
commit
466d39da71
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/stb-3a1174060a7dd4eb652d4e6854bc4cd98c159200.tar.gz
|
||||
/stb-c0c982601f40183e74d84a61237e968dca08380e.tar.gz
|
||||
/stb-af1a5bc352164740c1cc1354942b1c6b72eacb8a.tar.gz
|
||||
/stb-8b5f1f37b5b75829fc72d38e7b5d4bcbf8a26d55.tar.gz
|
||||
|
113
1204.patch
113
1204.patch
@ -1,113 +0,0 @@
|
||||
From f1fc796075dc6a3c41e67f0bb8a67585ff892435 Mon Sep 17 00:00:00 2001
|
||||
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
||||
Date: Wed, 8 Sep 2021 19:20:24 -0400
|
||||
Subject: [PATCH] Remove stb_perlin from tests
|
||||
|
||||
---
|
||||
tests/Makefile | 2 +-
|
||||
tests/stb.dsp | 8 --------
|
||||
tests/test.sbm | 1 -
|
||||
tests/test_c_compilation.c | 3 +--
|
||||
tests/test_cpp_compilation.cpp | 2 --
|
||||
tests/test_perlin.c | 1 -
|
||||
6 files changed, 2 insertions(+), 15 deletions(-)
|
||||
delete mode 100644 tests/test_perlin.c
|
||||
|
||||
diff --git a/tests/Makefile b/tests/Makefile
|
||||
index 1782ea6723..608e40fbcc 100644
|
||||
--- a/tests/Makefile
|
||||
+++ b/tests/Makefile
|
||||
@@ -6,7 +6,7 @@ CPPFLAGS = -Wno-write-strings -DSTB_DIVIDE_TEST
|
||||
#CFLAGS += -O -fsanitize=address
|
||||
|
||||
all:
|
||||
- $(CC) $(INCLUDES) $(CFLAGS) ../stb_vorbis.c test_c_compilation.c test_c_lexer.c test_dxt.c test_easyfont.c test_image.c test_image_write.c test_perlin.c test_sprintf.c test_truetype.c test_voxel.c -lm
|
||||
+ $(CC) $(INCLUDES) $(CFLAGS) ../stb_vorbis.c test_c_compilation.c test_c_lexer.c test_dxt.c test_easyfont.c test_image.c test_image_write.c test_sprintf.c test_truetype.c test_voxel.c -lm
|
||||
$(CC) $(INCLUDES) $(CPPFLAGS) -std=c++0x test_cpp_compilation.cpp -lm -lstdc++
|
||||
$(CC) $(INCLUDES) $(CFLAGS) -DIWT_TEST image_write_test.c -lm -o image_write_test
|
||||
$(CC) $(INCLUDES) $(CFLAGS) fuzz_main.c stbi_read_fuzzer.c -lm -o image_fuzzer
|
||||
diff --git a/tests/stb.dsp b/tests/stb.dsp
|
||||
index ba13ba1371..af16faf354 100644
|
||||
--- a/tests/stb.dsp
|
||||
+++ b/tests/stb.dsp
|
||||
@@ -150,10 +150,6 @@ SOURCE=..\stb_malloc.h
|
||||
# End Source File
|
||||
# Begin Source File
|
||||
|
||||
-SOURCE=..\stb_perlin.h
|
||||
-# End Source File
|
||||
-# Begin Source File
|
||||
-
|
||||
SOURCE=..\stb_rect_pack.h
|
||||
# End Source File
|
||||
# Begin Source File
|
||||
@@ -218,10 +214,6 @@ SOURCE=.\test_packer.c
|
||||
# End Source File
|
||||
# Begin Source File
|
||||
|
||||
-SOURCE=.\test_perlin.c
|
||||
-# End Source File
|
||||
-# Begin Source File
|
||||
-
|
||||
SOURCE=.\test_sprintf.c
|
||||
# End Source File
|
||||
# Begin Source File
|
||||
diff --git a/tests/test.sbm b/tests/test.sbm
|
||||
index 9465605846..f1518672f0 100644
|
||||
--- a/tests/test.sbm
|
||||
+++ b/tests/test.sbm
|
||||
@@ -53,7 +53,6 @@ main.c test_dxt.c
|
||||
main.c test_easyfont.c
|
||||
main.c test_image.c
|
||||
main.c test_image_write.c
|
||||
-main.c test_perlin.c
|
||||
main.c test_sprintf.c
|
||||
main.c test_vorbis.c ../stb_vorbis.c
|
||||
main.c test_voxel.c
|
||||
diff --git a/tests/test_c_compilation.c b/tests/test_c_compilation.c
|
||||
index 11f60231e6..27be5d682c 100644
|
||||
--- a/tests/test_c_compilation.c
|
||||
+++ b/tests/test_c_compilation.c
|
||||
@@ -17,7 +17,6 @@
|
||||
#include "stb_herringbone_wang_tile.h"
|
||||
#include "stb_image.h"
|
||||
#include "stb_image_write.h"
|
||||
-#include "stb_perlin.h"
|
||||
#include "stb_c_lexer.h"
|
||||
#include "stb_divide.h"
|
||||
#include "stb_image_resize.h"
|
||||
@@ -46,4 +45,4 @@ int quicktest(void)
|
||||
char buffer[999];
|
||||
stbsp_sprintf(buffer, "test%%test");
|
||||
return 0;
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
diff --git a/tests/test_cpp_compilation.cpp b/tests/test_cpp_compilation.cpp
|
||||
index fd8c5b6423..43ec5a2ba9 100644
|
||||
--- a/tests/test_cpp_compilation.cpp
|
||||
+++ b/tests/test_cpp_compilation.cpp
|
||||
@@ -6,7 +6,6 @@
|
||||
#include "stb_truetype.h"
|
||||
#include "stb_image_write.h"
|
||||
#include "stb_c_lexer.h"
|
||||
-#include "stb_perlin.h"
|
||||
#include "stb_dxt.h"
|
||||
#include "stb_divide.h"
|
||||
#include "stb_herringbone_wang_tile.h"
|
||||
@@ -45,7 +44,6 @@ void my_free(void *) { }
|
||||
#include "stb_rect_pack.h"
|
||||
#include "stb_truetype.h"
|
||||
#include "stb_image_write.h"
|
||||
-#include "stb_perlin.h"
|
||||
#include "stb_dxt.h"
|
||||
#include "stb_divide.h"
|
||||
#include "stb_herringbone_wang_tile.h"
|
||||
diff --git a/tests/test_perlin.c b/tests/test_perlin.c
|
||||
deleted file mode 100644
|
||||
index de702c9bcc..0000000000
|
||||
--- a/tests/test_perlin.c
|
||||
+++ /dev/null
|
||||
@@ -1 +0,0 @@
|
||||
-#include "stb_perlin.h"
|
||||
\ No newline at end of file
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (stb-af1a5bc352164740c1cc1354942b1c6b72eacb8a.tar.gz) = 5937baa1a9b7342ddc0e41c37ba0ea6b0c878f670a81b55bb124681e6b5e381fdc1d9557c96637e3ba082d6d968ed67a78b47f16aa5555c1c43394d1f9e57f2d
|
||||
SHA512 (stb-8b5f1f37b5b75829fc72d38e7b5d4bcbf8a26d55.tar.gz) = 76e0ed7536146aac71f89d6246235221c1dc0bd035ae4b33d496213acf5be95413cae4455a3f1419f84113320f7bd662dc50b47788cbdc8e7208bbbbcfd23f98
|
||||
|
36
stb.spec
36
stb.spec
@ -1,5 +1,5 @@
|
||||
%global commit af1a5bc352164740c1cc1354942b1c6b72eacb8a
|
||||
%global snapdate 20210910
|
||||
%global commit 8b5f1f37b5b75829fc72d38e7b5d4bcbf8a26d55
|
||||
%global snapdate 20220908
|
||||
|
||||
# We choose not to package the “stb_include” library (stb_include.h) because,
|
||||
# during the package review, it was observed that it follows coding practices
|
||||
@ -54,10 +54,6 @@ Patch: %{url}/pull/1196.patch
|
||||
# https://github.com/nothings/stb/pull/1198
|
||||
Patch: %{url}/pull/1198.patch
|
||||
|
||||
# Remove stb_perlin from tests
|
||||
# https://github.com/nothings/stb/pull/1198
|
||||
Patch: %{url}/pull/1204.patch
|
||||
|
||||
# Candidate fix for:
|
||||
# https://nvd.nist.gov/vuln/detail/CVE-2021-42715
|
||||
#
|
||||
@ -122,6 +118,7 @@ Patch: %{url}/pull/1297.patch
|
||||
%global stb_image_write_version 1.16
|
||||
%global stb_include_version 0.2
|
||||
%global stb_leakcheck_version 0.6
|
||||
%global stb_perlin_version 0.5
|
||||
%global stb_rect_pack_version 1.1
|
||||
%global stb_sprintf_version 1.10
|
||||
%global stb_textedit_version 1.14
|
||||
@ -178,6 +175,8 @@ Requires: stb_include-static = %{stb_include_version}%{snapinfo}-%{release
|
||||
%endif
|
||||
Requires: stb_leakcheck-devel%{?_isa} = %{stb_leakcheck_version}%{snapinfo}-%{release}
|
||||
Requires: stb_leakcheck-static = %{stb_leakcheck_version}%{snapinfo}-%{release}
|
||||
Requires: stb_perlin-devel%{?_isa} = %{stb_perlin_version}%{snapinfo}-%{release}
|
||||
Requires: stb_perlin-static = %{stb_perlin_version}%{snapinfo}-%{release}
|
||||
Requires: stb_rect_pack-devel%{?_isa} = %{stb_rect_pack_version}%{snapinfo}-%{release}
|
||||
Requires: stb_rect_pack-static = %{stb_rect_pack_version}%{snapinfo}-%{release}
|
||||
Requires: stb_sprintf-devel%{?_isa} = %{stb_sprintf_version}%{snapinfo}-%{release}
|
||||
@ -193,12 +192,6 @@ Requires: stb_vorbis-static = %{stb_vorbis_version}%{snapinfo}-%{release}
|
||||
Requires: stb_voxel_render-devel%{?_isa} = %{stb_voxel_render_version}%{snapinfo}-%{release}
|
||||
Requires: stb_voxel_render-static = %{stb_voxel_render_version}%{snapinfo}-%{release}
|
||||
|
||||
# Upstream removed the stb_perlin library in commit
|
||||
# 59e7dec3e8bb0a8d4050d03c2dc32cf71ffa87c6, asserting it was covered by
|
||||
# patents.
|
||||
Obsoletes: stb_perlin-devel < 0.5-0.5
|
||||
Obsoletes: stb_perlin-static < 0.5-0.5
|
||||
|
||||
%description devel
|
||||
The stb-devel package contains libraries and header files for developing
|
||||
applications that use stb.
|
||||
@ -398,6 +391,16 @@ Provides: stb_leakcheck-static = %{stb_leakcheck_version}%{snapinfo}-%{rel
|
||||
Quick and dirty malloc leak-checking.
|
||||
|
||||
|
||||
%package -n stb_perlin-devel
|
||||
Summary: Perlin noise
|
||||
Version: %{stb_perlin_version}%{snapinfo}
|
||||
|
||||
Provides: stb_perlin-static = %{stb_perlin_version}%{snapinfo}-%{release}
|
||||
|
||||
%description -n stb_perlin-devel
|
||||
Perlin noise
|
||||
|
||||
|
||||
%package -n stb_rect_pack-devel
|
||||
Summary: Rectangle packing
|
||||
Version: %{stb_rect_pack_version}%{snapinfo}
|
||||
@ -664,6 +667,7 @@ done <<'EOF'
|
||||
%{stb_image_write_version} stb_image_write.h
|
||||
%{stb_include_version} stb_include.h
|
||||
%{stb_leakcheck_version} stb_leakcheck.h
|
||||
%{stb_perlin_version} stb_perlin.h
|
||||
%{stb_rect_pack_version} stb_rect_pack.h
|
||||
%{stb_sprintf_version} stb_sprintf.h
|
||||
%{stb_textedit_version} stb_textedit.h
|
||||
@ -791,6 +795,14 @@ EOF
|
||||
%{_includedir}/stb_leakcheck.h
|
||||
|
||||
|
||||
%files -n stb_perlin-devel
|
||||
%license LICENSE
|
||||
# Directory has shared ownership across stb subpackages:
|
||||
%dir %{_includedir}/stb
|
||||
%{_includedir}/stb/stb_perlin.h
|
||||
%{_includedir}/stb_perlin.h
|
||||
|
||||
|
||||
%files -n stb_rect_pack-devel
|
||||
%license LICENSE
|
||||
# Directory has shared ownership across stb subpackages:
|
||||
|
Loading…
Reference in New Issue
Block a user