Update to c0c9826 (fix RHBZ#2002436)
Removed and obsoleted stb_perlin-devel due to possible patents Updated stb_truetype to 1.26 Bug fixes in stb_image (no new version number)
This commit is contained in:
parent
0c9099e004
commit
0a590e2830
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/stb-3a1174060a7dd4eb652d4e6854bc4cd98c159200.tar.gz
|
/stb-3a1174060a7dd4eb652d4e6854bc4cd98c159200.tar.gz
|
||||||
|
/stb-c0c982601f40183e74d84a61237e968dca08380e.tar.gz
|
||||||
|
113
1204.patch
Normal file
113
1204.patch
Normal file
@ -0,0 +1,113 @@
|
|||||||
|
From f1fc796075dc6a3c41e67f0bb8a67585ff892435 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
||||||
|
Date: Wed, 8 Sep 2021 19:20:24 -0400
|
||||||
|
Subject: [PATCH] Remove stb_perlin from tests
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/Makefile | 2 +-
|
||||||
|
tests/stb.dsp | 8 --------
|
||||||
|
tests/test.sbm | 1 -
|
||||||
|
tests/test_c_compilation.c | 3 +--
|
||||||
|
tests/test_cpp_compilation.cpp | 2 --
|
||||||
|
tests/test_perlin.c | 1 -
|
||||||
|
6 files changed, 2 insertions(+), 15 deletions(-)
|
||||||
|
delete mode 100644 tests/test_perlin.c
|
||||||
|
|
||||||
|
diff --git a/tests/Makefile b/tests/Makefile
|
||||||
|
index 1782ea6723..608e40fbcc 100644
|
||||||
|
--- a/tests/Makefile
|
||||||
|
+++ b/tests/Makefile
|
||||||
|
@@ -6,7 +6,7 @@ CPPFLAGS = -Wno-write-strings -DSTB_DIVIDE_TEST
|
||||||
|
#CFLAGS += -O -fsanitize=address
|
||||||
|
|
||||||
|
all:
|
||||||
|
- $(CC) $(INCLUDES) $(CFLAGS) ../stb_vorbis.c test_c_compilation.c test_c_lexer.c test_dxt.c test_easyfont.c test_image.c test_image_write.c test_perlin.c test_sprintf.c test_truetype.c test_voxel.c -lm
|
||||||
|
+ $(CC) $(INCLUDES) $(CFLAGS) ../stb_vorbis.c test_c_compilation.c test_c_lexer.c test_dxt.c test_easyfont.c test_image.c test_image_write.c test_sprintf.c test_truetype.c test_voxel.c -lm
|
||||||
|
$(CC) $(INCLUDES) $(CPPFLAGS) -std=c++0x test_cpp_compilation.cpp -lm -lstdc++
|
||||||
|
$(CC) $(INCLUDES) $(CFLAGS) -DIWT_TEST image_write_test.c -lm -o image_write_test
|
||||||
|
$(CC) $(INCLUDES) $(CFLAGS) fuzz_main.c stbi_read_fuzzer.c -lm -o image_fuzzer
|
||||||
|
diff --git a/tests/stb.dsp b/tests/stb.dsp
|
||||||
|
index ba13ba1371..af16faf354 100644
|
||||||
|
--- a/tests/stb.dsp
|
||||||
|
+++ b/tests/stb.dsp
|
||||||
|
@@ -150,10 +150,6 @@ SOURCE=..\stb_malloc.h
|
||||||
|
# End Source File
|
||||||
|
# Begin Source File
|
||||||
|
|
||||||
|
-SOURCE=..\stb_perlin.h
|
||||||
|
-# End Source File
|
||||||
|
-# Begin Source File
|
||||||
|
-
|
||||||
|
SOURCE=..\stb_rect_pack.h
|
||||||
|
# End Source File
|
||||||
|
# Begin Source File
|
||||||
|
@@ -218,10 +214,6 @@ SOURCE=.\test_packer.c
|
||||||
|
# End Source File
|
||||||
|
# Begin Source File
|
||||||
|
|
||||||
|
-SOURCE=.\test_perlin.c
|
||||||
|
-# End Source File
|
||||||
|
-# Begin Source File
|
||||||
|
-
|
||||||
|
SOURCE=.\test_sprintf.c
|
||||||
|
# End Source File
|
||||||
|
# Begin Source File
|
||||||
|
diff --git a/tests/test.sbm b/tests/test.sbm
|
||||||
|
index 9465605846..f1518672f0 100644
|
||||||
|
--- a/tests/test.sbm
|
||||||
|
+++ b/tests/test.sbm
|
||||||
|
@@ -53,7 +53,6 @@ main.c test_dxt.c
|
||||||
|
main.c test_easyfont.c
|
||||||
|
main.c test_image.c
|
||||||
|
main.c test_image_write.c
|
||||||
|
-main.c test_perlin.c
|
||||||
|
main.c test_sprintf.c
|
||||||
|
main.c test_vorbis.c ../stb_vorbis.c
|
||||||
|
main.c test_voxel.c
|
||||||
|
diff --git a/tests/test_c_compilation.c b/tests/test_c_compilation.c
|
||||||
|
index 11f60231e6..27be5d682c 100644
|
||||||
|
--- a/tests/test_c_compilation.c
|
||||||
|
+++ b/tests/test_c_compilation.c
|
||||||
|
@@ -17,7 +17,6 @@
|
||||||
|
#include "stb_herringbone_wang_tile.h"
|
||||||
|
#include "stb_image.h"
|
||||||
|
#include "stb_image_write.h"
|
||||||
|
-#include "stb_perlin.h"
|
||||||
|
#include "stb_c_lexer.h"
|
||||||
|
#include "stb_divide.h"
|
||||||
|
#include "stb_image_resize.h"
|
||||||
|
@@ -46,4 +45,4 @@ int quicktest(void)
|
||||||
|
char buffer[999];
|
||||||
|
stbsp_sprintf(buffer, "test%%test");
|
||||||
|
return 0;
|
||||||
|
-}
|
||||||
|
\ No newline at end of file
|
||||||
|
+}
|
||||||
|
diff --git a/tests/test_cpp_compilation.cpp b/tests/test_cpp_compilation.cpp
|
||||||
|
index fd8c5b6423..43ec5a2ba9 100644
|
||||||
|
--- a/tests/test_cpp_compilation.cpp
|
||||||
|
+++ b/tests/test_cpp_compilation.cpp
|
||||||
|
@@ -6,7 +6,6 @@
|
||||||
|
#include "stb_truetype.h"
|
||||||
|
#include "stb_image_write.h"
|
||||||
|
#include "stb_c_lexer.h"
|
||||||
|
-#include "stb_perlin.h"
|
||||||
|
#include "stb_dxt.h"
|
||||||
|
#include "stb_divide.h"
|
||||||
|
#include "stb_herringbone_wang_tile.h"
|
||||||
|
@@ -45,7 +44,6 @@ void my_free(void *) { }
|
||||||
|
#include "stb_rect_pack.h"
|
||||||
|
#include "stb_truetype.h"
|
||||||
|
#include "stb_image_write.h"
|
||||||
|
-#include "stb_perlin.h"
|
||||||
|
#include "stb_dxt.h"
|
||||||
|
#include "stb_divide.h"
|
||||||
|
#include "stb_herringbone_wang_tile.h"
|
||||||
|
diff --git a/tests/test_perlin.c b/tests/test_perlin.c
|
||||||
|
deleted file mode 100644
|
||||||
|
index de702c9bcc..0000000000
|
||||||
|
--- a/tests/test_perlin.c
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1 +0,0 @@
|
||||||
|
-#include "stb_perlin.h"
|
||||||
|
\ No newline at end of file
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (stb-3a1174060a7dd4eb652d4e6854bc4cd98c159200.tar.gz) = 282318244dd1002eeb6bff5c43d7ccbca26d001d5820018c354b8706bcd91e947056a5aafefcb922730cab5cabc05a03fb6576b6eb21ff76d54a4d71888f39fe
|
SHA512 (stb-c0c982601f40183e74d84a61237e968dca08380e.tar.gz) = a900cb82c6711c12cdafbbabef265b2e3d85e738e9b01955e4061440b8c0cecff1028838b2121a5e0f084dfc7c90aca3d52d0b1353ccdd3f8271cf5843fe0c11
|
||||||
|
36
stb.spec
36
stb.spec
@ -1,5 +1,5 @@
|
|||||||
%global forgeurl https://github.com/nothings/%{name}
|
%global forgeurl https://github.com/nothings/%{name}
|
||||||
%global commit 3a1174060a7dd4eb652d4e6854bc4cd98c159200
|
%global commit c0c982601f40183e74d84a61237e968dca08380e
|
||||||
|
|
||||||
# We choose not to package the “stb_include” library (stb_include.h) because it
|
# We choose not to package the “stb_include” library (stb_include.h) because it
|
||||||
# is so rife with old-school blithe C behavior—wanton use of strcat/strcpy into
|
# is so rife with old-school blithe C behavior—wanton use of strcat/strcpy into
|
||||||
@ -50,6 +50,10 @@ Patch2: %{forgeurl}/pull/1196.patch
|
|||||||
# https://github.com/nothings/stb/pull/1198
|
# https://github.com/nothings/stb/pull/1198
|
||||||
Patch3: %{forgeurl}/pull/1198.patch
|
Patch3: %{forgeurl}/pull/1198.patch
|
||||||
|
|
||||||
|
# Remove stb_perlin from tests
|
||||||
|
# https://github.com/nothings/stb/pull/1198
|
||||||
|
Patch4: %{forgeurl}/pull/1204.patch
|
||||||
|
|
||||||
%global stb_c_lexer_version 0.12
|
%global stb_c_lexer_version 0.12
|
||||||
%global stb_connected_components_version 0.96
|
%global stb_connected_components_version 0.96
|
||||||
%global stb_divide_version 0.94
|
%global stb_divide_version 0.94
|
||||||
@ -63,12 +67,11 @@ Patch3: %{forgeurl}/pull/1198.patch
|
|||||||
%global stb_image_write_version 1.16
|
%global stb_image_write_version 1.16
|
||||||
%global stb_include_version 0.2
|
%global stb_include_version 0.2
|
||||||
%global stb_leakcheck_version 0.6
|
%global stb_leakcheck_version 0.6
|
||||||
%global stb_perlin_version 0.5
|
|
||||||
%global stb_rect_pack_version 1.1
|
%global stb_rect_pack_version 1.1
|
||||||
%global stb_sprintf_version 1.10
|
%global stb_sprintf_version 1.10
|
||||||
%global stb_textedit_version 1.14
|
%global stb_textedit_version 1.14
|
||||||
%global stb_tilemap_editor_version 0.42
|
%global stb_tilemap_editor_version 0.42
|
||||||
%global stb_truetype_version 1.25
|
%global stb_truetype_version 1.26
|
||||||
%global stb_vorbis_version 1.22
|
%global stb_vorbis_version 1.22
|
||||||
%global stb_voxel_render_version 0.89
|
%global stb_voxel_render_version 0.89
|
||||||
|
|
||||||
@ -120,8 +123,6 @@ Requires: stb_include-static = %{stb_include_version}-%{release}
|
|||||||
%endif
|
%endif
|
||||||
Requires: stb_leakcheck-devel%{?_isa} = %{stb_leakcheck_version}-%{release}
|
Requires: stb_leakcheck-devel%{?_isa} = %{stb_leakcheck_version}-%{release}
|
||||||
Requires: stb_leakcheck-static = %{stb_leakcheck_version}-%{release}
|
Requires: stb_leakcheck-static = %{stb_leakcheck_version}-%{release}
|
||||||
Requires: stb_perlin-devel%{?_isa} = %{stb_perlin_version}-%{release}
|
|
||||||
Requires: stb_perlin-static = %{stb_perlin_version}-%{release}
|
|
||||||
Requires: stb_rect_pack-devel%{?_isa} = %{stb_rect_pack_version}-%{release}
|
Requires: stb_rect_pack-devel%{?_isa} = %{stb_rect_pack_version}-%{release}
|
||||||
Requires: stb_rect_pack-static = %{stb_rect_pack_version}-%{release}
|
Requires: stb_rect_pack-static = %{stb_rect_pack_version}-%{release}
|
||||||
Requires: stb_sprintf-devel%{?_isa} = %{stb_sprintf_version}-%{release}
|
Requires: stb_sprintf-devel%{?_isa} = %{stb_sprintf_version}-%{release}
|
||||||
@ -137,6 +138,12 @@ Requires: stb_vorbis-static = %{stb_vorbis_version}-%{release}
|
|||||||
Requires: stb_voxel_render-devel%{?_isa} = %{stb_voxel_render_version}-%{release}
|
Requires: stb_voxel_render-devel%{?_isa} = %{stb_voxel_render_version}-%{release}
|
||||||
Requires: stb_voxel_render-static = %{stb_voxel_render_version}-%{release}
|
Requires: stb_voxel_render-static = %{stb_voxel_render_version}-%{release}
|
||||||
|
|
||||||
|
# Upstream removed the stb_perlin library in commit
|
||||||
|
# 59e7dec3e8bb0a8d4050d03c2dc32cf71ffa87c6, asserting it was covered by
|
||||||
|
# patents.
|
||||||
|
Obsoletes: stb_perlin-devel < 0.5-0.5
|
||||||
|
Obsoletes: stb_perlin-static < 0.5-0.5
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The %{name}-devel package contains libraries and header files for developing
|
The %{name}-devel package contains libraries and header files for developing
|
||||||
applications that use %{name}.
|
applications that use %{name}.
|
||||||
@ -336,16 +343,6 @@ Provides: stb_leakcheck-static = %{stb_leakcheck_version}-%{release}
|
|||||||
Quick and dirty malloc leak-checking.
|
Quick and dirty malloc leak-checking.
|
||||||
|
|
||||||
|
|
||||||
%package -n stb_perlin-devel
|
|
||||||
Summary: Perlin noise
|
|
||||||
Version: %{stb_perlin_version}
|
|
||||||
|
|
||||||
Provides: stb_perlin-static = %{stb_perlin_version}-%{release}
|
|
||||||
|
|
||||||
%description -n stb_perlin-devel
|
|
||||||
Perlin noise.
|
|
||||||
|
|
||||||
|
|
||||||
%package -n stb_rect_pack-devel
|
%package -n stb_rect_pack-devel
|
||||||
Summary: Rectangle packing
|
Summary: Rectangle packing
|
||||||
Version: %{stb_rect_pack_version}
|
Version: %{stb_rect_pack_version}
|
||||||
@ -612,7 +609,6 @@ done <<'EOF'
|
|||||||
%{stb_image_write_version} stb_image_write.h
|
%{stb_image_write_version} stb_image_write.h
|
||||||
%{stb_include_version} stb_include.h
|
%{stb_include_version} stb_include.h
|
||||||
%{stb_leakcheck_version} stb_leakcheck.h
|
%{stb_leakcheck_version} stb_leakcheck.h
|
||||||
%{stb_perlin_version} stb_perlin.h
|
|
||||||
%{stb_rect_pack_version} stb_rect_pack.h
|
%{stb_rect_pack_version} stb_rect_pack.h
|
||||||
%{stb_sprintf_version} stb_sprintf.h
|
%{stb_sprintf_version} stb_sprintf.h
|
||||||
%{stb_textedit_version} stb_textedit.h
|
%{stb_textedit_version} stb_textedit.h
|
||||||
@ -740,14 +736,6 @@ EOF
|
|||||||
%{_includedir}/stb_leakcheck.h
|
%{_includedir}/stb_leakcheck.h
|
||||||
|
|
||||||
|
|
||||||
%files -n stb_perlin-devel
|
|
||||||
%license LICENSE
|
|
||||||
# Directory has shared ownership across stb subpackages:
|
|
||||||
%dir %{_includedir}/stb
|
|
||||||
%{_includedir}/stb/stb_perlin.h
|
|
||||||
%{_includedir}/stb_perlin.h
|
|
||||||
|
|
||||||
|
|
||||||
%files -n stb_rect_pack-devel
|
%files -n stb_rect_pack-devel
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
# Directory has shared ownership across stb subpackages:
|
# Directory has shared ownership across stb subpackages:
|
||||||
|
Loading…
Reference in New Issue
Block a user