pax: fix the -X option segfault

Resolves: #1175009
Version: 1.5.2-9
This commit is contained in:
Pavel Raiskup 2014-12-17 13:08:03 +01:00
parent 3c90053e65
commit dfbde78b4d
2 changed files with 35 additions and 1 deletions

View File

@ -0,0 +1,26 @@
From 68f6e16d7d2c8a6c91cd430b12a1a0c7b15672b4 Mon Sep 17 00:00:00 2001
From: Pavel Raiskup <praiskup@redhat.com>
Date: Wed, 17 Dec 2014 12:57:37 +0100
Subject: [PATCH] pax: don't segfault with -X option
Pass a valid address of nomount variable into getallargs().
---
star/pax.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/star/pax.c b/star/pax.c
index 9abe3f8..c627a46 100644
--- a/star/pax.c
+++ b/star/pax.c
@@ -166,7 +166,7 @@ gargs(ac, av)
gethdr, &chdrtype, /* -x */
gethdr, &chdrtype, /* artype= */
#endif /* __old__lint */
- nomount) < 0) {
+ &nomount) < 0) {
errmsgno(EX_BAD, "Bad Option: %s.\n", av[0]);
susage(EX_BAD);
}
--
2.1.0

View File

@ -7,7 +7,7 @@
Summary: An archiving tool with ACL support
Name: star
Version: 1.5.2
Release: 8%{?dist}
Release: 9%{?dist}
URL: http://cdrecord.berlios.de/old/private/star.html
Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
@ -48,6 +48,10 @@ Patch10: star-1.5.2-rmt-rh-access.patch
# ~> related to #968980
Patch11: star-1.5.2-use-ssh-by-default.patch
# Fix segfault for 'pax -X' (rhbz#1175009)
# ~> downstream
Patch12: star-1.5.3-pax-X-option.patch
Requires(post): %{ALTERNATIVES}
Requires(preun): %{ALTERNATIVES}
@ -126,6 +130,7 @@ restoring files from a backup), and tar (an archiving program).
%patch9 -p1 -b .aarch64
%patch10 -p1 -b .rmt-access-rules
%patch11 -p1 -b .ssh-by-default
%patch12 -p1 -b .pax-X
cp -a star/all.mk star/Makefile
@ -242,6 +247,9 @@ fi
%{_sysconfdir}/rmt
%changelog
* Wed Dec 17 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-9
- fix segfault for pax -X (#1175009)
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild