rebase to 1.5.3

Also from now, do not requires 'spax' by star.

Version: 1.5.3-1
This commit is contained in:
Pavel Raiskup 2014-06-27 15:52:34 +02:00
parent ec7c0a3511
commit afd80faf0f
6 changed files with 131 additions and 154 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/star-1.5.2.tar.bz2 /star-1.5.3.tar.bz2

View File

@ -1 +1 @@
5c15cedb52e26b02b95c82de08c5fcc1 star-1.5.2.tar.bz2 46ef6425082e60966ec9d33f73fd44b0 star-1.5.3.tar.bz2

View File

@ -1,42 +0,0 @@
--- star-1.5/DEFAULTS/Defaults.linux.fix 2007-08-23 13:35:54.000000000 +0200
+++ star-1.5/DEFAULTS/Defaults.linux 2007-08-23 13:51:33.000000000 +0200
@@ -8,8 +8,8 @@
# Compiler stuff
#
###########################################################################
-DEFCCOM= cc
-#DEFCCOM= gcc
+#DEFCCOM= cc
+DEFCCOM= gcc
###########################################################################
#
@@ -40,22 +40,21 @@ __LINUX_SRC_INCLUDE= $(_LINUX_SRC_INCLUD
LINUX_SRC_INCLUDE= $(__LINUX_SRC_INCLUDE:$(_UNIQ)no%=%)
DEFINCDIRS= $(SRCROOT)/include
-LDPATH= -L/opt/schily/lib
-#RUNPATH= -R$(INS_BASE)/lib -R/opt/schily/lib -R$(OLIBSDIR)
-RUNPATH= -R$(INS_BASE)/lib -R/opt/schily/lib
+LDPATH=
+RUNPATH=
###########################################################################
#
# Installation config stuff
#
###########################################################################
-INS_BASE= /opt/schily
-INS_KBASE= /
-INS_RBASE= /
+INS_BASE= $(RPM_INSTALLDIR)/usr/
+INS_KBASE= $(RPM_INSTALLDIR)/
+INS_RBASE= $(RPM_INSTALLDIR)/
#
DEFUMASK= 002
#
DEFINSMODEF= 444
DEFINSMODEX= 755
DEFINSUSR= root
-DEFINSGRP= bin
+DEFINSGRP= root

View File

@ -1,9 +1,9 @@
diff --git a/autoconf/configure.in b/autoconf/configure.in diff --git a/autoconf/configure.in b/autoconf/configure.in
index 1465ce1..3046a62 100644 index fc9f880..30383e4 100644
--- a/autoconf/configure.in --- a/autoconf/configure.in
+++ b/autoconf/configure.in +++ b/autoconf/configure.in
@@ -817,6 +817,15 @@ AC_CHECK_FUNCS(sched_yield) @@ -906,6 +906,15 @@ LIBS="$LIBS $lib_cap"
AC_CHECK_FUNCS(nanosleep) AC_CHECK_FUNCS(cap_get_proc cap_set_proc cap_set_flag cap_clear_flag)
LIBS="$ac_save_LIBS" LIBS="$ac_save_LIBS"
+AC_CHECK_HEADERS(selinux/selinux.h) +AC_CHECK_HEADERS(selinux/selinux.h)
@ -18,27 +18,28 @@ index 1465ce1..3046a62 100644
dnl Misc OS checks. dnl Misc OS checks.
AC_CHECK_FILES(/dev/tty /dev/null /dev/zero) AC_CHECK_FILES(/dev/tty /dev/null /dev/zero)
AC_CHECK_FILES(/dev/stdin /dev/stdout /dev/stderr) AC_CHECK_FILES(/dev/stdin /dev/stdout /dev/stderr)
@@ -894,6 +903,7 @@ AC_SUBST(lib_secdb) @@ -992,6 +1001,7 @@ AC_SUBST(lib_secdb)
AC_SUBST(lib_gen) AC_SUBST(lib_gen)
AC_SUBST(lib_pthread) AC_SUBST(lib_pthread)
AC_SUBST(lib_rt) AC_SUBST(lib_rt)
+AC_SUBST(lib_selinux) +AC_SUBST(lib_selinux)
AC_SUBST(lib_dl) AC_SUBST(lib_dl)
AC_SUBST(lib_dir) AC_SUBST(lib_dir)
AC_SUBST(lib_cap)
diff --git a/autoconf/rules.cnf.in b/autoconf/rules.cnf.in diff --git a/autoconf/rules.cnf.in b/autoconf/rules.cnf.in
index 6de994c..31b1575 100644 index affcb5c..2b7bff2 100644
--- a/autoconf/rules.cnf.in --- a/autoconf/rules.cnf.in
+++ b/autoconf/rules.cnf.in +++ b/autoconf/rules.cnf.in
@@ -30,5 +30,6 @@ LIB_SECDB = @lib_secdb@ @@ -34,6 +34,7 @@ LIB_SECDB = @lib_secdb@
LIB_GEN = @lib_gen@ LIB_GEN = @lib_gen@
LIB_PTHREAD = @lib_pthread@ LIB_PTHREAD = @lib_pthread@
LIB_RT = @lib_rt@ LIB_RT = @lib_rt@
+LIB_SELINUX = @lib_selinux@ +LIB_SELINUX = @lib_selinux@
LIB_DL= @lib_dl@ LIB_DL= @lib_dl@
LIB_DIR= @lib_dir@ LIB_DIR= @lib_dir@
LIB_CAP= @lib_cap@
diff --git a/star/cpio.mk b/star/cpio.mk diff --git a/star/cpio.mk b/star/cpio.mk
index ec48a95..8a2c7a0 100644 index 37a6dd2..8bfc3bd 100644
--- a/star/cpio.mk --- a/star/cpio.mk
+++ b/star/cpio.mk +++ b/star/cpio.mk
@@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND @@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND
@ -52,17 +53,17 @@ index ec48a95..8a2c7a0 100644
@@ -34,7 +35,7 @@ CFILES= cpio.c header.c cpiohdr.c xheader.c xattr.c \ @@ -34,7 +35,7 @@ CFILES= cpio.c header.c cpiohdr.c xheader.c xattr.c \
HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \ HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \
movearch.h table.h props.h fifo.h diff.h \ movearch.h table.h props.h fifo.h diff.h \
checkerr.h dumpdate.h bitstring.h checkerr.h dumpdate.h bitstring.h pathname.h
-LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) -LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP)
+LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_SELINUX) +LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP) $(LIB_SELINUX)
XMK_FILE= scpioman.mk XMK_FILE= scpioman.mk
########################################################################### ###########################################################################
diff --git a/star/extract.c b/star/extract.c diff --git a/star/extract.c b/star/extract.c
index 9a83bf4..3d68c43 100644 index cf60154..98842e1 100644
--- a/star/extract.c --- a/star/extract.c
+++ b/star/extract.c +++ b/star/extract.c
@@ -253,6 +253,17 @@ extern struct WALK walkstate; @@ -256,6 +256,17 @@ extern struct WALK walkstate;
continue; continue;
} }
#endif #endif
@ -81,7 +82,7 @@ index 9a83bf4..3d68c43 100644
if (!void_bad(&finfo)) if (!void_bad(&finfo))
break; break;
diff --git a/star/gnutar.mk b/star/gnutar.mk diff --git a/star/gnutar.mk b/star/gnutar.mk
index d0da54b..9c5de30 100644 index 1a296e1..6595aa2 100644
--- a/star/gnutar.mk --- a/star/gnutar.mk
+++ b/star/gnutar.mk +++ b/star/gnutar.mk
@@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND @@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND
@ -95,14 +96,14 @@ index d0da54b..9c5de30 100644
@@ -34,7 +35,7 @@ CFILES= gnutar.c header.c cpiohdr.c xheader.c xattr.c \ @@ -34,7 +35,7 @@ CFILES= gnutar.c header.c cpiohdr.c xheader.c xattr.c \
HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \ HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \
movearch.h table.h props.h fifo.h diff.h \ movearch.h table.h props.h fifo.h diff.h \
checkerr.h dumpdate.h bitstring.h checkerr.h dumpdate.h bitstring.h pathname.h
-LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) -LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP)
+LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_SELINUX) +LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP) $(LIB_SELINUX)
XMK_FILE= gnutarman.mk XMK_FILE= gnutarman.mk
########################################################################### ###########################################################################
diff --git a/star/pax.mk b/star/pax.mk diff --git a/star/pax.mk b/star/pax.mk
index 0254e77..15c8ea0 100644 index 73c6bc1..d2a52a9 100644
--- a/star/pax.mk --- a/star/pax.mk
+++ b/star/pax.mk +++ b/star/pax.mk
@@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND @@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND
@ -116,17 +117,17 @@ index 0254e77..15c8ea0 100644
@@ -35,7 +36,7 @@ CFILES= pax.c header.c cpiohdr.c xheader.c xattr.c \ @@ -35,7 +36,7 @@ CFILES= pax.c header.c cpiohdr.c xheader.c xattr.c \
HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \ HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \
movearch.h table.h props.h fifo.h diff.h \ movearch.h table.h props.h fifo.h diff.h \
checkerr.h dumpdate.h bitstring.h checkerr.h dumpdate.h bitstring.h pathname.h
-LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) -LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP)
+LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_SELINUX) +LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP) $(LIB_SELINUX)
XMK_FILE= spaxman.mk XMK_FILE= spaxman.mk
########################################################################### ###########################################################################
diff --git a/star/star.c b/star/star.c diff --git a/star/star.c b/star/star.c
index 7b58964..fe9d984 100644 index 9dfcef7..464c751 100644
--- a/star/star.c --- a/star/star.c
+++ b/star/star.c +++ b/star/star.c
@@ -46,6 +46,10 @@ static UConst char sccsid[] = @@ -48,6 +48,10 @@ static UConst char sccsid[] =
#include "starsubs.h" #include "starsubs.h"
#include "checkerr.h" #include "checkerr.h"
@ -137,7 +138,7 @@ index 7b58964..fe9d984 100644
EXPORT int main __PR((int ac, char **av)); EXPORT int main __PR((int ac, char **av));
LOCAL void star_create __PR((int ac, char *const *av)); LOCAL void star_create __PR((int ac, char *const *av));
LOCAL void checkdumptype __PR((GINFO *gp)); LOCAL void checkdumptype __PR((GINFO *gp));
@@ -399,6 +403,10 @@ main(ac, av) @@ -402,6 +406,10 @@ main(ac, av)
comerr("Panic cannot set back effective uid.\n"); comerr("Panic cannot set back effective uid.\n");
} }
my_uid = geteuid(); my_uid = geteuid();
@ -207,7 +208,7 @@ index a914ade..1e2a233 100644
/* /*
diff --git a/star/suntar.mk b/star/suntar.mk diff --git a/star/suntar.mk b/star/suntar.mk
index 5690c9f..f781f63 100644 index 9b76a23..1842917 100644
--- a/star/suntar.mk --- a/star/suntar.mk
+++ b/star/suntar.mk +++ b/star/suntar.mk
@@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND @@ -19,6 +19,7 @@ CPPOPTS += -DUSE_FIND
@ -221,17 +222,17 @@ index 5690c9f..f781f63 100644
@@ -34,7 +35,7 @@ CFILES= suntar.c header.c cpiohdr.c xheader.c xattr.c \ @@ -34,7 +35,7 @@ CFILES= suntar.c header.c cpiohdr.c xheader.c xattr.c \
HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \ HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \
movearch.h table.h props.h fifo.h diff.h \ movearch.h table.h props.h fifo.h diff.h \
checkerr.h dumpdate.h bitstring.h checkerr.h dumpdate.h bitstring.h pathname.h
-LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) -LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP)
+LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_SELINUX) +LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_CAP) $(LIB_SELINUX)
XMK_FILE= suntarman.mk XMK_FILE= suntarman.mk
########################################################################### ###########################################################################
diff --git a/star/xattr.c b/star/xattr.c diff --git a/star/xattr.c b/star/xattr.c
index 1462950..6493447 100644 index 2e262ef..08fc42e 100644
--- a/star/xattr.c --- a/star/xattr.c
+++ b/star/xattr.c +++ b/star/xattr.c
@@ -196,6 +196,27 @@ fail: @@ -198,6 +198,27 @@ fail:
#endif /* USE_XATTR */ #endif /* USE_XATTR */
} }
@ -259,7 +260,7 @@ index 1462950..6493447 100644
/* ARGSUSED */ /* ARGSUSED */
EXPORT BOOL EXPORT BOOL
set_xattr(info) set_xattr(info)
@@ -209,6 +230,10 @@ set_xattr(info) @@ -211,6 +232,10 @@ set_xattr(info)
return (TRUE); return (TRUE);
for (xap = info->f_xattr; xap->name != NULL; xap++) { for (xap = info->f_xattr; xap->name != NULL; xap++) {

19
star-1.5.3-star-mk.patch Normal file
View File

@ -0,0 +1,19 @@
diff --git a/star/star.mk b/star/star.mk
index 68d3482..4961a29 100644
--- a/star/star.mk
+++ b/star/star.mk
@@ -32,11 +32,11 @@ CFILES= star.c header.c cpiohdr.c xheader.c xattr.c \
subst.c volhdr.c \
chdir.c match.c defaults.c dumpdate.c \
fifo.c device.c checkerr.c \
- findinfo.c
+ findinfo.c pathname.c
HFILES= star.h starsubs.h dirtime.h xtab.h xutimes.h \
movearch.h table.h props.h fifo.h diff.h restore.h \
- checkerr.h dumpdate.h bitstring.h
-LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_SELINUX)
+ checkerr.h dumpdate.h bitstring.h pathname.h
+LIBS= -ldeflt -lrmt -lfind -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_INTL) $(LIB_SELINUX) $(LIB_CAP)
XMK_FILE= Makefile.man starformatman.mk
###########################################################################

157
star.spec
View File

@ -6,79 +6,66 @@
Summary: An archiving tool with ACL support Summary: An archiving tool with ACL support
Name: star Name: star
Version: 1.5.2 Version: 1.5.3
Release: 11%{?dist} Release: 1%{?dist}
License: CDDL License: CDDL
Group: Applications/Archiving Group: Applications/Archiving
URL: http://cdrecord.berlios.de/old/private/star.html URL: http://freecode.com/projects/star
Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2 Source: http://downloads.sourceforge.net/s-tar/%{name}-%{version}.tar.bz2
# add SELinux support to star(#)
Patch1: star-1.5.3-selinux.patch
# do not segfault with data-change-warn option (#255261)
Patch2: star-1.5-changewarnSegv.patch
# Prevent buffer overflow for filenames with length of 100 characters (#556664)
Patch3: star-1.5.2-bufferoverflow.patch
# Fix some invalid manpage references (#624612)
Patch4: star-1.5.1-manpagereferences.patch
#use gcc for compilation, change defaults for Linux
Patch1: star-1.5-newMake.patch
#add SELinux support to star(#)
Patch2: star-1.5.2-selinux.patch
#do not segfault with data-change-warn option (#255261)
Patch3: star-1.5-changewarnSegv.patch
#Prevent buffer overflow for filenames with length of 100 characters (#556664)
Patch4: star-1.5.2-bufferoverflow.patch
#Fix some invalid manpage references (#624612)
Patch5: star-1.5.1-manpagereferences.patch
# do not crash when xattrs are not set on all files (#861848) # do not crash when xattrs are not set on all files (#861848)
Patch6: star-1.5.1-selinux-segfault.patch Patch5: star-1.5.1-selinux-segfault.patch
# note that the H=crc format uses Sum32 algorithm, not CRC
Patch7: star-1.5.1-crc.patch
# fix man-page-day objections # note that the H=crc format uses Sum32 algorithm, not CRC
# ~> proposed upstream: Patch6: star-1.5.1-crc.patch
# https://lists.berlios.de/pipermail/star-developers/2013-April/000027.html
# ~> #948866
Patch8: star-1.5.2-man-page-day.patch
# Disable profiling on aarch64 as it's not currently supported upstream # Disable profiling on aarch64 as it's not currently supported upstream
Patch9: star-aarch64.patch Patch7: star-aarch64.patch
# Allow rmt to access all files. # Allow rmt to access all files.
# ~> downstream # ~> downstream
# ~> #968980 # ~> #968980
Patch10: star-1.5.2-rmt-rh-access.patch Patch8: star-1.5.2-rmt-rh-access.patch
# Use ssh rather than rsh by default # Use ssh rather than rsh by default
# ~> downstream # ~> downstream
# ~> related to #968980 # ~> related to #968980
Patch11: star-1.5.2-use-ssh-by-default.patch Patch9: star-1.5.2-use-ssh-by-default.patch
# Fix broken star.mk in 1.5.3 (included from all.mk)
Patch10: star-1.5.3-star-mk.patch
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel BuildRequires: libattr-devel libacl-devel libtool libselinux-devel
BuildRequires: e2fsprogs-devel BuildRequires: e2fsprogs-devel
Requires(post): %{ALTERNATIVES}
Requires(preun): %{ALTERNATIVES}
# Historically, star installed /usr/bin/spax binary also so we don't want to
# break the compatibility. We don't care about scpio because scpio binary was
# not installed.
Requires: spax
%description %description
Star saves many files together into a single tape or disk archive, Star saves many files together into a single tape or disk archive,
and can restore individual files from the archive. Star supports ACL. and can restore individual files from the archive. Star supports ACL.
%package -n spax %package -n spax
# Temporary! Remove once no problem may occur. We really need to force update
# of older star and pax, when any of them is installed. Its file list
# collisions with 'spax'.
Conflicts: star < 1.5.2-5
Conflicts: pax < 3.4-16
Summary: Portable archive exchange Summary: Portable archive exchange
Group: Applications/Archiving Group: Applications/Archiving
Requires(post): %{ALTERNATIVES}
Requires(preun): %{ALTERNATIVES}
%description -n spax %description -n spax
The pax utility shall read and write archives, write lists of the members of The pax utility shall read and write archives, write lists of the members of
archive files and copy directory hierarchies as is defined in IEEE Std 1003.1. archive files and copy directory hierarchies as is defined in IEEE Std 1003.1.
%package -n scpio %package -n scpio
# Temporary! Remove once _no problem_ may occur. We really need to force
# update of older star if it installed — its files overlaps with scpio.
Conflicts: star < 1.5.2-5
Summary: Copy file archives in and out (LEGACY) Summary: Copy file archives in and out (LEGACY)
Group: Applications/Archiving Group: Applications/Archiving
@ -110,20 +97,20 @@ restoring files from a backup), and tar (an archiving program).
%prep %prep
%setup -q %setup -q
%patch1 -p1 -b .newMake
%if %{WITH_SELINUX} %if %{WITH_SELINUX}
%patch2 -p1 -b .selinux %patch1 -p1 -b .selinux
%endif %endif
%patch3 -p1 -b .changewarnSegv %patch2 -p1 -b .changewarnSegv
%patch4 -p1 -b .namesoverflow %patch3 -p1 -b .namesoverflow
%patch5 -p1 -b .references %patch4 -p1 -b .references
%patch6 -p1 -b .selinux-segfault %patch5 -p1 -b .selinux-segfault
%patch7 -p1 -b .crc %patch6 -p1 -b .crc
%patch8 -p1 -b .man-page-day %patch7 -p1 -b .aarch64
%patch9 -p1 -b .aarch64 %patch8 -p1 -b .rmt-access-rules
%patch10 -p1 -b .rmt-access-rules %patch9 -p1 -b .ssh-by-default
%patch11 -p1 -b .ssh-by-default %patch10 -p1 -b .bug-config-1.5.3
# disable single "fat" binary
cp -a star/all.mk star/Makefile cp -a star/all.mk star/Makefile
star_recode() star_recode()
@ -136,8 +123,6 @@ star_recode()
star_recode AN-1.5 AN-1.5.2 star/star.4 star_recode AN-1.5 AN-1.5.2 star/star.4
cp -a READMEs/README.linux .
for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do
for AFILE in gcc cc; do for AFILE in gcc cc; do
[ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \ [ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
@ -146,31 +131,36 @@ for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do
done done
%build %build
export MAKEPROG=gmake # Silence irritating warning
# Autoconfiscate export GMAKE_NOWARN=true
(cd autoconf; AC_MACRODIR=. AWK=gawk ./autoconf)
# Note: disable optimalisation by COPTX='-g3 -O0' LDOPTX='-g3 -O0'
make %{?_smp_mflags} \
RUNPATH= \
PARCH=%{_target_cpu} \
K_ARCH=%{_target_cpu} \
COPTX="$RPM_OPT_FLAGS -DTRY_EXT2_FS" CC="%{__cc}"
#make %%{?_smp_mflags} PARCH=%%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
# ~~> enable debug by COPTX='-g3 -O0' LDOPTX='-g3 -O0'
make %{?_smp_mflags} PARCH=%{_target_cpu} \
COPTX="$RPM_OPT_FLAGS -DTRY_EXT2_FS" CC="%{__cc}" \
K_ARCH=%{_target_cpu} \
CONFFLAGS="%{_target_platform} --prefix=%{_prefix} \
--exec-prefix=%{_exec_prefix} --bindir=%{_bindir} \
--sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
--datadir=%{_datadir} --includedir=%{_includedir} \
--libdir=%{_libdir} --libexec=%{_libexecdir} \
--localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} \
--mandir=%{_mandir} --infodir=%{_infodir}" < /dev/null
%install %install
export MAKEPROG=gmake # This is work-around atypical build system. Variables used:
mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man4 # INS_BASE - something like DESTDIR together with --prefix in with autotools
# INS_BASE - something like DESTDIR for configuration files, but etc/default
make install RPM_INSTALLDIR=${RPM_BUILD_ROOT} PARCH=%{_target_cpu} K_ARCH=%{_target_cpu} < /dev/null # is at least in 1.5.3 hardcoded
# INSTALL - install script, used non-default because the -o & -g options are
# causing ugly build output
# Things like --docdir, etc. are randomly hard-coded so we must deal with it.
make install -s \
INS_BASE=$RPM_BUILD_ROOT%{_prefix} \
INS_RBASE=$RPM_BUILD_ROOT \
INSTALL='sh $(SRCROOT)/conf/install-sh -c -m $(INSMODEINS)'
ln -s star.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/ustar.1 ln -s star.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/ustar.1
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}
mkdir -p ${RPM_BUILD_ROOT}%{_pkgdocdir}
ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt
install -p -m 644 COPYING star/README CDDL.Schily.txt AN-* \
${RPM_BUILD_ROOT}%{_pkgdocdir}
# XXX Nuke unpackaged files. # XXX Nuke unpackaged files.
( cd ${RPM_BUILD_ROOT} ( cd ${RPM_BUILD_ROOT}
@ -182,18 +172,24 @@ ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt
rm -f .%{_bindir}/star_fat rm -f .%{_bindir}/star_fat
rm -f .%{_bindir}/star_sym rm -f .%{_bindir}/star_sym
rm -f .%{_bindir}/suntar rm -f .%{_bindir}/suntar
rm -rf .%{_docdir}/rmt rm -f .%{_sysconfdir}/default/star
rm -rf .%{_prefix}%{_sysconfdir} rm -rf .%{_prefix}%{_sysconfdir}
rm -rf .%{_prefix}/include rm -rf .%{_prefix}/include
rm -rf .%{_prefix}/lib # hard-wired intently rm -rf .%{_prefix}/lib # hard-wired intently
rm -rf .%{_mandir}/man3 rm -rf .%{_mandir}/man3
rm -rf .%{_mandir}/man5/{makefiles,makerules}.5* rm -rf .%{_mandir}/man5/{makefiles,makerules}.5*
rm -rf .%{_mandir}/man1/{tartest,gnutar,smt,mt,suntar,match}.1* rm -rf .%{_mandir}/man1/{tartest,gnutar,smt,mt,suntar,match}.1*
rm -rf .%{_docdir}/star/testscripts
rm -rf .%{_docdir}/star/TODO
rm -rf .%{_docdir}/rmt
) )
%clean %clean
%global general_docs README AN* COPYING CDDL.Schily.txt TODO README.linux %global general_docs \
%dir %{_pkgdocdir} \
%doc %{_pkgdocdir}/COPYING \
%doc %{_pkgdocdir}/CDDL.Schily.txt \
%post -n spax %post -n spax
%{ALTERNATIVES} \ %{ALTERNATIVES} \
@ -207,7 +203,7 @@ if [ $1 -eq 0 ]; then
fi fi
%files %files
%doc %{general_docs} %doc %{_pkgdocdir}
%{_bindir}/star %{_bindir}/star
%{_bindir}/ustar %{_bindir}/ustar
%{_mandir}/man1/star.1* %{_mandir}/man1/star.1*
@ -215,19 +211,19 @@ fi
%{_mandir}/man5/star.5* %{_mandir}/man5/star.5*
%files -n scpio %files -n scpio
%doc %{general_docs} %general_docs
%doc %{_mandir}/man1/scpio.1* %doc %{_mandir}/man1/scpio.1*
%{_bindir}/scpio %{_bindir}/scpio
%files -n spax %files -n spax
%doc %{general_docs} %general_docs
%doc %{_mandir}/man1/spax.1* %doc %{_mandir}/man1/spax.1*
%{_bindir}/spax %{_bindir}/spax
%ghost %verify(not md5 size mode mtime) %{ALT_LINK} %ghost %verify(not md5 size mode mtime) %{ALT_LINK}
%ghost %verify(not md5 size mode mtime) %{ALT_SL1_LINK} %ghost %verify(not md5 size mode mtime) %{ALT_SL1_LINK}
%files -n rmt %files -n rmt
%doc %{general_docs} %general_docs
%{_sbindir}/rmt %{_sbindir}/rmt
%{_mandir}/man1/rmt.1* %{_mandir}/man1/rmt.1*
%config %{_sysconfdir}/default/rmt %config %{_sysconfdir}/default/rmt
@ -239,6 +235,9 @@ fi
%{_sysconfdir}/rmt %{_sysconfdir}/rmt
%changelog %changelog
* Fri Jun 27 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.3-1
- rebase to 1.5.3
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-11 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild