update to latest upstream release

This commit is contained in:
Ondrej Vasik 2008-12-03 12:49:56 +00:00
parent e217cf0181
commit aaca4caab8
5 changed files with 18 additions and 17 deletions

View File

@ -1 +1 @@
star-1.5a84.tar.bz2 star-1.5a89.tar.bz2

View File

@ -1 +1 @@
7b3860592468e46396fe34157f338d42 star-1.5a84.tar.bz2 b75a14385aeaa7b8213d481c758f766d star-1.5a89.tar.bz2

View File

@ -1,6 +1,6 @@
--- star-1.5/star/checkerr.c.orig-segv 2006-10-31 18:06:25.000000000 +0100 --- star-1.5/star/checkerr.c.orig-segv 2006-10-31 18:06:25.000000000 +0100
+++ star-1.5/star/checkerr.c 2007-08-27 11:42:39.000000000 +0200 +++ star-1.5/star/checkerr.c 2007-08-27 11:42:39.000000000 +0200
@@ -183,44 +183,45 @@ LOCAL struct eflags { @@ -183,39 +183,45 @@ LOCAL struct eflags {
*/ */
LOCAL UInt32_t LOCAL UInt32_t
errflags(eflag, doexit) errflags(eflag, doexit)
@ -11,13 +11,10 @@
{ {
- register char *p = eflag; - register char *p = eflag;
- char *ef = _endword(eflag); - char *ef = _endword(eflag);
- char ec;
- register struct eflags *ep; - register struct eflags *ep;
- register int slen; - register int slen;
- register UInt32_t nflags = 0; - register UInt32_t nflags = 0;
- -
- ec = *ef;
- *ef = '\0';
- do { - do {
- for (ep = eflags; ep->fname; ep++) { - for (ep = eflags; ep->fname; ep++) {
- slen = strlen(ep->fname); - slen = strlen(ep->fname);
@ -31,13 +28,11 @@
- if (ep->fname == NULL) { - if (ep->fname == NULL) {
- if (doexit) - if (doexit)
- comerrno(EX_BAD, "Bad flag '%s'\n", p); - comerrno(EX_BAD, "Bad flag '%s'\n", p);
- *ef = ec; /* Restore old character */
- return (0); - return (0);
- } - }
- p = strchr(p, '|'); - p = strchr(p, '|');
- } while (p && *p++ == '|'); - } while (p < ef && p && *p++ == '|');
- -
- *ef = ec; /* Restore old character */
- if ((nflags & ~(UInt32_t)(E_ABORT|E_WARN)) == 0) { - if ((nflags & ~(UInt32_t)(E_ABORT|E_WARN)) == 0) {
- if (doexit) - if (doexit)
- comerrno(EX_BAD, "Bad error condition '%s'.\n", eflag); - comerrno(EX_BAD, "Bad error condition '%s'.\n", eflag);

View File

@ -72,8 +72,8 @@
/* /*
--- star-1.5/star/Makefile.selinux 2007-06-16 16:46:18.000000000 +0200 --- star-1.5/star/Makefile.selinux 2007-06-16 16:46:18.000000000 +0200
+++ star-1.5/star/Makefile 2007-08-24 11:51:13.000000000 +0200 +++ star-1.5/star/Makefile 2007-08-24 11:51:13.000000000 +0200
@@ -1,64 +1,19 @@ @@ -1,67 +1,19 @@
-#ident @(#)star_fat.mk 1.21 07/06/16 -#ident @(#)star_fat.mk 1.22 08/01/02
+#ident @(#)all.mk 1.1 05/02/16 +#ident @(#)all.mk 1.1 05/02/16
########################################################################### ###########################################################################
-#include $(MAKE_M_ARCH).def -#include $(MAKE_M_ARCH).def
@ -84,7 +84,7 @@
# #
-# This is star_fat.mk, it creates one "fat" binary for all functionality. -# This is star_fat.mk, it creates one "fat" binary for all functionality.
+# This is all.mk, it creates sevral binaries, one for each function. +# This is all.mk, it creates several binaries, one for each function.
# #
-# If you like to create non "fat" binaries, remove Makefile -# If you like to create non "fat" binaries, remove Makefile
-# and copy all.mk to Makefile. -# and copy all.mk to Makefile.
@ -129,6 +129,9 @@
-#LIBS= -lunos -#LIBS= -lunos
-#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib -#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) -LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
-#
-# Wenn -lfind, dann auch $(LIB_INTL)
-#
-XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \ -XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
- spaxman.mk suntarman.mk Makefile.dfl Makefile.doc - spaxman.mk suntarman.mk Makefile.dfl Makefile.doc
@ -181,9 +184,9 @@
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib #LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) -LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX) +LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \ #
spaxman.mk suntarman.mk Makefile.dfl Makefile.doc # Wenn -lfind, dann auch $(LIB_INTL)
#
--- star-1.5/star/star.c.selinux 2007-07-16 09:43:14.000000000 +0200 --- star-1.5/star/star.c.selinux 2007-07-16 09:43:14.000000000 +0200
+++ star-1.5/star/star.c 2007-08-24 11:51:13.000000000 +0200 +++ star-1.5/star/star.c 2007-08-24 11:51:13.000000000 +0200
@@ -45,6 +45,10 @@ @@ -45,6 +45,10 @@

View File

@ -3,7 +3,7 @@
%endif %endif
Summary: An archiving tool with ACL support Summary: An archiving tool with ACL support
Name: star Name: star
Version: 1.5a84 Version: 1.5a89
Release: 6%{?dist} Release: 6%{?dist}
URL: http://cdrecord.berlios.de/old/private/star.html URL: http://cdrecord.berlios.de/old/private/star.html
Source: ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}.tar.bz2 Source: ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}.tar.bz2
@ -98,8 +98,11 @@ rm -rf ${RPM_BUILD_ROOT}
%{_mandir}/man1/spax.1* %{_mandir}/man1/spax.1*
%changelog %changelog
* Wed Dec 03 2008 Ondrej Vasik <ovasik@redhat.com> 1.5a89-1
- update to latest upstream release
* Fri Jun 06 2008 Dennis Gilmore <dennis@ausil.us> 1.5a84-6 * Fri Jun 06 2008 Dennis Gilmore <dennis@ausil.us> 1.5a84-6
- add sparcv9 support - add sparcv9 support
* Mon May 12 2008 Peter Vrabec <pvrabec@redhat.com> 1.5a84-5 * Mon May 12 2008 Peter Vrabec <pvrabec@redhat.com> 1.5a84-5
- add super-H(sh3,4) architecture support (#442883) - add super-H(sh3,4) architecture support (#442883)