This commit is contained in:
Peter Vrabec 2005-11-08 15:59:33 +00:00
parent c217751bde
commit 0a28ddf179
4 changed files with 146 additions and 154 deletions

View File

@ -1 +1 @@
star-1.5a68.tar.bz2
star-1.5a69.tar.bz2

View File

@ -1 +1 @@
3ef28c02ec0ab85cb525652d1961df53 star-1.5a68.tar.bz2
3d70f46190b902ed252ad48d4bfd1345 star-1.5a69.tar.bz2

View File

@ -1,7 +1,6 @@
diff --git a/conf/configure.in b/conf/configure.in
--- a/conf/configure.in
+++ b/conf/configure.in
@@ -312,6 +312,15 @@ if test "$ac_cv_header_attr_xattr_h" = y
--- star-1.5/conf/configure.in.selinux 2005-10-11 04:51:05.000000000 -0400
+++ star-1.5/conf/configure.in 2005-11-08 16:36:57.000000000 -0500
@@ -314,6 +314,15 @@
LIBS="$ac_save_LIBS"
fi
@ -17,106 +16,24 @@ diff --git a/conf/configure.in b/conf/configure.in
dnl Checks for OS madness.
AC_BROKEN_LINUX_EXT2_FS_H
AC_BROKEN_SRC_LINUX_EXT2_FS_H
@@ -327,5 +336,6 @@ AC_SUBST(scsi_lib)
@@ -329,5 +338,6 @@
AC_SUBST(lib_acl)
AC_SUBST(lib_acl_test)
AC_SUBST(lib_attr)
+AC_SUBST(lib_selinux)
AC_OUTPUT(rules.cnf)
diff --git a/conf/rules.cnf.in b/conf/rules.cnf.in
--- a/conf/rules.cnf.in
+++ b/conf/rules.cnf.in
@@ -9,3 +9,5 @@ LIB_CRYPT= @lib_crypt@
--- star-1.5/conf/rules.cnf.in.selinux 2004-10-07 14:32:26.000000000 -0400
+++ star-1.5/conf/rules.cnf.in 2005-11-08 16:36:57.000000000 -0500
@@ -9,3 +9,5 @@
LIB_ACL= @lib_acl@
LIB_ACL_TEST= @lib_acl_test@
LIB_ATTR = @lib_attr@
+LIB_SELINUX = @lib_selinux@
+
diff --git a/star/Makefile b/star/Makefile
--- a/star/Makefile
+++ b/star/Makefile
@@ -24,6 +24,7 @@ CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP
CPPOPTS += -DUSE_LARGEFILES
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
+CPPOPTS += -DWITH_SELINUX
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DCOPY_LINKS_DELAYED
CPPOPTS += -DSTAR_FAT
@@ -43,7 +44,7 @@ HFILES= star.h starsubs.h dirtime.h xta
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
spaxman.mk suntarman.mk Makefile.dfl
diff --git a/star/cpio.mk b/star/cpio.mk
--- a/star/cpio.mk
+++ b/star/cpio.mk
@@ -18,6 +18,7 @@ CPPOPTS += -DUSE_LARGEFILES
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
+CPPOPTS += -DWITH_SELINUX
CFILES= cpio.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -34,7 +35,7 @@ HFILES= star.h starsubs.h dirtime.h xta
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= scpioman.mk
###########################################################################
diff --git a/star/extract.c b/star/extract.c
--- a/star/extract.c
+++ b/star/extract.c
@@ -209,6 +209,16 @@ extract(vhname)
if (prblockno)
(void) tblocks(); /* set curblockno */
+#ifdef WITH_SELINUX
+ if (!to_stdout && selinux_enabled) {
+ if (setselinux(&finfo) == FALSE) {
+ errmsgno(EX_BAD,
+ "Can not setup security context for '%s'. Not created.\n",
+ finfo.f_name);
+ }
+ }
+#endif
+
if (finfo.f_xflags & XF_BAD_META) {
if (!void_bad(&finfo))
break;
diff --git a/star/gnutar.mk b/star/gnutar.mk
--- a/star/gnutar.mk
+++ b/star/gnutar.mk
@@ -18,6 +18,7 @@ CPPOPTS += -DUSE_LARGEFILES
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
+CPPOPTS += -DWITH_SELINUX
CFILES= gnutar.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -34,7 +35,7 @@ HFILES= star.h starsubs.h dirtime.h xta
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= gnutarman.mk
###########################################################################
diff --git a/star/pax.mk b/star/pax.mk
--- a/star/pax.mk
+++ b/star/pax.mk
@@ -17,6 +17,7 @@ CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP
--- star-1.5/star/pax.mk.selinux 2005-02-09 18:31:56.000000000 -0500
+++ star-1.5/star/pax.mk 2005-11-08 16:36:57.000000000 -0500
@@ -17,6 +17,7 @@
CPPOPTS += -DUSE_LARGEFILES
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
@ -124,7 +41,7 @@ diff --git a/star/pax.mk b/star/pax.mk
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DPAX
CFILES= pax.c header.c cpiohdr.c xheader.c xattr.c \
@@ -35,7 +36,7 @@ HFILES= star.h starsubs.h dirtime.h xta
@@ -35,7 +36,7 @@
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
@ -133,12 +50,68 @@ diff --git a/star/pax.mk b/star/pax.mk
XMK_FILE= spaxman.mk
###########################################################################
diff --git a/star/star.c b/star/star.c
--- a/star/star.c
+++ b/star/star.c
@@ -40,6 +40,10 @@ static char sccsid[] =
#endif
#include "dumpdate.h"
--- star-1.5/star/star.mk.selinux 2005-08-28 07:22:30.000000000 -0400
+++ star-1.5/star/star.mk 2005-11-08 16:36:57.000000000 -0500
@@ -19,6 +19,7 @@
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DCOPY_LINKS_DELAYED
+CPPOPTS += -DWITH_SELINUX
CFILES= star.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -35,7 +36,7 @@
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk
###########################################################################
--- star-1.5/star/star_fat.mk.selinux 2005-11-01 15:53:51.000000000 -0500
+++ star-1.5/star/star_fat.mk 2005-11-08 16:36:57.000000000 -0500
@@ -28,6 +28,7 @@
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DCOPY_LINKS_DELAYED
CPPOPTS += -DSTAR_FAT
+CPPOPTS += -DWITH_SELINUX
CFILES= star_fat.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -48,7 +49,7 @@
find.h gettnum.h fetchdir.h walk.h find_list.h mem.h find_misc.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
spaxman.mk suntarman.mk Makefile.dfl
--- star-1.5/star/Makefile.selinux 2005-11-01 15:53:51.000000000 -0500
+++ star-1.5/star/Makefile 2005-11-08 16:36:57.000000000 -0500
@@ -25,6 +25,7 @@
CPPOPTS += -DUSE_FIND
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
+CPPOPTS += -DWITH_SELINUX
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DCOPY_LINKS_DELAYED
CPPOPTS += -DSTAR_FAT
@@ -48,7 +49,7 @@
find.h gettnum.h fetchdir.h walk.h find_list.h mem.h find_misc.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
spaxman.mk suntarman.mk Makefile.dfl
--- star-1.5/star/star.c.selinux 2005-11-01 17:15:05.000000000 -0500
+++ star-1.5/star/star.c 2005-11-08 16:36:57.000000000 -0500
@@ -44,6 +44,10 @@
#include "starsubs.h"
#include "checkerr.h"
+#ifdef WITH_SELINUX
+int selinux_enabled=0;
@ -147,7 +120,7 @@ diff --git a/star/star.c b/star/star.c
EXPORT int main __PR((int ac, char **av));
LOCAL void star_create __PR((int ac, char *const *av));
LOCAL void checkdumptype __PR((GINFO *gp));
@@ -358,6 +362,11 @@ main(ac, av)
@@ -374,6 +378,11 @@
comerr("Panic cannot set back effective uid.\n");
}
my_uid = geteuid();
@ -159,50 +132,85 @@ diff --git a/star/star.c b/star/star.c
/*
* WARNING: We now are no more able to open a new remote connection
* unless we have been called by root.
diff --git a/star/star.mk b/star/star.mk
--- a/star/star.mk
+++ b/star/star.mk
@@ -19,6 +19,7 @@ CPPOPTS += -DUSE_ACL
--- star-1.5/star/extract.c.selinux 2005-11-08 16:35:01.000000000 -0500
+++ star-1.5/star/extract.c 2005-11-08 16:41:18.000000000 -0500
@@ -213,6 +213,16 @@
if (prblockno)
(void) tblocks(); /* set curblockno */
+#ifdef WITH_SELINUX
+ if (!to_stdout && selinux_enabled) {
+ if (setselinux(&finfo) == FALSE) {
+ errmsgno(EX_BAD,
+ "Can not setup security context for '%s'. Not created.\n",
+ finfo.f_name);
+ }
+ }
+#endif
+
if (finfo.f_flags & F_BAD_META) {
if (!void_bad(&finfo))
break;
--- star-1.5/star/cpio.mk.selinux 2005-02-09 18:31:56.000000000 -0500
+++ star-1.5/star/cpio.mk 2005-11-08 16:36:57.000000000 -0500
@@ -18,6 +18,7 @@
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DCOPY_LINKS_DELAYED
+CPPOPTS += -DWITH_SELINUX
CFILES= star.c header.c cpiohdr.c xheader.c xattr.c \
CFILES= cpio.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -35,7 +36,7 @@ HFILES= star.h starsubs.h dirtime.h xta
@@ -34,7 +35,7 @@
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk
XMK_FILE= scpioman.mk
###########################################################################
diff --git a/star/star_fat.mk b/star/star_fat.mk
--- a/star/star_fat.mk
+++ b/star/star_fat.mk
@@ -27,6 +27,7 @@ CPPOPTS += -DUSE_XATTR
--- star-1.5/star/gnutar.mk.selinux 2005-02-09 18:31:56.000000000 -0500
+++ star-1.5/star/gnutar.mk 2005-11-08 16:36:57.000000000 -0500
@@ -18,6 +18,7 @@
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
CPPOPTS += -DCOPY_LINKS_DELAYED
CPPOPTS += -DSTAR_FAT
+CPPOPTS += -DWITH_SELINUX
CFILES= star_fat.c header.c cpiohdr.c xheader.c xattr.c \
CFILES= gnutar.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -43,7 +44,7 @@ HFILES= star.h starsubs.h dirtime.h xta
@@ -34,7 +35,7 @@
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
spaxman.mk suntarman.mk Makefile.dfl
XMK_FILE= gnutarman.mk
diff --git a/star/starsubs.h b/star/starsubs.h
--- a/star/starsubs.h
+++ b/star/starsubs.h
@@ -293,6 +293,11 @@ extern BOOL get_number __PR((char *keywo
###########################################################################
--- star-1.5/star/suntar.mk.selinux 2005-02-09 18:31:56.000000000 -0500
+++ star-1.5/star/suntar.mk 2005-11-08 16:36:57.000000000 -0500
@@ -18,6 +18,7 @@
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
+CPPOPTS += -DWITH_SELINUX
CFILES= suntar.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -34,7 +35,7 @@
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= suntarman.mk
###########################################################################
--- star-1.5/star/starsubs.h.selinux 2005-11-01 16:32:18.000000000 -0500
+++ star-1.5/star/starsubs.h 2005-11-08 16:36:57.000000000 -0500
@@ -301,6 +301,11 @@
extern BOOL get_xattr __PR((register FINFO *info));
extern BOOL set_xattr __PR((register FINFO *info));
extern void free_xattr __PR((star_xattr_t **xattr));
@ -214,30 +222,9 @@ diff --git a/star/starsubs.h b/star/starsubs.h
#endif
/*
diff --git a/star/suntar.mk b/star/suntar.mk
--- a/star/suntar.mk
+++ b/star/suntar.mk
@@ -18,6 +18,7 @@ CPPOPTS += -DUSE_LARGEFILES
CPPOPTS += -DUSE_ACL
CPPOPTS += -DUSE_XATTR
CPPOPTS += -DUSE_FFLAGS
+CPPOPTS += -DWITH_SELINUX
CFILES= suntar.c header.c cpiohdr.c xheader.c xattr.c \
list.c extract.c create.c append.c diff.c restore.c \
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
@@ -34,7 +35,7 @@ HFILES= star.h starsubs.h dirtime.h xta
checkerr.h dumpdate.h bitstring.h
#LIBS= -lunos
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
XMK_FILE= suntarman.mk
###########################################################################
diff --git a/star/xattr.c b/star/xattr.c
--- a/star/xattr.c
+++ b/star/xattr.c
@@ -159,6 +159,29 @@ fail:
--- star-1.5/star/xattr.c.selinux 2005-09-02 18:29:35.000000000 -0400
+++ star-1.5/star/xattr.c 2005-11-08 16:36:57.000000000 -0500
@@ -169,6 +169,29 @@
#endif /* USE_XATTR */
}
@ -267,7 +254,7 @@ diff --git a/star/xattr.c b/star/xattr.c
/* ARGSUSED */
EXPORT BOOL
set_xattr(info)
@@ -171,6 +194,10 @@ set_xattr(info)
@@ -181,6 +204,10 @@
return (TRUE);
for (xap = info->f_xattr; xap->name != NULL; xap++) {

View File

@ -3,13 +3,15 @@
%endif
Summary: An archiving tool with ACL support
Name: star
Version: 1.5a68
Version: 1.5a69
Release: 1
Source: ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}.tar.bz2
Patch0: star-1.5-newMake.patch
Patch1: star-1.5-newMake.patch
Patch2: star-1.5-nofsync.patch
Patch3: star-1.5-davej.patch
Patch4: star-1.5-selinux.patch
Patch5: star-1.5-defineULLONG.patch
License: CDDL 1.0
Group: Applications/Archiving
BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -21,13 +23,13 @@ and can restore individual files from the archive. Star supports ACL.
%prep
%setup -q -n star-1.5
%patch0 -p1 -b .newMake
%patch1 -p1 -b .newMake
%patch2 -p1 -b .nofsync
%patch3 -p1 -b .davej
%if %{WITH_SELINUX}
%patch4 -p1 -b .selinux
%endif
%patch5 -p1 -b .defineULLONG
for PLAT in x86_64 ppc64 s390 s390x; do
for AFILE in gcc cc; do
@ -100,6 +102,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_mandir}/man1/spax.1*
%changelog
* Tue Nov 08 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a69-1
- upgrade
* Mon Oct 10 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a68-1
- upgrade