Fix conflict in patches
This commit is contained in:
parent
39f9584222
commit
5421a7ac42
@ -1,7 +1,7 @@
|
|||||||
From 05c2c3047912fca1c1a35ab1c8d3157b05383495 Mon Sep 17 00:00:00 2001
|
From 408edbc9ef7b7467c153f2498d7034962222664c Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Pavel=20B=C5=99ezina?= <pbrezina@redhat.com>
|
From: =?UTF-8?q?Pavel=20B=C5=99ezina?= <pbrezina@redhat.com>
|
||||||
Date: Mon, 3 Apr 2017 12:56:01 +0200
|
Date: Mon, 3 Apr 2017 12:56:01 +0200
|
||||||
Subject: [PATCH] responders: do not leak selinux context on clients
|
Subject: [PATCH 1/2] responders: do not leak selinux context on clients
|
||||||
destruction
|
destruction
|
||||||
MIME-Version: 1.0
|
MIME-Version: 1.0
|
||||||
Content-Type: text/plain; charset=UTF-8
|
Content-Type: text/plain; charset=UTF-8
|
||||||
@ -19,7 +19,7 @@ Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
|
|||||||
1 file changed, 19 insertions(+), 1 deletion(-)
|
1 file changed, 19 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/src/responder/common/responder_common.c b/src/responder/common/responder_common.c
|
diff --git a/src/responder/common/responder_common.c b/src/responder/common/responder_common.c
|
||||||
index 154d7dc7718c437d10e152fcba98161e2034fb14..67e1deefdfde19c95a68029b11099579d851513f 100644
|
index 76f43609651217e537ffa515aaf5b5caa98a2e90..b5b4a3284cf288f1bd328fee83877e9ba6cb61e4 100644
|
||||||
--- a/src/responder/common/responder_common.c
|
--- a/src/responder/common/responder_common.c
|
||||||
+++ b/src/responder/common/responder_common.c
|
+++ b/src/responder/common/responder_common.c
|
||||||
@@ -97,7 +97,7 @@ static errno_t get_client_cred(struct cli_ctx *cctx)
|
@@ -97,7 +97,7 @@ static errno_t get_client_cred(struct cli_ctx *cctx)
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 78a08d30b5fbf6e1e3b589e0cf67022e0c1faa33 Mon Sep 17 00:00:00 2001
|
From 3ebb0b03c35c5b733d7bdb53b434950711461bbb Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Michal=20=C5=BDidek?= <mzidek@redhat.com>
|
From: =?UTF-8?q?Michal=20=C5=BDidek?= <mzidek@redhat.com>
|
||||||
Date: Wed, 8 Feb 2017 12:01:37 +0100
|
Date: Wed, 8 Feb 2017 12:01:37 +0100
|
||||||
Subject: [PATCH] selinux: Do not fail if SELinux is not managed
|
Subject: [PATCH 2/2] selinux: Do not fail if SELinux is not managed
|
||||||
MIME-Version: 1.0
|
MIME-Version: 1.0
|
||||||
Content-Type: text/plain; charset=UTF-8
|
Content-Type: text/plain; charset=UTF-8
|
||||||
Content-Transfer-Encoding: 8bit
|
Content-Transfer-Encoding: 8bit
|
||||||
@ -23,14 +23,14 @@ Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
|
|||||||
5 files changed, 49 insertions(+), 24 deletions(-)
|
5 files changed, 49 insertions(+), 24 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
index 5264183cd199be464e5e99d2ab31ba4fcd77c5ec..d45c0ff757dfae378c71c6f8850fddce2c61cad8 100644
|
index 45b04de2638a745a189c0b4e5794ccd29913b10d..fed51a9d09d867856cbf26bfcd99df3b89d4859d 100644
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -4040,6 +4040,7 @@ selinux_child_SOURCES = \
|
@@ -3827,6 +3827,7 @@ selinux_child_SOURCES = \
|
||||||
|
src/util/sss_semanage.c \
|
||||||
src/util/atomic_io.c \
|
src/util/atomic_io.c \
|
||||||
src/util/util.c \
|
src/util/util.c \
|
||||||
src/util/util_ext.c \
|
+ src/util/util_errors.c \
|
||||||
+ src/util/util_errors.c
|
|
||||||
$(NULL)
|
$(NULL)
|
||||||
selinux_child_CFLAGS = \
|
selinux_child_CFLAGS = \
|
||||||
$(AM_CFLAGS) \
|
$(AM_CFLAGS) \
|
||||||
@ -182,10 +182,10 @@ index fe06bee1dfec3abca3aa3cd5e85e55386ac11343..0da97aad4d8eba733b131c2749932e03
|
|||||||
}
|
}
|
||||||
|
|
||||||
diff --git a/src/util/util_errors.c b/src/util/util_errors.c
|
diff --git a/src/util/util_errors.c b/src/util/util_errors.c
|
||||||
index 466a3b4062f39b29d831a5d8a62dc8d576eb2e97..97eaf160f20bcc8cfe52254070a2d182e19addd4 100644
|
index 17388c997db5315c2491af1021e75aff07632488..97a7853827bb3a4a9c49f0306ca52be0f9aa8389 100644
|
||||||
--- a/src/util/util_errors.c
|
--- a/src/util/util_errors.c
|
||||||
+++ b/src/util/util_errors.c
|
+++ b/src/util/util_errors.c
|
||||||
@@ -75,6 +75,7 @@ struct err_string error_to_str[] = {
|
@@ -74,6 +74,7 @@ struct err_string error_to_str[] = {
|
||||||
{ "Cannot connect to system bus" }, /* ERR_NO_SYSBUS */
|
{ "Cannot connect to system bus" }, /* ERR_NO_SYSBUS */
|
||||||
{ "LDAP search returned a referral" }, /* ERR_REFERRAL */
|
{ "LDAP search returned a referral" }, /* ERR_REFERRAL */
|
||||||
{ "Error setting SELinux user context" }, /* ERR_SELINUX_CONTEXT */
|
{ "Error setting SELinux user context" }, /* ERR_SELINUX_CONTEXT */
|
||||||
@ -194,10 +194,10 @@ index 466a3b4062f39b29d831a5d8a62dc8d576eb2e97..97eaf160f20bcc8cfe52254070a2d182
|
|||||||
{ "Time specification not supported" }, /* ERR_TIMESPEC_NOT_SUPPORTED */
|
{ "Time specification not supported" }, /* ERR_TIMESPEC_NOT_SUPPORTED */
|
||||||
{ "Invalid SSSD configuration detected" }, /* ERR_INVALID_CONFIG */
|
{ "Invalid SSSD configuration detected" }, /* ERR_INVALID_CONFIG */
|
||||||
diff --git a/src/util/util_errors.h b/src/util/util_errors.h
|
diff --git a/src/util/util_errors.h b/src/util/util_errors.h
|
||||||
index 2f90c0a5d65325a431a8e4d9a480170808c9198e..4a250bf0339ba689680c155fa8e6d43f42c2467e 100644
|
index 7aacad26084a3a2af6333988f07db865f6a4d299..8d0d99b4cc86812d9c67d9319a23055c1c8fa4dc 100644
|
||||||
--- a/src/util/util_errors.h
|
--- a/src/util/util_errors.h
|
||||||
+++ b/src/util/util_errors.h
|
+++ b/src/util/util_errors.h
|
||||||
@@ -97,6 +97,7 @@ enum sssd_errors {
|
@@ -96,6 +96,7 @@ enum sssd_errors {
|
||||||
ERR_NO_SYSBUS,
|
ERR_NO_SYSBUS,
|
||||||
ERR_REFERRAL,
|
ERR_REFERRAL,
|
||||||
ERR_SELINUX_CONTEXT,
|
ERR_SELINUX_CONTEXT,
|
||||||
|
Loading…
Reference in New Issue
Block a user