Updating to SSSD 1.0.1
Fixes: CVE-2010-0014
This commit is contained in:
parent
d9fd9eee1e
commit
2de26e9e6f
@ -1 +1 @@
|
||||
sssd-1.0.0.tar.gz
|
||||
sssd-1.0.1.tar.gz
|
||||
|
@ -1,47 +0,0 @@
|
||||
From a79fed1bece2e33759546f97ce0f22af3745ac80 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Mon, 21 Dec 2009 13:03:03 -0500
|
||||
Subject: [PATCH] Allow debug_timestamps setting on a per-domain basis
|
||||
|
||||
This was missing from the SSSDConfig API, though it was supported
|
||||
by the daemon.
|
||||
---
|
||||
server/config/SSSDConfigTest.py | 2 ++
|
||||
server/config/etc/sssd.api.conf | 1 +
|
||||
2 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/server/config/SSSDConfigTest.py b/server/config/SSSDConfigTest.py
|
||||
index f893d98..1e79342 100755
|
||||
--- a/server/config/SSSDConfigTest.py
|
||||
+++ b/server/config/SSSDConfigTest.py
|
||||
@@ -372,6 +372,7 @@ class SSSDConfigTestSSSDDomain(unittest.TestCase):
|
||||
options = domain.list_options()
|
||||
control_list = [
|
||||
'debug_level',
|
||||
+ 'debug_timestamps',
|
||||
'min_id',
|
||||
'max_id',
|
||||
'timeout',
|
||||
@@ -586,6 +587,7 @@ class SSSDConfigTestSSSDDomain(unittest.TestCase):
|
||||
options = domain.list_options()
|
||||
control_list = [
|
||||
'debug_level',
|
||||
+ 'debug_timestamps',
|
||||
'min_id',
|
||||
'max_id',
|
||||
'timeout',
|
||||
diff --git a/server/config/etc/sssd.api.conf b/server/config/etc/sssd.api.conf
|
||||
index c8ddae4..bdb6aab 100644
|
||||
--- a/server/config/etc/sssd.api.conf
|
||||
+++ b/server/config/etc/sssd.api.conf
|
||||
@@ -42,6 +42,7 @@ chpass_provider = str, None
|
||||
[domain]
|
||||
# Options available to all domains
|
||||
debug_level = int, None, 0
|
||||
+debug_timestamps = bool, None
|
||||
command = str, None
|
||||
min_id = int, None, 1000
|
||||
max_id = int, None
|
||||
--
|
||||
1.6.5.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
b4a21cd65157e775dd5843d6a7ded10d sssd-1.0.0.tar.gz
|
||||
695a5fb6003dad6f4af65146e4f039bf sssd-1.0.1.tar.gz
|
||||
|
10
sssd.spec
10
sssd.spec
@ -2,8 +2,8 @@
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import *; import sys; sys.stdout.write(get_python_lib())")}
|
||||
|
||||
Name: sssd
|
||||
Version: 1.0.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.0.1
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
Summary: System Security Services Daemon
|
||||
# The entire source code is GPLv3+ except replace/ which is LGPLv3+
|
||||
@ -12,8 +12,6 @@ URL: http://fedorahosted.org/sssd
|
||||
Source: https://fedorahosted.org/released/sssd/sssd-%{version}.tar.gz
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
Patch1: cfg_dbg_timestamps.patch
|
||||
|
||||
### Patches ###
|
||||
|
||||
### Dependencies ###
|
||||
@ -80,7 +78,6 @@ service.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .cfg_dbg_timestamps
|
||||
|
||||
%build
|
||||
NSS_LIBS=-lnss3 \
|
||||
@ -208,6 +205,9 @@ fi
|
||||
%postun client -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Jan 11 2010 Stephen Gallagher <sgallagh@redhat.com> - 1.0.1-1
|
||||
- Fix CVE-2010-0014
|
||||
|
||||
* Mon Dec 21 2009 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
|
||||
- Patch SSSDConfig API to address
|
||||
- https://bugzilla.redhat.com/show_bug.cgi?id=549482
|
||||
|
Loading…
Reference in New Issue
Block a user