Update to 4.2 release.

This commit is contained in:
Bruno Wolff III 2011-03-01 22:25:52 -06:00
parent 2738394427
commit e59d8926b6
5 changed files with 20 additions and 44 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@ squashfs-4.1.tar.bz2
/squashfs-4.2-2010-12-23.bz2 /squashfs-4.2-2010-12-23.bz2
/squashfs-4.2-20101223.bz2 /squashfs-4.2-20101223.bz2
/squashfs-4.2-20101231.bz2 /squashfs-4.2-20101231.bz2
/squashfs4.2.tar.gz

View File

@ -1 +1 @@
3f5e167796a3b2dbf1a4457d27c72e3c squashfs-4.2-20101231.bz2 1b7a781fb4cf8938842279bd3e8ee852 squashfs4.2.tar.gz

View File

@ -1,12 +0,0 @@
diff -up squashfs-tools/xz_wrapper.c.bigendian squashfs-tools/xz_wrapper.c
--- squashfs-tools/xz_wrapper.c.bigendian 2011-01-11 14:16:43.000000000 +0100
+++ squashfs-tools/xz_wrapper.c 2011-01-11 14:16:48.000000000 +0100
@@ -214,7 +214,7 @@ static int xz_extract_options(int block_
dictionary_size = block_size;
flags = 0;
} else {
- SQUASHFS_INSWAP_COMP_OPTS(&comp_opts);
+ SQUASHFS_INSWAP_COMP_OPTS(comp_opts);
dictionary_size = comp_opts->dictionary_size;
flags = comp_opts->flags;

View File

@ -1,13 +0,0 @@
--- squashfs-tools/Makefile.orig 2010-12-31 15:36:47.000000000 -0600
+++ squashfs-tools/Makefile 2011-01-01 10:58:33.000000000 -0600
@@ -100,8 +100,8 @@
UNSQUASHFS_OBJS = unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o \
unsquash-4.o swap.o compressor.o
-CFLAGS = $(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
- -D_GNU_SOURCE -DCOMP_DEFAULT=\"$(COMP_DEFAULT)\" -O2 -Wall
+CFLAGS = $(RPM_OPT_FLAGS) $(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -D_GNU_SOURCE -DCOMP_DEFAULT=\"$(COMP_DEFAULT)\"
LIBS = -lpthread -lm
ifdef GZIP_SUPPORT

View File

@ -1,18 +1,12 @@
Summary: Utility for the creation of squashfs filesystems Summary: Utility for the creation of squashfs filesystems
Name: squashfs-tools Name: squashfs-tools
Version: 4.2 Version: 4.2
%global cvsdate 20101231 Release: 1%{?dist}
Release: 0.4.%{cvsdate}%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Base Group: System Environment/Base
URL: http://squashfs.sf.net URL: http://squashfs.sourceforge.net/
# cvs -z3 -d:pserver:anonymous@squashfs.cvs.sourceforge.net:/cvsroot/squashfs export -D "%{cvsdate} 2359 UTC" -d squashfs-%{version}-%{cvsdate} squashfs Source0: http://downloads.sourceforge.net/squashfs/squashfs%{version}.tar.gz
# tar cfj squashfs-%{version}-%{cvsdate}.bz2 squashfs-%{version}-%{cvsdate}
Source0: squashfs-%{version}-%{cvsdate}.bz2
Patch0: squashfs-cflags.patch
Patch1: squashfs-compressors.patch Patch1: squashfs-compressors.patch
# https://sourceforge.net/tracker/?func=detail&aid=3155564&group_id=63835&atid=505343
Patch2: squashfs-bigendian.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: zlib-devel BuildRequires: zlib-devel
BuildRequires: xz-devel BuildRequires: xz-devel
@ -24,32 +18,38 @@ Squashfs is a highly compressed read-only filesystem for Linux. This package
contains the utilities for manipulating squashfs filesystems. contains the utilities for manipulating squashfs filesystems.
%prep %prep
%setup -q -n squashfs-%{version}-%{cvsdate} %setup -q
%patch0 -p0 %patch0 -p0
%patch1 -p0 %patch1 -p0
%patch2 -p0
%build %build
pushd squashfs-tools pushd squashfs-tools
make RPM_OPT_FLAGS="%{optflags}" make CFLAGS="%{optflags}"
%install %install
rm -rf $RPM_BUILD_ROOT mkdir -p %{buildroot}/sbin %{buildroot}/usr/sbin
mkdir -p $RPM_BUILD_ROOT/sbin $RPM_BUILD_ROOT/usr/sbin install -m 755 squashfs-tools/mksquashfs %{buildroot}/sbin/mksquashfs
install -m 755 squashfs-tools/mksquashfs $RPM_BUILD_ROOT/sbin/mksquashfs install -m 755 squashfs-tools/unsquashfs %{buildroot}%{_sbindir}/unsquashfs
install -m 755 squashfs-tools/unsquashfs $RPM_BUILD_ROOT%{_sbindir}/unsquashfs
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf %{buildroot}
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc README %doc README ACKNOWLEDGEMENTS DONATIONS PERFORMANCE.README README-4.2 CHANGES pseudo-file.example COPYING
/sbin/mksquashfs /sbin/mksquashfs
%{_sbindir}/unsquashfs %{_sbindir}/unsquashfs
%changelog %changelog
* Tue Mar 01 2011 Bruno Wolff III <bruno@wolff.to> - 4.2-1
- 4.2 is released.
- Bugfix for bad data causing crash.
- Include doc files added for release.
- Big endian patch is now upstream.
- Buildroot tag isn't needed any more.
- We can now specify CFLAGS on the make call.
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-0.4.20101231 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-0.4.20101231
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild