Update printf formats to match datatypes after CVE patch

This commit is contained in:
Bruno Wolff III 2015-06-24 14:27:31 -05:00
parent 2517a973ac
commit af393379e3
2 changed files with 15 additions and 1 deletions

11
local-cve-fix.patch Normal file
View File

@ -0,0 +1,11 @@
--- squashfs-tools/unsquash-4.c.orig 2015-06-24 14:23:22.270710744 -0500
+++ squashfs-tools/unsquash-4.c 2015-06-24 14:24:13.671243487 -0500
@@ -35,7 +35,7 @@
size_t indexes = SQUASHFS_FRAGMENT_INDEXES(sBlk.s.fragments);
long long *fragment_table_index;
- TRACE("read_fragment_table: %d fragments, reading %d fragment indexes "
+ TRACE("read_fragment_table: %u fragments, reading %zu fragment indexes "
"from 0x%llx\n", sBlk.s.fragments, indexes,
sBlk.s.fragment_table_start);

View File

@ -1,7 +1,7 @@
Summary: Utility for the creation of squashfs filesystems
Name: squashfs-tools
Version: 4.3
Release: 10%{?dist}
Release: 11%{?dist}
License: GPLv2+
Group: System Environment/Base
URL: http://squashfs.sourceforge.net/
@ -23,6 +23,8 @@ Patch2: 2gb.patch
# Which is forked from Phillip's squashfs-tools, though it looks like
# the issue applies to us.
Patch3: cve-2015-4645.patch
# Update formats to match changes in cve-2015-4645.patch
Patch4: squashfs-tools.spec
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: zlib-devel
BuildRequires: xz-devel
@ -40,6 +42,7 @@ contains the utilities for manipulating squashfs filesystems.
%patch1 -p1
%patch2 -p0
%patch3 -p1
%patch4 -p0
%build
pushd squashfs-tools