- update to 3.6.18 (http://www.sqlite.org/releaselog/3_6_18.html)
- drop no longer needed test-disabler patches
This commit is contained in:
parent
61184f52c3
commit
c7084d09dd
@ -1,2 +1 @@
|
||||
sqlite-3.6.17.tar.gz
|
||||
sqlite_docs_3_6_17.zip
|
||||
sqlite_docs_3_6_18.zip
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
f89f62afc765e08b3f0e47cdc47a15d4 sqlite-3.6.17.tar.gz
|
||||
a9081064aecf1a512aa0ca442803460c sqlite_docs_3_6_17.zip
|
||||
4c5f5e694532c75841ffdef05cb1c117 sqlite_docs_3_6_18.zip
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up sqlite-3.6.13/test/io.test.nodirsync sqlite-3.6.13/test/io.test
|
||||
--- sqlite-3.6.13/test/io.test.nodirsync 2009-05-14 12:12:21.000000000 +0300
|
||||
+++ sqlite-3.6.13/test/io.test 2009-05-14 12:13:51.000000000 +0300
|
||||
@@ -426,7 +426,8 @@ sqlite3_simulate_device -char safe_appen
|
||||
# on the journal file between steps (2) and (3) above.
|
||||
#
|
||||
if {$::tcl_platform(platform)=="unix"} {
|
||||
- set expected_sync_count 3
|
||||
+ # normally 3 but with -DSQLITE_DISABLE_DIRSYNC its 2
|
||||
+ set expected_sync_count 2
|
||||
} else {
|
||||
set expected_sync_count 2
|
||||
}
|
@ -1,38 +0,0 @@
|
||||
diff -up sqlite-3.6.17/test/tkt3922.test.tkt3951 sqlite-3.6.17/test/tkt3922.test
|
||||
--- sqlite-3.6.17/test/tkt3922.test.tkt3951 2009-06-26 17:19:55.000000000 +0300
|
||||
+++ sqlite-3.6.17/test/tkt3922.test 2009-08-21 13:12:27.000000000 +0300
|
||||
@@ -36,20 +36,20 @@ if {[working_64bit_int]} {
|
||||
}
|
||||
} {-1 integer}
|
||||
}
|
||||
-do_test tkt3922.2 {
|
||||
- execsql {
|
||||
- DELETE FROM t1;
|
||||
- INSERT INTO t1 VALUES('-9223372036854775809');
|
||||
- SELECT a, typeof(a) FROM t1;
|
||||
- }
|
||||
-} {-9.22337203685478e+18 real}
|
||||
-do_test tkt3922.3 {
|
||||
- execsql {
|
||||
- DELETE FROM t1;
|
||||
- INSERT INTO t1 VALUES('-9223372036854776832');
|
||||
- SELECT a, typeof(a) FROM t1;
|
||||
- }
|
||||
-} {-9.22337203685478e+18 real}
|
||||
+#do_test tkt3922.2 {
|
||||
+# execsql {
|
||||
+# DELETE FROM t1;
|
||||
+# INSERT INTO t1 VALUES('-9223372036854775809');
|
||||
+# SELECT a, typeof(a) FROM t1;
|
||||
+# }
|
||||
+#} {-9.22337203685478e+18 real}
|
||||
+#do_test tkt3922.3 {
|
||||
+# execsql {
|
||||
+# DELETE FROM t1;
|
||||
+# INSERT INTO t1 VALUES('-9223372036854776832');
|
||||
+# SELECT a, typeof(a) FROM t1;
|
||||
+# }
|
||||
+#} {-9.22337203685478e+18 real}
|
||||
do_test tkt3922.4 {
|
||||
execsql {
|
||||
DELETE FROM t1;
|
12
sqlite.spec
12
sqlite.spec
@ -4,7 +4,7 @@
|
||||
%bcond_without check
|
||||
|
||||
# upstream doesn't provide separate -docs sources for all minor releases
|
||||
%define basever 3.6.17
|
||||
%define basever 3.6.18
|
||||
%define docver %(echo %{basever}|sed -e "s/\\./_/g")
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
@ -20,10 +20,6 @@ Source1: http://www.sqlite.org/sqlite_docs_%{docver}.zip
|
||||
Patch1: sqlite-3.6.12-libdl.patch
|
||||
# Avoid insecure sprintf(), use a system path for lempar.c, patch from Debian
|
||||
Patch2: sqlite-3.6.6.2-lemon-snprintf.patch
|
||||
# Fixup io-test fsync expectations wrt SQLITE_DISABLE_DIRSYNC
|
||||
Patch3: sqlite-3.6.13-iotest-nodirsync.patch
|
||||
# Disable two tests failing on at least on x86_64, ticket #3951
|
||||
Patch4: sqlite-3.6.17-tkt3951.patch
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
# libdl patch needs
|
||||
BuildRequires: autoconf
|
||||
@ -94,8 +90,6 @@ This package contains the tcl modules for %{name}.
|
||||
%setup -q -a1
|
||||
%patch1 -p1 -b .libdl
|
||||
%patch2 -p1 -b .lemon-sprintf
|
||||
%patch3 -p1 -b .nodirsync
|
||||
%patch4 -p1 -b .tkt3951
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -178,6 +172,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 06 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.18-1
|
||||
- update to 3.6.18 (http://www.sqlite.org/releaselog/3_6_18.html)
|
||||
- drop no longer needed test-disabler patches
|
||||
|
||||
* Fri Aug 21 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.17-1
|
||||
- update to 3.6.17 (http://www.sqlite.org/releaselog/3_6_17.html)
|
||||
- disable to failing tests until upstream fixes
|
||||
|
Loading…
Reference in New Issue
Block a user