Updated to version 3.35.5 (#1951196)
This commit is contained in:
parent
2b4b69fa67
commit
bee3a4ab7c
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (sqlite-src-3350400.zip) = 3a3fa1df47b8f148fffbb056522e0e671d9e295c154173124208b7b1348d321eba410a40fbdea02fdc1af3b55cdfce37044ed09f328502fc50f42f5ecabc1236
|
SHA512 (sqlite-src-3350500.zip) = f9afd11b3c42a8241f91e2ecafc3928e7391cc0f1fbee236b8122c2d3ca922d0c82d2605968b131351b6c5e38f983f8eed29b86c94cfa72799e2387b3b3db561
|
||||||
SHA512 (sqlite-doc-3350400.zip) = cc967b6625e0ae3ffb4a84f87a6efb5bc0e2d3cb2080e438c9e1ba3b8c2ba707612b8bdfc2bf3291ef2ad2836780127050762945a3ff7503f662cf30ab4fde4a
|
SHA512 (sqlite-doc-3350500.zip) = 2da5357623f4db7003f46ec7ea8bdd8a794ad6e1be9a25a8ebccfe5222da43eabc32d9d17acfd7766aa4cf1fd010e476a8087fab78ac6f6596c7c5b8a06de685
|
||||||
SHA512 (sqlite-autoconf-3350400.tar.gz) = 9a0a37ca2defc0fda208eda0812502f34783bec8a2470fc44caaeab2985f045d77e993d76f4ae6436d0b927601404f7e42c9e3d377a32d9a67140435c3eaf5b9
|
SHA512 (sqlite-autoconf-3350500.tar.gz) = 039af796f79fc4517be0bd5ba37886264d49da309e234ae6fccdb488ef0109ed2b917fc3e6c1fc7224dff4f736824c653aaf8f0a37550c5ebc14d035cb8ac737
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
Subject: [PATCH] Fix a problem with handling expressions like '(col IS NULL
|
|
||||||
AND <expr1>) OR col == NULL' in WHERE clauses.
|
|
||||||
|
|
||||||
---
|
|
||||||
src/whereexpr.c | 1 +
|
|
||||||
test/notnull2.test | 10 ++++++++++
|
|
||||||
2 files changed, 11 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/whereexpr.c b/src/whereexpr.c
|
|
||||||
index b3f48fe..1807fbb 100644
|
|
||||||
--- a/src/whereexpr.c
|
|
||||||
+++ b/src/whereexpr.c
|
|
||||||
@@ -511,6 +511,7 @@ static void whereCombineDisjuncts(
|
|
||||||
int op; /* Operator for the combined expression */
|
|
||||||
int idxNew; /* Index in pWC of the next virtual term */
|
|
||||||
|
|
||||||
+ if( (pOne->wtFlags | pTwo->wtFlags) & TERM_VNULL ) return;
|
|
||||||
if( (pOne->eOperator & (WO_EQ|WO_LT|WO_LE|WO_GT|WO_GE))==0 ) return;
|
|
||||||
if( (pTwo->eOperator & (WO_EQ|WO_LT|WO_LE|WO_GT|WO_GE))==0 ) return;
|
|
||||||
if( (eOp & (WO_EQ|WO_LT|WO_LE))!=eOp
|
|
||||||
diff --git a/test/notnull2.test b/test/notnull2.test
|
|
||||||
index 9ae190f..0a7a492 100644
|
|
||||||
--- a/test/notnull2.test
|
|
||||||
+++ b/test/notnull2.test
|
|
||||||
@@ -97,5 +97,15 @@ do_execsql_test 2.1 {
|
|
||||||
SELECT * FROM (SELECT a, b FROM t1) LEFT JOIN t3 ON a IS NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
+#-------------------------------------------------------------------------
|
|
||||||
+reset_db
|
|
||||||
+do_execsql_test 3.0 {
|
|
||||||
+ CREATE TABLE t0(c0 PRIMARY KEY);
|
|
||||||
+ INSERT INTO t0(c0) VALUES (0);
|
|
||||||
+}
|
|
||||||
+do_execsql_test 3.1 {
|
|
||||||
+ SELECT * FROM t0 WHERE ((c0 NOT NULL) AND 1) OR (c0 == NULL);
|
|
||||||
+} {0}
|
|
||||||
+
|
|
||||||
finish_test
|
|
||||||
|
|
||||||
--
|
|
||||||
2.30.2
|
|
||||||
|
|
17
sqlite.spec
17
sqlite.spec
@ -4,15 +4,15 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
%define realver 3350400
|
%define realver 3350500
|
||||||
%define docver 3350400
|
%define docver 3350500
|
||||||
%define rpmver 3.35.4
|
%define rpmver 3.35.5
|
||||||
%define year 2021
|
%define year 2021
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
URL: http://www.sqlite.org/
|
URL: http://www.sqlite.org/
|
||||||
|
|
||||||
@ -31,11 +31,8 @@ Patch3: sqlite-3.8.0-percentile-test.patch
|
|||||||
Patch4: sqlite-3.16-datetest-2.2c.patch
|
Patch4: sqlite-3.16-datetest-2.2c.patch
|
||||||
# Modify sync2.test to pass with DIRSYNC turned off
|
# Modify sync2.test to pass with DIRSYNC turned off
|
||||||
Patch5: sqlite-3.18.0-sync2-dirsync.patch
|
Patch5: sqlite-3.18.0-sync2-dirsync.patch
|
||||||
# Fixed handling LIKE experrsion in WHERE clause
|
|
||||||
# https://sqlite.org/src/info/40852ca8e215e51f
|
|
||||||
Patch6: sqlite-3.35.4-fix-handling-LIKE-expressions.patch
|
|
||||||
# Remove SHA-1 algorithm accoridng to its deprecation (downstream)
|
# Remove SHA-1 algorithm accoridng to its deprecation (downstream)
|
||||||
Patch7: sqlite-3.34.1-remove-SHA-1.patch
|
Patch6: sqlite-3.34.1-remove-SHA-1.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -145,7 +142,6 @@ This package contains the analysis program for %{name}.
|
|||||||
%endif
|
%endif
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
|
||||||
|
|
||||||
# Remove backup-file
|
# Remove backup-file
|
||||||
rm -f %{name}-doc-%{docver}/sqlite.css~ || :
|
rm -f %{name}-doc-%{docver}/sqlite.css~ || :
|
||||||
@ -264,6 +260,9 @@ make test
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 20 2021 Ondrej Dubaj <odubaj@redhat.com> - 3.35.5-1
|
||||||
|
- Updated to version 3.35.5 (https://sqlite.org/releaselog/3_35_5.html)
|
||||||
|
|
||||||
* Thu Apr 15 2021 Ondrej Dubaj <odubaj@redhat.com> - 3.35.4-3
|
* Thu Apr 15 2021 Ondrej Dubaj <odubaj@redhat.com> - 3.35.4-3
|
||||||
- Remove SHA-1 algorithms according to its deprecation in RHEL-9 (#1935442)
|
- Remove SHA-1 algorithms according to its deprecation in RHEL-9 (#1935442)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user