This commit is contained in:
Jan Staněk 2015-07-28 16:00:10 +02:00
parent 0ce38edc0e
commit aa82fcfac8
4 changed files with 11 additions and 23 deletions

2
.gitignore vendored
View File

@ -68,3 +68,5 @@
/sqlite-doc-3081001.zip
/sqlite-src-3081002.zip
/sqlite-doc-3081002.zip
/sqlite-src-3081100.zip
/sqlite-doc-3081100.zip

View File

@ -1,2 +1,2 @@
5d717638b97b3be1a4d855d957028738 sqlite-src-3081002.zip
59e10cdbacbda10469a7c57843d1ffdd sqlite-doc-3081002.zip
d1508ab4ad9b4ce349bf5e8badaa8b92 sqlite-src-3081100.zip
979a1601b700b4969914ee03dade41aa sqlite-doc-3081100.zip

View File

@ -1,14 +0,0 @@
diff -up sqlite-src-3081001/Makefile.in.old sqlite-src-3081001/Makefile.in
--- sqlite-src-3081001/Makefile.in.old 2015-05-11 09:24:56.310577370 +0200
+++ sqlite-src-3081001/Makefile.in 2015-05-11 09:25:42.618876370 +0200
@@ -995,7 +995,9 @@ smoketest: testfixture$(TEXE) fuzzershel
sqlite3_analyzer.c: sqlite3.c $(TOP)/src/tclsqlite.c $(TOP)/tool/spaceanal.tcl
echo "#define TCLSH 2" > $@
- echo "#define SQLITE_ENABLE_DBSTAT_VTAB" >> $@
+ echo "#ifndef SQLITE_ENABLE_DBSTAT_VTAB" >> $@
+ echo "#define SQLITE_ENABLE_DBSTAT_VTAB 0" >> $@
+ echo "#endif" >> $@
cat sqlite3.c $(TOP)/src/tclsqlite.c >> $@
echo "static const char *tclsh_main_loop(void){" >> $@
echo "static const char *zMainloop = " >> $@

View File

@ -3,14 +3,14 @@
%bcond_with static
%bcond_without check
%define realver 3081002
%define docver 3081002
%define rpmver 3.8.10.2
%define realver 3081100
%define docver 3081100
%define rpmver 3.8.11
Summary: Library that implements an embeddable SQL database engine
Name: sqlite
Version: %{rpmver}
Release: 3%{?dist}
Release: 1%{?dist}
License: Public Domain
Group: Applications/Databases
URL: http://www.sqlite.org/
@ -27,8 +27,6 @@ Patch2: sqlite-3.7.7.1-stupid-openfiles-test.patch
Patch3: sqlite-3.7.15-no-malloc-usable-size.patch
# Temporary workaround for failed percentile test, see patch for details
Patch4: sqlite-3.8.0-percentile-test.patch
# Fix define of new compile option
Patch5: sqlite-3.8.10.1-dbstat-vtab-define-fix.patch
# Disable test failing due to tcl regression. Details in patch file.
Patch6: sqlite-3.8.10.1-tcl-regress-tests.patch
@ -117,7 +115,6 @@ This package contains the analysis program for %{name}.
%patch2 -p1 -b .stupid-openfiles-test
%patch3 -p1 -b .no-malloc-usable-size
%patch4 -p1 -b .nonprecise-percentile-test
%patch5 -p1 -b .dbstat-vtab-define
%patch6 -p1 -b .tcl-regress
# Remove cgi-script erroneously included in sqlite-doc-3070500
@ -210,6 +207,9 @@ make test
%endif
%changelog
* Tue Jul 28 2015 Jan Stanek <jstanek@redhat.com> - 3.8.11-1
- Updated to version 3.8.11 (https://sqlite.org/releaselog/3_8_11.html)
* Fri Jun 19 2015 Jan Stanek <jstanek@redhat.com> - 3.8.10.2-3
- Enabled SQLITE_ENABLE_FTS3_PARENTHESIS extension (rhbz#1232301)