Updated to version 3.14.1
This commit is contained in:
parent
e4c2a64939
commit
8ec1196bae
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
1184f80542c8e63dea5ba467c40b1220 sqlite-src-3130000.zip
|
2990ed6a3d3f45a65d66386fba1e64d8 sqlite-src-3140100.zip
|
||||||
24e54c25ef018e3a26c8e101fab2515e sqlite-doc-3130000.zip
|
494287b4dc0d2696e0ca1e7462e518da sqlite-doc-3140100.zip
|
||||||
4e83f39fa2ffb610ac5ecd36865da6a2 sqlite-autoconf-3130000.tar.gz
|
3634a90a3f49541462bcaed3474b2684 sqlite-autoconf-3140100.tar.gz
|
||||||
|
@ -4,9 +4,9 @@ According to sqlite upstream[1], this should be fixed in tcl 8.6.5.
|
|||||||
[1] http://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-users/2015-May/059518.html
|
[1] http://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-users/2015-May/059518.html
|
||||||
|
|
||||||
diff -up sqlite-src-3130000/test/shell1.test.orig sqlite-src-3130000/test/shell1.test
|
diff -up sqlite-src-3130000/test/shell1.test.orig sqlite-src-3130000/test/shell1.test
|
||||||
--- sqlite-src-3130000/test/shell1.test.orig 2016-05-24 17:46:53.447074482 +0200
|
--- sqlite-src-3140100/test/shell1.test.orig 2016-08-12 02:17:02.000000000 +0200
|
||||||
+++ sqlite-src-3130000/test/shell1.test 2016-05-24 17:48:20.951080978 +0200
|
+++ sqlite-src-3140100/test/shell1.test 2016-08-15 15:00:59.869664051 +0200
|
||||||
@@ -855,65 +855,65 @@ do_test shell1-4.6 {
|
@@ -855,67 +855,67 @@ do_test shell1-4.6 {
|
||||||
|
|
||||||
# Test using arbitrary byte data with the shell via standard input/output.
|
# Test using arbitrary byte data with the shell via standard input/output.
|
||||||
#
|
#
|
||||||
@ -25,6 +25,8 @@ diff -up sqlite-src-3130000/test/shell1.test.orig sqlite-src-3130000/test/shell1
|
|||||||
- if {$i==0x0D || ($tcl_platform(platform)=="windows" && $i==0x1A)} {
|
- if {$i==0x0D || ($tcl_platform(platform)=="windows" && $i==0x1A)} {
|
||||||
- continue
|
- continue
|
||||||
- }
|
- }
|
||||||
|
- if {$i>=0xE0 && $tcl_platform(os)=="OpenBSD"} continue
|
||||||
|
- if {$i>=0xE0 && $i<=0xEF && $tcl_platform(os)=="Linux"} continue
|
||||||
- set hex [format %02X $i]
|
- set hex [format %02X $i]
|
||||||
- set char [subst \\x$hex]; set oldChar $char
|
- set char [subst \\x$hex]; set oldChar $char
|
||||||
- set escapes [list]
|
- set escapes [list]
|
||||||
@ -84,6 +86,8 @@ diff -up sqlite-src-3130000/test/shell1.test.orig sqlite-src-3130000/test/shell1
|
|||||||
+# if {$i==0x0D || ($tcl_platform(platform)=="windows" && $i==0x1A)} {
|
+# if {$i==0x0D || ($tcl_platform(platform)=="windows" && $i==0x1A)} {
|
||||||
+# continue
|
+# continue
|
||||||
+# }
|
+# }
|
||||||
|
+# if {$i>=0xE0 && $tcl_platform(os)=="OpenBSD"} continue
|
||||||
|
+# if {$i>=0xE0 && $i<=0xEF && $tcl_platform(os)=="Linux"} continue
|
||||||
+# set hex [format %02X $i]
|
+# set hex [format %02X $i]
|
||||||
+# set char [subst \\x$hex]; set oldChar $char
|
+# set char [subst \\x$hex]; set oldChar $char
|
||||||
+# set escapes [list]
|
+# set escapes [list]
|
||||||
|
12
sqlite.spec
12
sqlite.spec
@ -3,9 +3,9 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
%define realver 3130000
|
%define realver 3140100
|
||||||
%define docver 3130000
|
%define docver 3140100
|
||||||
%define rpmver 3.13.0
|
%define rpmver 3.14.1
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
@ -130,9 +130,6 @@ This package contains the analysis program for %{name}.
|
|||||||
%patch4 -p1 -b .nonprecise-percentile-test
|
%patch4 -p1 -b .nonprecise-percentile-test
|
||||||
%patch6 -p1 -b .tcl-regress
|
%patch6 -p1 -b .tcl-regress
|
||||||
|
|
||||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
|
||||||
rm -f %{name}-doc-%{realver}/search
|
|
||||||
|
|
||||||
autoconf # Rerun with new autoconf to add support for aarm64
|
autoconf # Rerun with new autoconf to add support for aarm64
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -227,6 +224,9 @@ make test
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 15 2016 Jakub Dorňák <jdornak@redhat.com> - 3.14.1-1
|
||||||
|
- Updated to version 3.14.1 (https://sqlite.org/releaselog/3_14_1.html)
|
||||||
|
|
||||||
* Tue May 24 2016 Jakub Dorňák <jdornak@redhat.com> - 3.13.0-1
|
* Tue May 24 2016 Jakub Dorňák <jdornak@redhat.com> - 3.13.0-1
|
||||||
- Updated to version 3.13.0 (https://sqlite.org/releaselog/3_13_0.html)
|
- Updated to version 3.13.0 (https://sqlite.org/releaselog/3_13_0.html)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user