- Recreated patches to work on current version.
This commit is contained in:
Jan Staněk 2015-01-20 09:42:24 +01:00
parent 10b7004e32
commit 40789bb5a6
5 changed files with 55 additions and 47 deletions

2
.gitignore vendored
View File

@ -58,3 +58,5 @@
/sqlite-doc-3080702.zip
/sqlite-src-3080704.zip
/sqlite-doc-3080704.zip
/sqlite-src-3080800.zip
/sqlite-doc-3080800.zip

View File

@ -1,2 +1,2 @@
460fad10bea6b1cce19d012cebc3b463 sqlite-src-3080704.zip
42560edd0f320e09cfff045ca4f6a281 sqlite-doc-3080704.zip
4582c8fe99fa59a31fe25566ac018b4d sqlite-src-3080800.zip
2eccef516e76f4e2c1584e725038c564 sqlite-doc-3080800.zip

View File

@ -1,24 +1,24 @@
diff -up sqlite-src-3071500/configure.ac.malloc-usable-size sqlite-src-3071500/configure.ac
--- sqlite-src-3071500/configure.ac.malloc-usable-size 2012-12-13 14:00:32.685869844 +0200
+++ sqlite-src-3071500/configure.ac 2012-12-13 14:00:43.321830496 +0200
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
diff -up sqlite-src-3080800/configure.ac.no-malloc-usable-size sqlite-src-3080800/configure.ac
--- sqlite-src-3080800/configure.ac.no-malloc-usable-size 2015-01-20 09:25:03.791148561 +0100
+++ sqlite-src-3080800/configure.ac 2015-01-20 09:27:36.215771856 +0100
@@ -109,7 +109,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
#########
# Figure out whether or not we have these functions
#
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
-AC_CHECK_FUNCS([fdatasync gmtime_r isnan localtime_r localtime_s malloc_usable_size strchrnul usleep utime])
+AC_CHECK_FUNCS([fdatasync gmtime_r isnan localtime_r localtime_s strchrnul usleep utime])
#########
# By default, we use the amalgamation (this may be changed below...)
diff -up sqlite-src-3071500/configure.malloc-usable-size sqlite-src-3071500/configure
--- sqlite-src-3071500/configure.malloc-usable-size 2012-12-13 14:00:28.552884276 +0200
+++ sqlite-src-3071500/configure 2012-12-13 14:00:54.720788024 +0200
@@ -12147,7 +12147,7 @@ done
diff -up sqlite-src-3080800/configure.no-malloc-usable-size sqlite-src-3080800/configure
--- sqlite-src-3080800/configure.no-malloc-usable-size 2015-01-20 09:25:03.793148569 +0100
+++ sqlite-src-3080800/configure 2015-01-20 09:28:08.109902277 +0100
@@ -12140,7 +12140,7 @@ done
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
-for ac_func in fdatasync gmtime_r isnan localtime_r localtime_s malloc_usable_size strchrnul usleep utime
+for ac_func in fdatasync gmtime_r isnan localtime_r localtime_s strchrnul usleep utime
do
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5

View File

@ -1,36 +1,38 @@
diff -up sqlite-src-3070701/test/oserror.test.openfiles sqlite-src-3070701/test/oserror.test
--- sqlite-src-3070701/test/oserror.test.openfiles 2011-07-13 09:56:46.025857411 +0300
+++ sqlite-src-3070701/test/oserror.test 2011-07-13 09:57:11.634759798 +0300
@@ -51,19 +51,19 @@ proc do_re_test {tn script expression} {
diff -up sqlite-src-3080800/test/oserror.test.stupid-openfiles-test sqlite-src-3080800/test/oserror.test
--- sqlite-src-3080800/test/oserror.test.stupid-openfiles-test 2015-01-20 09:23:35.085785827 +0100
+++ sqlite-src-3080800/test/oserror.test 2015-01-20 09:24:12.446938604 +0100
@@ -51,20 +51,20 @@ proc do_re_test {tn script expression} {
# a call to getcwd() may fail if there are no free file descriptors. So
# an error may be reported for either open() or getcwd() here.
#
-puts "Possible valgrind error about invalid file descriptor follows:"
-do_test 1.1.1 {
-if {![clang_sanitize_address]} {
- do_test 1.1.1 {
- set ::log [list]
- list [catch {
- for {set i 0} {$i < 2000} {incr i} { sqlite3 dbh_$i test.db -readonly 1 }
- } msg] $msg
-} {1 {unable to open database file}}
-do_test 1.1.2 {
- } {1 {unable to open database file}}
- do_test 1.1.2 {
- catch { for {set i 0} {$i < 2000} {incr i} { dbh_$i close } }
-} {1}
-do_re_test 1.1.3 {
- } {1}
- do_re_test 1.1.3 {
- lindex $::log 0
-} {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
+#puts "Possible valgrind error about invalid file descriptor follows:"
+#do_test 1.1.1 {
- } {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
-}
+#if {![clang_sanitize_address]} {
+# do_test 1.1.1 {
+# set ::log [list]
+# list [catch {
+# for {set i 0} {$i < 2000} {incr i} { sqlite3 dbh_$i test.db -readonly 1 }
+# } msg] $msg
+#} {1 {unable to open database file}}
+#do_test 1.1.2 {
+# } {1 {unable to open database file}}
+# do_test 1.1.2 {
+# catch { for {set i 0} {$i < 2000} {incr i} { dbh_$i close } }
+#} {1}
+#do_re_test 1.1.3 {
+# } {1}
+# do_re_test 1.1.3 {
+# lindex $::log 0
+#} {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
+# } {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
+#}
# Test a failure in open() due to the path being a directory.

View File

@ -3,9 +3,9 @@
%bcond_with static
%bcond_without check
%define realver 3080704
%define docver 3080704
%define rpmver 3.8.7.4
%define realver 3080800
%define docver 3080800
%define rpmver 3.8.8
Summary: Library that implements an embeddable SQL database engine
Name: sqlite
@ -204,6 +204,10 @@ make test
%endif
%changelog
* Tue Jan 20 2015 Jan Stanek <jstanek@redhat.com> - 3.8.8-1
- Updated to version 3.8.8 (https://sqlite.org/releaselog/3_8_8.html)
- Recreated patches to work on current version.
* Fri Dec 12 2014 Jan Stanek <jstanek@redhat.com> - 3.8.7.4-1
- Updated to version 3.8.7.4 (http://www.sqlite.org/releaselog/3_8_7_4.html)