- update to 3.6.4

- drop patches already upstream
This commit is contained in:
Panu Matilainen 2008-11-08 11:16:25 +00:00
parent 778c041844
commit 2182006839
7 changed files with 251 additions and 47 deletions

View File

@ -1 +1 @@
sqlite-3.5.9.tar.gz
sqlite-3.6.4.tar.gz

View File

@ -1 +1 @@
b58412904b42fe49e5a281e99da0fd72 sqlite-3.5.9.tar.gz
b9832cd8734d4568e384e1c60b50c92f sqlite-3.6.4.tar.gz

View File

@ -1,12 +0,0 @@
diff -up sqlite-3.5.8/sqlite3.pc.in.release sqlite-3.5.8/sqlite3.pc.in
--- sqlite-3.5.8/sqlite3.pc.in.release 2008-04-23 09:11:38.000000000 +0300
+++ sqlite-3.5.8/sqlite3.pc.in 2008-04-23 09:11:48.000000000 +0300
@@ -7,7 +7,7 @@ includedir=@includedir@
Name: SQLite
Description: SQL database engine
-Version: @VERSION@
+Version: @RELEASE@
Libs: -L${libdir} -lsqlite3
Libs.private: @LIBS@
Cflags: -I${includedir}

View File

@ -1,11 +0,0 @@
diff -up sqlite-3.5.9/configure.libdl sqlite-3.5.9/configure
--- sqlite-3.5.9/configure.libdl 2008-09-22 18:37:55.000000000 +0300
+++ sqlite-3.5.9/configure 2008-09-22 18:38:11.000000000 +0300
@@ -12067,6 +12067,7 @@ else
fi;
if test "${use_loadextension}" = "yes" ; then
LOADEXTENSION_FLAGS=""
+ LIBS="-ldl $LIBS"
else
LOADEXTENSION_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
fi

View File

@ -1,11 +0,0 @@
diff -up sqlite-3.5.9/src/expr.c.remove-temp sqlite-3.5.9/src/expr.c
--- sqlite-3.5.9/src/expr.c.remove-temp 2008-05-13 15:50:50.000000000 +0300
+++ sqlite-3.5.9/src/expr.c 2008-09-22 18:04:39.000000000 +0300
@@ -3428,6 +3428,7 @@ int sqlite3GetTempReg(Parse *pParse){
}
void sqlite3ReleaseTempReg(Parse *pParse, int iReg){
if( iReg && pParse->nTempReg<ArraySize(pParse->aTempReg) ){
+ sqlite3ExprWritableRegister(pParse, iReg, iReg);
pParse->aTempReg[pParse->nTempReg++] = iReg;
}
}

240
sqlite-3.6.4-libdl.patch Normal file
View File

@ -0,0 +1,240 @@
diff -up sqlite-3.6.4/configure.ac.orig sqlite-3.6.4/configure.ac
--- sqlite-3.6.4/configure.ac.orig 2008-11-08 11:37:15.000000000 +0200
+++ sqlite-3.6.4/configure.ac 2008-11-08 11:35:50.000000000 +0200
@@ -606,6 +606,7 @@ AC_ARG_ENABLE(load-extension, AC_HELP_ST
[use_loadextension=$enableval],[use_loadextension=no])
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
+ AC_SEARCH_LIBS(dlopen, [dl])
else
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
fi
diff -up sqlite-3.6.4/configure.orig sqlite-3.6.4/configure
--- sqlite-3.6.4/configure.orig 2008-11-08 11:39:22.000000000 +0200
+++ sqlite-3.6.4/configure 2008-11-08 11:39:29.000000000 +0200
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.59 for sqlite 3.6.1.
+# Generated by GNU Autoconf 2.59 for sqlite 3.6.4.
#
# Copyright (C) 2003 Free Software Foundation, Inc.
# This configure script is free software; the Free Software Foundation
@@ -416,8 +416,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='sqlite'
PACKAGE_TARNAME='sqlite'
-PACKAGE_VERSION='3.6.1'
-PACKAGE_STRING='sqlite 3.6.1'
+PACKAGE_VERSION='3.6.4'
+PACKAGE_STRING='sqlite 3.6.4'
PACKAGE_BUGREPORT=''
# Factoring default headers for most tests.
@@ -926,7 +926,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures sqlite 3.6.1 to adapt to many kinds of systems.
+\`configure' configures sqlite 3.6.4 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -987,7 +987,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of sqlite 3.6.1:";;
+ short | recursive ) echo "Configuration of sqlite 3.6.4:";;
esac
cat <<\_ACEOF
@@ -1137,7 +1137,7 @@ fi
test -n "$ac_init_help" && exit 0
if $ac_init_version; then
cat <<\_ACEOF
-sqlite configure 3.6.1
+sqlite configure 3.6.4
generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
@@ -1151,7 +1151,7 @@ cat >&5 <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by sqlite $as_me 3.6.1, which was
+It was created by sqlite $as_me 3.6.4, which was
generated by GNU Autoconf 2.59. Invocation command line was
$ $0 $@
@@ -1489,7 +1489,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
# The following RCS revision string applies to configure.in
-# $Revision: 1.64 $
+# $Revision: 1.49 $
#########
# Programs needed
@@ -11266,10 +11266,6 @@ if test "$TARGET_EXEEXT" = ".exe"; then
SQLITE_OS_WIN=0
SQLITE_OS_OS2=1
CFLAGS="$CFLAGS -DSQLITE_OS_OS2=1"
- if test "$ac_compiler_gnu" = "yes" ; then
- CFLAGS="$CFLAGS -Zomf -Zexe -Zmap"
- BUILD_CFLAGS="$BUILD_CFLAGS -Zomf -Zexe"
- fi
else
SQLITE_OS_UNIX=0
SQLITE_OS_WIN=1
@@ -12066,6 +12062,132 @@ else
fi;
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
+ echo "$as_me:$LINENO: checking for library containing dlopen" >&5
+echo $ECHO_N "checking for library containing dlopen... $ECHO_C" >&6
+if test "${ac_cv_search_dlopen+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ ac_func_search_save_LIBS=$LIBS
+ac_cv_search_dlopen=no
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any gcc2 internal prototype to avoid an error. */
+#ifdef __cplusplus
+extern "C"
+#endif
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char dlopen ();
+int
+main ()
+{
+dlopen ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+ (eval $ac_link) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+ { ac_try='test -z "$ac_c_werror_flag"
+ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; } &&
+ { ac_try='test -s conftest$ac_exeext'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ ac_cv_search_dlopen="none required"
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+fi
+rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+if test "$ac_cv_search_dlopen" = no; then
+ for ac_lib in dl; do
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any gcc2 internal prototype to avoid an error. */
+#ifdef __cplusplus
+extern "C"
+#endif
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char dlopen ();
+int
+main ()
+{
+dlopen ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+ (eval $ac_link) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+ { ac_try='test -z "$ac_c_werror_flag"
+ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; } &&
+ { ac_try='test -s conftest$ac_exeext'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ ac_cv_search_dlopen="-l$ac_lib"
+break
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+fi
+rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ done
+fi
+LIBS=$ac_func_search_save_LIBS
+fi
+echo "$as_me:$LINENO: result: $ac_cv_search_dlopen" >&5
+echo "${ECHO_T}$ac_cv_search_dlopen" >&6
+if test "$ac_cv_search_dlopen" != no; then
+ test "$ac_cv_search_dlopen" = "none required" || LIBS="$ac_cv_search_dlopen $LIBS"
+
+fi
+
else
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
fi
@@ -12506,7 +12628,7 @@ _ASBOX
} >&5
cat >&5 <<_CSEOF
-This file was extended by sqlite $as_me 3.6.1, which was
+This file was extended by sqlite $as_me 3.6.4, which was
generated by GNU Autoconf 2.59. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -12569,7 +12691,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-sqlite config.status 3.6.1
+sqlite config.status 3.6.4
configured by $0, generated by GNU Autoconf 2.59,
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"

View File

@ -5,17 +5,14 @@
Summary: Library that implements an embeddable SQL database engine
Name: sqlite
Version: 3.5.9
Release: 2%{?dist}
Version: 3.6.4
Release: 1%{?dist}
License: Public Domain
Group: Applications/Databases
URL: http://www.sqlite.org/
Source: http://www.sqlite.org/sqlite-%{version}.tar.gz
Patch1: sqlite-3.5.8-pkgconfig-version.patch
# Kludge -ldl into LIBS for load-extension
Patch2: sqlite-3.5.9-libdl.patch
# Upstream fix for http://www.sqlite.org/cvstrac/tktview?tn=3201
Patch3: sqlite-3.5.9-remove-temporary.patch
# Fix build with --enable-load-extension, upstream ticket #3137
Patch1: sqlite-3.6.4-libdl.patch
Obsoletes: sqlite3 sqlite3-devel
BuildRequires: ncurses-devel readline-devel glibc-devel
BuildRequires: /usr/bin/tclsh
@ -55,9 +52,7 @@ This package contains the tcl modules for %{name}.
%prep
%setup -q
%patch1 -p1 -b .pkgconf
%patch2 -p1 -b .libdl
%patch3 -p1 -b .remove-temp
%patch1 -p1 -b .libdl
%build
export CFLAGS="$RPM_OPT_FLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -Wall"
@ -101,7 +96,6 @@ rm -rf $RPM_BUILD_ROOT
%files devel
%defattr(-, root, root)
%doc doc/*.*
%{_includedir}/*.h
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
@ -116,6 +110,10 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Sat Nov 08 2008 Panu Matilainen <pmatilai@redhat.com> - 3.6.4-1
- update to 3.6.4
- drop patches already upstream
* Mon Sep 22 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.9-2
- Remove references to temporary registers from cache on release (#463061)
- Enable loading of external extensions (#457433)