- update to 3.6.12 (#492662)

- remove reference to non-existent sqlite-doc from manual (#488883)
- drop unused patches
This commit is contained in:
Panu Matilainen 2009-04-03 09:49:27 +00:00
parent 5b48bde7a4
commit 1393d4e6c2
7 changed files with 38 additions and 282 deletions

View File

@ -1 +1 @@
sqlite-3.6.10.tar.gz
sqlite-3.6.12.tar.gz

View File

@ -1 +1 @@
a03bdc86df4025b6881d58557e4b5bd3 sqlite-3.6.10.tar.gz
13600865a69a3f54d2ac42a0d6b743db sqlite-3.6.12.tar.gz

View File

@ -1,32 +0,0 @@
diff -up sqlite-3.6.10/src/parse.y.keywords sqlite-3.6.10/src/parse.y
--- sqlite-3.6.10/src/parse.y.keywords 2009-01-15 16:01:46.000000000 +0200
+++ sqlite-3.6.10/src/parse.y 2009-01-22 21:38:42.000000000 +0200
@@ -183,8 +183,8 @@ id(A) ::= ID(X). {A = X;}
ABORT AFTER ANALYZE ASC ATTACH BEFORE BEGIN CASCADE CAST CONFLICT
DATABASE DEFERRED DESC DETACH EACH END EXCLUSIVE EXPLAIN FAIL FOR
IGNORE IMMEDIATE INITIALLY INSTEAD LIKE_KW MATCH PLAN
- QUERY KEY OF OFFSET PRAGMA RAISE REPLACE RESTRICT ROW
- TEMP TRIGGER VACUUM VIEW VIRTUAL
+ QUERY KEY OF OFFSET PRAGMA RAISE RELEASE REPLACE RESTRICT ROW
+ SAVEPOINT TEMP TRIGGER VACUUM VIEW VIRTUAL
%ifdef SQLITE_OMIT_COMPOUND_SELECT
EXCEPT INTERSECT UNION
%endif SQLITE_OMIT_COMPOUND_SELECT
diff -up sqlite-3.6.10/test/table.test.keywords sqlite-3.6.10/test/table.test
--- sqlite-3.6.10/test/table.test.keywords 2008-11-06 00:38:57.000000000 +0200
+++ sqlite-3.6.10/test/table.test 2009-01-22 21:38:42.000000000 +0200
@@ -314,6 +314,14 @@ do_test table-7.3 {
SELECT * FROM weird;
}
} {desc a asc b key 9 14_vac 0 fuzzy_dog_12 xyz begin hi end y'all}
+do_test table-7.3 {
+ execsql {
+ CREATE TABLE savepoint(release);
+ INSERT INTO savepoint(release) VALUES(10);
+ UPDATE savepoint SET release = 5;
+ SELECT release FROM savepoint;
+ }
+} {5}
# Try out the CREATE TABLE AS syntax
#

11
sqlite-3.6.12-libdl.patch Normal file
View File

@ -0,0 +1,11 @@
diff -up sqlite-3.6.4/configure.ac.orig sqlite-3.6.4/configure.ac
--- sqlite-3.6.4/configure.ac.orig 2008-11-08 11:37:15.000000000 +0200
+++ sqlite-3.6.4/configure.ac 2008-11-08 11:35:50.000000000 +0200
@@ -606,6 +606,7 @@ AC_ARG_ENABLE(load-extension, AC_HELP_ST
[use_loadextension=$enableval],[use_loadextension=no])
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
+ AC_SEARCH_LIBS(dlopen, [dl])
else
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
fi

View File

@ -0,0 +1,12 @@
diff -up sqlite-3.6.12/sqlite3.1.no-sqlite-doc sqlite-3.6.12/sqlite3.1
--- sqlite-3.6.12/sqlite3.1.no-sqlite-doc 2009-04-03 12:37:35.000000000 +0300
+++ sqlite-3.6.12/sqlite3.1 2009-04-03 12:37:44.000000000 +0300
@@ -221,8 +221,6 @@ o All other command line options are pro
.SH SEE ALSO
http://www.sqlite.org/
-.br
-The sqlite-doc package
.SH AUTHOR
This manual page was originally written by Andreas Rottmann
<rotty@debian.org>, for the Debian GNU/Linux system (but may be used

View File

@ -1,240 +0,0 @@
diff -up sqlite-3.6.4/configure.ac.orig sqlite-3.6.4/configure.ac
--- sqlite-3.6.4/configure.ac.orig 2008-11-08 11:37:15.000000000 +0200
+++ sqlite-3.6.4/configure.ac 2008-11-08 11:35:50.000000000 +0200
@@ -606,6 +606,7 @@ AC_ARG_ENABLE(load-extension, AC_HELP_ST
[use_loadextension=$enableval],[use_loadextension=no])
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
+ AC_SEARCH_LIBS(dlopen, [dl])
else
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
fi
diff -up sqlite-3.6.4/configure.orig sqlite-3.6.4/configure
--- sqlite-3.6.4/configure.orig 2008-11-08 11:39:22.000000000 +0200
+++ sqlite-3.6.4/configure 2008-11-08 11:39:29.000000000 +0200
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.59 for sqlite 3.6.1.
+# Generated by GNU Autoconf 2.59 for sqlite 3.6.4.
#
# Copyright (C) 2003 Free Software Foundation, Inc.
# This configure script is free software; the Free Software Foundation
@@ -416,8 +416,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='sqlite'
PACKAGE_TARNAME='sqlite'
-PACKAGE_VERSION='3.6.1'
-PACKAGE_STRING='sqlite 3.6.1'
+PACKAGE_VERSION='3.6.4'
+PACKAGE_STRING='sqlite 3.6.4'
PACKAGE_BUGREPORT=''
# Factoring default headers for most tests.
@@ -926,7 +926,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures sqlite 3.6.1 to adapt to many kinds of systems.
+\`configure' configures sqlite 3.6.4 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -987,7 +987,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of sqlite 3.6.1:";;
+ short | recursive ) echo "Configuration of sqlite 3.6.4:";;
esac
cat <<\_ACEOF
@@ -1137,7 +1137,7 @@ fi
test -n "$ac_init_help" && exit 0
if $ac_init_version; then
cat <<\_ACEOF
-sqlite configure 3.6.1
+sqlite configure 3.6.4
generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
@@ -1151,7 +1151,7 @@ cat >&5 <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by sqlite $as_me 3.6.1, which was
+It was created by sqlite $as_me 3.6.4, which was
generated by GNU Autoconf 2.59. Invocation command line was
$ $0 $@
@@ -1489,7 +1489,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
# The following RCS revision string applies to configure.in
-# $Revision: 1.65 $
+# $Revision: 1.49 $
#########
# Programs needed
@@ -11266,10 +11266,6 @@ if test "$TARGET_EXEEXT" = ".exe"; then
SQLITE_OS_WIN=0
SQLITE_OS_OS2=1
CFLAGS="$CFLAGS -DSQLITE_OS_OS2=1"
- if test "$ac_compiler_gnu" = "yes" ; then
- CFLAGS="$CFLAGS -Zomf -Zexe -Zmap"
- BUILD_CFLAGS="$BUILD_CFLAGS -Zomf -Zexe"
- fi
else
SQLITE_OS_UNIX=0
SQLITE_OS_WIN=1
@@ -12066,6 +12062,132 @@ else
fi;
if test "${use_loadextension}" = "yes" ; then
OPT_FEATURE_FLAGS=""
+ echo "$as_me:$LINENO: checking for library containing dlopen" >&5
+echo $ECHO_N "checking for library containing dlopen... $ECHO_C" >&6
+if test "${ac_cv_search_dlopen+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ ac_func_search_save_LIBS=$LIBS
+ac_cv_search_dlopen=no
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any gcc2 internal prototype to avoid an error. */
+#ifdef __cplusplus
+extern "C"
+#endif
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char dlopen ();
+int
+main ()
+{
+dlopen ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+ (eval $ac_link) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+ { ac_try='test -z "$ac_c_werror_flag"
+ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; } &&
+ { ac_try='test -s conftest$ac_exeext'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ ac_cv_search_dlopen="none required"
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+fi
+rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+if test "$ac_cv_search_dlopen" = no; then
+ for ac_lib in dl; do
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any gcc2 internal prototype to avoid an error. */
+#ifdef __cplusplus
+extern "C"
+#endif
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char dlopen ();
+int
+main ()
+{
+dlopen ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+ (eval $ac_link) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+ { ac_try='test -z "$ac_c_werror_flag"
+ || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; } &&
+ { ac_try='test -s conftest$ac_exeext'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ ac_cv_search_dlopen="-l$ac_lib"
+break
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+fi
+rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ done
+fi
+LIBS=$ac_func_search_save_LIBS
+fi
+echo "$as_me:$LINENO: result: $ac_cv_search_dlopen" >&5
+echo "${ECHO_T}$ac_cv_search_dlopen" >&6
+if test "$ac_cv_search_dlopen" != no; then
+ test "$ac_cv_search_dlopen" = "none required" || LIBS="$ac_cv_search_dlopen $LIBS"
+
+fi
+
else
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
fi
@@ -12506,7 +12628,7 @@ _ASBOX
} >&5
cat >&5 <<_CSEOF
-This file was extended by sqlite $as_me 3.6.1, which was
+This file was extended by sqlite $as_me 3.6.4, which was
generated by GNU Autoconf 2.59. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -12569,7 +12691,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-sqlite config.status 3.6.1
+sqlite config.status 3.6.4
configured by $0, generated by GNU Autoconf 2.59,
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"

View File

@ -5,18 +5,17 @@
Summary: Library that implements an embeddable SQL database engine
Name: sqlite
Version: 3.6.10
Release: 4%{?dist}
Version: 3.6.12
Release: 1%{?dist}
License: Public Domain
Group: Applications/Databases
URL: http://www.sqlite.org/
Source: http://www.sqlite.org/sqlite-%{version}.tar.gz
# Fix build with --enable-load-extension, upstream ticket #3137
Patch1: sqlite-3.6.6.2-libdl.patch
Patch1: sqlite-3.6.12-libdl.patch
# Avoid insecure sprintf(), use a system path for lempar.c, patch from Debian
Patch2: sqlite-3.6.6.2-lemon-snprintf.patch
# Upstream fix http://www.sqlite.org/cvstrac/chngview?cn=6186
Patch3: sqlite-3.6.10-keywords.patch
Patch3: sqlite-3.6.12-no-sqlite-doc.patch
Obsoletes: sqlite3 sqlite3-devel
BuildRequires: ncurses-devel readline-devel glibc-devel
%if %{with tcl}
@ -77,14 +76,16 @@ This package contains the tcl modules for %{name}.
%setup -q
%patch1 -p1 -b .libdl
%patch2 -p1 -b .lemon-sprintf
%patch3 -p1 -b .keywords
%patch3 -p1 -b .no-sqlite-doc
%build
autoconf
export CFLAGS="$RPM_OPT_FLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -Wall"
%configure %{!?with_tcl:--disable-tcl} \
--enable-threadsafe \
--enable-threads-override-locks \
--enable-load-extension
--enable-load-extension \
%{?with_tcl:TCLLIBDIR=%{tcl_sitearch}/sqlite3}
make %{?_smp_mflags}
make doc
@ -92,7 +93,7 @@ make doc
%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=${RPM_BUILD_ROOT} %{?with_tcl:TCLLIBDIR=%{tcl_sitearch}} install
make DESTDIR=${RPM_BUILD_ROOT} install
install -D -m0644 sqlite3.1 $RPM_BUILD_ROOT/%{_mandir}/man1/sqlite3.1
install -D -m0755 lemon $RPM_BUILD_ROOT/%{_bindir}/lemon
@ -148,6 +149,10 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Fri Apr 03 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.12-1
- update to 3.6.12 (#492662)
- remove reference to non-existent sqlite-doc from manual (#488883)
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.10-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild