Updated to version 1.5.0.

This commit is contained in:
Vitaly Zaitsev 2020-01-27 20:34:01 +01:00
parent 701d2f03e7
commit e84ca53e4e
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A
6 changed files with 6 additions and 112 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@
/v1.2.1.tar.gz
/v1.3.1.tar.gz
/v1.4.2.tar.gz
/v1.5.0.tar.gz

View File

@ -1 +1 @@
SHA512 (v1.4.2.tar.gz) = 886b489138a1bdf363b5eab65a7d973f570a01c399ff5b910fcfee172ad4ff4d42a45dc2ae24e77b07130df527fb13a86b3e55ac992e72c418aebb232e27eabf
SHA512 (v1.5.0.tar.gz) = 78991c943dd95af563c4b29545b9b5d635caf1af5031262dde734ecf70c0b4ae866d954ee77b050f9f0cc089a3bc57ee9583895e51cb00dd1cc6c10ff905ca34

View File

@ -1,30 +0,0 @@
From fbb3f41dff9ad6499de48cadd756e99f18b4392c Mon Sep 17 00:00:00 2001
From: gabime <gmelman1@gmail.com>
Date: Sun, 20 Oct 2019 10:22:44 +0300
Subject: [PATCH] Fix #1273
---
CMakeLists.txt | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa9e1fab..abceb307 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,11 +82,15 @@ message(STATUS "Build type: " ${CMAKE_BUILD_TYPE})
set(SPDLOG_SRCS
src/spdlog.cpp
src/stdout_sinks.cpp
- src/fmt.cpp
src/color_sinks.cpp
src/file_sinks.cpp
src/async.cpp)
+
+if(NOT SPDLOG_FMT_EXTERNAL)
+ list(APPEND SPDLOG_SRCS src/fmt.cpp)
+endif()
+
if (SPDLOG_BUILD_SHARED)
if(WIN32)
message(FATAL_ERROR "spdlog shared lib is not yet supported under windows")

View File

@ -1,51 +0,0 @@
From 1fff2d8ae3afeebfeb1dcfe69920306966bae69e Mon Sep 17 00:00:00 2001
From: Vitaly Zaitsev <vitaly@easycoding.org>
Date: Wed, 18 Dec 2019 15:11:48 +0100
Subject: [PATCH] Backported upstream patch with assert() fixes.
---
include/spdlog/details/circular_q.h | 1 +
include/spdlog/details/pattern_formatter-inl.h | 2 --
include/spdlog/details/thread_pool-inl.h | 1 +
3 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/spdlog/details/circular_q.h b/include/spdlog/details/circular_q.h
index fee3a3bf..d147c5e0 100644
--- a/include/spdlog/details/circular_q.h
+++ b/include/spdlog/details/circular_q.h
@@ -5,6 +5,7 @@
#pragma once
#include <vector>
+#include <cassert>
namespace spdlog {
namespace details {
diff --git a/include/spdlog/details/pattern_formatter-inl.h b/include/spdlog/details/pattern_formatter-inl.h
index 1b95eb6d..9a657970 100644
--- a/include/spdlog/details/pattern_formatter-inl.h
+++ b/include/spdlog/details/pattern_formatter-inl.h
@@ -72,8 +72,6 @@ public:
private:
void pad_it(size_t count)
{
- // count = std::min(count, spaces_.size());
- assert(count <= spaces_.size());
fmt_helper::append_string_view(string_view_t(spaces_.data(), count), dest_);
}
diff --git a/include/spdlog/details/thread_pool-inl.h b/include/spdlog/details/thread_pool-inl.h
index 77d0b1fb..6b740ca2 100644
--- a/include/spdlog/details/thread_pool-inl.h
+++ b/include/spdlog/details/thread_pool-inl.h
@@ -8,6 +8,7 @@
#endif
#include "spdlog/common.h"
+#include <cassert>
namespace spdlog {
namespace details {
--
2.24.1

View File

@ -1,22 +0,0 @@
From 4858d7e454e66d347024a074749535b91ccbeed9 Mon Sep 17 00:00:00 2001
From: gabime <gmelman1@gmail.com>
Date: Sun, 20 Oct 2019 10:27:17 +0300
Subject: [PATCH] Fix #1274
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index abceb307..5946b2a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -189,7 +189,7 @@ if (SPDLOG_INSTALL)
set(project_config_out "${CMAKE_CURRENT_BINARY_DIR}/spdlogConfig.cmake")
set(config_targets_file "spdlogConfigTargets.cmake")
set(version_config_file "${CMAKE_CURRENT_BINARY_DIR}/spdlogConfigVersion.cmake")
- set(export_dest_dir "${CMAKE_INSTALL_LIBDIR}/spdlog/cmake")
+ set(export_dest_dir "${CMAKE_INSTALL_LIBDIR}/cmake/spdlog")
set(pkgconfig_install_dir "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
set(pkg_config "${CMAKE_BINARY_DIR}/${PROJECT_NAME}.pc")

View File

@ -1,20 +1,13 @@
%global user gabime
Name: spdlog
Version: 1.4.2
Version: 1.5.0
Release: 1%{?dist}
Summary: Super fast C++ logging library
License: MIT
URL: https://github.com/%{user}/%{name}
Source0: %{url}/archive/v%{version}.tar.gz
# https://github.com/gabime/spdlog/commit/1aa9ea92e20142a1ce2f2e1ac40ed1fa781fac19
Patch100: %{name}-fix-cassert.patch
# https://github.com/gabime/spdlog/commit/4858d7e454e66d347024a074749535b91ccbeed9
Patch101: %{name}-fix-cmake.patch
# https://github.com/gabime/spdlog/commit/fbb3f41dff9ad6499de48cadd756e99f18b4392c
Patch102: %{name}-external-fmt.patch
BuildRequires: google-benchmark-devel
BuildRequires: fmt-devel >= 6.1.2
BuildRequires: ninja-build
@ -78,6 +71,9 @@ popd
%{_libdir}/pkgconfig/%{name}.pc
%changelog
* Mon Jan 27 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.5.0-1
- Updated to version 1.5.0.
* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 1.4.2-1
- Updated to version 1.4.2.