Update to 1.5.5
This commit is contained in:
parent
708ba41fbc
commit
046176ccd3
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/1.0.0RC3.tar.gz
|
||||
/1.0.0.tar.gz
|
||||
/1.0.1.tar.gz
|
||||
/1.1.5.tar.gz
|
||||
|
@ -1,26 +1,7 @@
|
||||
diff --git a/Build.PL b/Build.PL
|
||||
index 9c25124..73e3321 100644
|
||||
index 5c650ce..09febb4 100644
|
||||
--- a/Build.PL
|
||||
+++ b/Build.PL
|
||||
@@ -9,15 +9,15 @@ use File::Spec;
|
||||
my %prereqs = qw(
|
||||
Boost::Geometry::Utils 0.15
|
||||
Encode::Locale 0
|
||||
- ExtUtils::MakeMaker 6.80
|
||||
- ExtUtils::ParseXS 3.22
|
||||
+ ExtUtils::MakeMaker 6.70
|
||||
+ ExtUtils::ParseXS 3.18
|
||||
File::Basename 0
|
||||
File::Spec 0
|
||||
Getopt::Long 0
|
||||
Math::ConvexHull::MonotoneChain 0.01
|
||||
Math::Geometry::Voronoi 1.3
|
||||
Math::PlanePath 53
|
||||
- Module::Build::WithXSpp 0.14
|
||||
+ Module::Build::WithXSpp 0.13
|
||||
Moo 1.003001
|
||||
Scalar::Util 0
|
||||
Storable 0
|
||||
@@ -146,7 +146,9 @@ if (@missing_prereqs) {
|
||||
exit 1;
|
||||
} elsif (!$gui) {
|
||||
|
@ -1,18 +1,17 @@
|
||||
diff --git a/xs/Build.PL b/xs/Build.PL
|
||||
index b358623..90a2cc2 100644
|
||||
index 5a10ac0..fb0f6a6 100644
|
||||
--- a/xs/Build.PL
|
||||
+++ b/xs/Build.PL
|
||||
@@ -25,7 +25,7 @@ my $build = Module::Build::WithXSpp->new(
|
||||
# HAS_BOOL : stops Perl/lib/CORE/handy.h from doing "# define bool char" for MSVC
|
||||
# NOGDI : prevents inclusion of wingdi.h which defines functions Polygon() and Polyline() in global namespace
|
||||
extra_compiler_flags => [qw(-D_GLIBCXX_USE_C99 -DHAS_BOOL -DNOGDI -DSLIC3RXS), ($ENV{SLIC3R_DEBUG} ? ' -DSLIC3R_DEBUG -g' : '')],
|
||||
-
|
||||
@@ -41,6 +41,7 @@ my $build = Module::Build::WithXSpp->new(
|
||||
Module::Build::WithXSpp 0.13
|
||||
)},
|
||||
extra_compiler_flags => \@cflags,
|
||||
+ extra_linker_flags => [qw(-lpolyclipping)],
|
||||
|
||||
# Provides extra C typemaps that are auto-merged
|
||||
extra_typemap_modules => {
|
||||
'ExtUtils::Typemaps::Default' => '1.03',
|
||||
diff --git a/xs/src/ClipperUtils.hpp b/xs/src/ClipperUtils.hpp
|
||||
index 8f0974d..ab8f46d 100644
|
||||
index 2ab3ff7..2058f82 100644
|
||||
--- a/xs/src/ClipperUtils.hpp
|
||||
+++ b/xs/src/ClipperUtils.hpp
|
||||
@@ -2,7 +2,7 @@
|
||||
@ -23,9 +22,22 @@ index 8f0974d..ab8f46d 100644
|
||||
+#include <polyclipping/clipper.hpp>
|
||||
#include "ExPolygon.hpp"
|
||||
#include "Polygon.hpp"
|
||||
|
||||
#include "Surface.hpp"
|
||||
diff --git a/xs/src/Geometry.cpp b/xs/src/Geometry.cpp
|
||||
index 0295d54..a8cae39 100644
|
||||
--- a/xs/src/Geometry.cpp
|
||||
+++ b/xs/src/Geometry.cpp
|
||||
@@ -1,7 +1,7 @@
|
||||
#include "Geometry.hpp"
|
||||
#include "Line.hpp"
|
||||
#include "PolylineCollection.hpp"
|
||||
-#include "clipper.hpp"
|
||||
+#include <polyclipping/clipper.hpp>
|
||||
#include <algorithm>
|
||||
#include <cmath>
|
||||
#include <list>
|
||||
diff --git a/xs/xsp/Clipper.xsp b/xs/xsp/Clipper.xsp
|
||||
index 2e63afb..61910e6 100644
|
||||
index 43a30a4..263c808 100644
|
||||
--- a/xs/xsp/Clipper.xsp
|
||||
+++ b/xs/xsp/Clipper.xsp
|
||||
@@ -2,7 +2,7 @@
|
||||
|
15
slic3r-linker.patch
Normal file
15
slic3r-linker.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/xs/Build.PL b/xs/Build.PL
|
||||
index 5a10ac0..e21df5e 100644
|
||||
--- a/xs/Build.PL
|
||||
+++ b/xs/Build.PL
|
||||
@@ -41,6 +41,10 @@ my $build = Module::Build::WithXSpp->new(
|
||||
Module::Build::WithXSpp 0.13
|
||||
)},
|
||||
extra_compiler_flags => \@cflags,
|
||||
+ extra_linker_flags => [qw(
|
||||
+ -ladmesh
|
||||
+ -lpoly2tri
|
||||
+ )],
|
||||
|
||||
# Provides extra C typemaps that are auto-merged
|
||||
extra_typemap_modules => {
|
50
slic3r.spec
50
slic3r.spec
@ -1,6 +1,6 @@
|
||||
Name: slic3r
|
||||
Version: 1.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 1.1.5
|
||||
Release: 1%{?dist}
|
||||
Summary: G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
|
||||
License: AGPLv3 and CC-BY
|
||||
# Images are CC-BY, code is AGPLv3
|
||||
@ -8,7 +8,7 @@ Group: Applications/Engineering
|
||||
URL: http://slic3r.org/
|
||||
Source0: https://github.com/alexrj/Slic3r/archive/%{version}.tar.gz
|
||||
|
||||
# This is blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1047914
|
||||
# This is waiting for the new release of clipper
|
||||
%global with_clipper 0
|
||||
|
||||
# Modify Build.PL so we are able to build this on Fedora
|
||||
@ -18,40 +18,34 @@ Patch0: %{name}-buildpl.patch
|
||||
# Use /usr/share/slic3r as datadir
|
||||
# Those two are located at the same place at the code, so the patch is merged
|
||||
Patch1: %{name}-nowarn-datadir.patch
|
||||
Patch2: %{name}-linker.patch
|
||||
|
||||
%if %with_clipper
|
||||
# Unbundle clipper
|
||||
Patch2: %{name}-clipper.patch
|
||||
Patch3: %{name}-clipper.patch
|
||||
%endif
|
||||
|
||||
Source1: %{name}.desktop
|
||||
Source2: %{name}.appdata.xml
|
||||
|
||||
BuildRequires: perl(Boost::Geometry::Utils) >= 0.15
|
||||
BuildRequires: perl(Class::XSAccessor)
|
||||
BuildRequires: perl(Encode::Locale)
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl(ExtUtils::Typemaps::Default) >= 1.03
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.80
|
||||
BuildRequires: perl(ExtUtils::ParseXS) >= 3.22
|
||||
BuildRequires: perl(ExtUtils::Typemap)
|
||||
BuildRequires: perl(ExtUtils::Typemaps::Default) >= 1.03
|
||||
BuildRequires: perl(File::Basename)
|
||||
BuildRequires: perl(File::Spec)
|
||||
BuildRequires: perl(Getopt::Long)
|
||||
BuildRequires: perl(Growl::GNTP)
|
||||
BuildRequires: perl(Growl::GNTP) >= 0.15
|
||||
BuildRequires: perl(IO::Scalar)
|
||||
BuildRequires: perl(List::Util)
|
||||
BuildRequires: perl(Math::ConvexHull::MonotoneChain)
|
||||
BuildRequires: perl(Math::ConvexHull) >= 1.0.4
|
||||
BuildRequires: perl(Math::Geometry::Voronoi) >= 1.3
|
||||
BuildRequires: perl(Math::PlanePath) >= 53
|
||||
BuildRequires: perl(Module::Build)
|
||||
BuildRequires: perl(Module::Build::WithXSpp)
|
||||
|
||||
%if 0%{?fedora} > 19
|
||||
BuildRequires: perl(Module::Build::WithXSpp) >= 0.14
|
||||
BuildRequires: perl(Moo) >= 1.003001
|
||||
%else
|
||||
BuildRequires: perl(Moo)
|
||||
%endif
|
||||
|
||||
BuildRequires: perl(parent)
|
||||
BuildRequires: perl(Scalar::Util)
|
||||
BuildRequires: perl(Storable)
|
||||
@ -67,21 +61,15 @@ BuildRequires: perl(XML::SAX::ExpatXS)
|
||||
BuildRequires: polyclipping-devel
|
||||
%endif
|
||||
|
||||
BuildRequires: admesh-devel >= 0.97.5
|
||||
BuildRequires: boost-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: poly2tri-devel
|
||||
BuildRequires: ImageMagick
|
||||
Requires: perl(Class::XSAccessor)
|
||||
Requires: perl(Growl::GNTP)
|
||||
|
||||
%if 0%{?fedora} > 19
|
||||
Requires: perl(Moo) >= 1.003001
|
||||
%endif
|
||||
|
||||
Requires: perl(XML::SAX)
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
# Temporary bundling exception https://fedorahosted.org/fpc/ticket/368
|
||||
Provides: bundled(admesh) = 0.95
|
||||
|
||||
%description
|
||||
Slic3r is a G-code generator for 3D printers. It's compatible with RepRaps,
|
||||
Makerbots, Ultimakers and many more machines.
|
||||
@ -93,13 +81,19 @@ for more information.
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%if %with_clipper
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
# Remove bundled clipper
|
||||
rm xs/src/clipper.*pp
|
||||
%endif
|
||||
|
||||
# Remove bundled admesh, poly2tri and boost
|
||||
rm -rf xs/src/admesh
|
||||
rm -rf xs/src/poly2tri
|
||||
rm -rf xs/src/boost
|
||||
|
||||
%build
|
||||
cd xs
|
||||
perl ./Build.PL installdirs=vendor optimize="$RPM_OPT_FLAGS"
|
||||
@ -182,6 +176,10 @@ fi
|
||||
%{_datadir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Sun Jun 29 2014 Miro Hrončok <mhroncok@redhat.com> - 1.1.5-1
|
||||
- Update to 1.1.5
|
||||
- Unbundle stuff
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user