initial import, rhbz#1428202

This commit is contained in:
Raphael Groner 2018-02-13 19:35:55 +01:00
parent 5b523dfe1d
commit 276da5a433
6 changed files with 277 additions and 3 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/SiriKali-1.3.2.tar.xz

View File

@ -0,0 +1,79 @@
From 6dad4d1feb4f4f2f98ab4c02114cafd560cb61c0 Mon Sep 17 00:00:00 2001
From: ink <mhogomchungu@gmail.com>
Date: Sat, 13 Jan 2018 20:07:24 +0300
Subject: [PATCH] fix a build issue when lxqt_wallet internal library is
completely missing
---
src/cryfscreateoptions.cpp | 2 +-
src/gocryptfscreateoptions.cpp | 2 +-
src/keydialog.cpp | 2 +-
src/siritask.h | 2 +-
src/walletconfig.cpp | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/src/cryfscreateoptions.cpp b/src/cryfscreateoptions.cpp
index 31ed227..1fc925d 100644
--- a/src/cryfscreateoptions.cpp
+++ b/src/cryfscreateoptions.cpp
@@ -21,7 +21,7 @@
#include "ui_cryfscreateoptions.h"
#include "utility.h"
-#include "task.h"
+#include "task.hpp"
cryfscreateoptions::cryfscreateoptions( QWidget * parent,
std::function< void( const QStringList& ) > function ) :
diff --git a/src/gocryptfscreateoptions.cpp b/src/gocryptfscreateoptions.cpp
index 07c64f5..34b9b2f 100644
--- a/src/gocryptfscreateoptions.cpp
+++ b/src/gocryptfscreateoptions.cpp
@@ -21,7 +21,7 @@
#include "ui_gocryptfscreateoptions.h"
#include "utility.h"
-#include "task.h"
+#include "task.hpp"
gocryptfscreateoptions::gocryptfscreateoptions( QWidget * parent,
std::function< void( const QStringList& ) > function ) :
diff --git a/src/keydialog.cpp b/src/keydialog.cpp
index e99ae9e..1720e4b 100644
--- a/src/keydialog.cpp
+++ b/src/keydialog.cpp
@@ -29,7 +29,7 @@
#include "options.h"
#include "dialogmsg.h"
-#include "task.h"
+#include "task.hpp"
#include "utility.h"
#include "lxqt_wallet.h"
#include "utility2.h"
diff --git a/src/siritask.h b/src/siritask.h
index c3942cd..f4c4373 100644
--- a/src/siritask.h
+++ b/src/siritask.h
@@ -21,7 +21,7 @@
#define ZULUMOUNTTASK_H
#include "volumeinfo.h"
-#include "task.h"
+#include "task.hpp"
#include "utility.h"
#include "favorites.h"
#include <QVector>
diff --git a/src/walletconfig.cpp b/src/walletconfig.cpp
index e793e02..9dd9f27 100644
--- a/src/walletconfig.cpp
+++ b/src/walletconfig.cpp
@@ -25,7 +25,7 @@
#include "tablewidget.h"
#include "walletconfiginput.h"
#include "utility.h"
-#include "task.h"
+#include "task.hpp"
#include <Qt>
#include <QTableWidget>

View File

@ -1,3 +0,0 @@
# sirikali
The sirikali package

View File

@ -0,0 +1,69 @@
From ef54268108f0f04e5e1c8aaffd2bf4bdcca4d087 Mon Sep 17 00:00:00 2001
From: ink <mhogomchungu@gmail.com>
Date: Sat, 13 Jan 2018 19:34:26 +0300
Subject: [PATCH] add "sirikali.appdata.xml" file
---
CMakeLists.txt | 2 ++
src/sirikali.appdata.xml | 39 +++++++++++++++++++++++++++++++++++++++
2 files changed, 41 insertions(+)
create mode 100644 src/sirikali.appdata.xml
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c29fe5..afd70c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -350,6 +350,8 @@ install( FILES translations/de_DE.qm DESTINATION ${CMAKE_INSTALL_DATADIR}/sirika
install( FILES src/sirikali.1.gz DESTINATION ${CMAKE_INSTALL_DATADIR}/man/man1/ )
install( FILES src/sirikali.pkexec.1.gz DESTINATION ${CMAKE_INSTALL_DATADIR}/man/man1/ )
+install( FILES src/sirikali.appdata.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/metainfo/ )
+
endif()
if( NOT APPLE )
diff --git a/src/sirikali.appdata.xml b/src/sirikali.appdata.xml
new file mode 100644
index 0000000..172810c
--- /dev/null
+++ b/src/sirikali.appdata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright 2016 David Steele <steele@debian.org> -->
+<component type="desktop">
+<id>sirikali.desktop</id>
+<metadata_license>CC0-1.0</metadata_license>
+<name>SiriKali</name>
+<summary>Manage user encrypted directories</summary>
+<description>
+<p>Sirikali provides a Qt/C++ GUI front end to cryfs,gocryptfs,securefs and encfs,
+allowing the user to create, mount, and unmount encrypted volumes.</p>
+<p>It works well together with cloud services like Dropbox, iCloud, OneDrive and others.</p>
+</description>
+<url type="homepage">https://mhogomchungu.github.io/sirikali/</url>
+<url type="bugtracker">https://github.com/mhogomchungu/sirikali/issues</url>
+<provides>
+ <binary>sirikali</binary>
+</provides>
+<project_license>GPL-2.0</project_license>
+<developer_name>Francis Banyikwa</developer_name>
+<update_contact>mhogomchungu_AT_gmail.com</update_contact>
+<translation type="qt">sirikali</translation>
+<screenshots>
+ <screenshot type="default">
+ <image>https://raw.githubusercontent.com/mhogomchungu/sirikali/master/images/Screenshot_20160810_215609.png</image>
+ <caption>Manage encrypted directories</caption>
+ </screenshot>
+</screenshots>
+<releases>
+ <!-- Get timestamp with 'date +%s' -->
+ <release version="1.3.2" timestamp="1514678400"></release>
+ <release version="1.3.1" timestamp="1506816000"></release>
+ <release version="1.3.0" timestamp="1502928000"></release>
+ <release version="1.2.9" timestamp="1499771719"></release>
+ <release version="1.2.8" timestamp="1499017170"></release>
+ <release version="1.1.0" timestamp="1472745600"></release>
+ <release version="1.0.0" timestamp="1470931200"></release>
+</releases>
+</component>
+

127
sirikali.spec Normal file
View File

@ -0,0 +1,127 @@
#
# Spec file for package sirikali
#
# Copyright © 2016 Francis Banyikwa <mhogomchungu@gmail.com>
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 2 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
%global srcname SiriKali
%global srcurl https://github.com/mhogomchungu/%{name}
Name: sirikali
Version: 1.3.2
Release: 2%{?dist}
Summary: GUI front end to encfs,cryfs,gocryptfs and securefs
License: GPLv2+
URL: http://mhogomchungu.github.io/%{name}
Source0: %{srcurl}/releases/download/%{version}/%{srcname}-%{version}.tar.xz
# src/siritask.h:24:10: fatal error: task.h: No such file or directory
Patch0: %{srcurl}/commit/6dad4d1feb4f4f2f98ab4c02114cafd560cb61c0.patch
# add appdata
Patch1: %{srcurl}/commit/ef54268108f0f04e5e1c8aaffd2bf4bdcca4d087.patch
BuildRequires: cmake
BuildRequires: gcc-c++
BuildRequires: json-devel
BuildRequires: libgcrypt-devel
BuildRequires: pkgconfig(libsecret-1)
BuildRequires: pkgconfig(lxqt-wallet)
BuildRequires: pkgconfig(Qt5Core)
BuildRequires: pkgconfig(Qt5Gui)
BuildRequires: pkgconfig(Qt5Network)
BuildRequires: libappstream-glib
BuildRequires: desktop-file-utils
Requires: hicolor-icon-theme
Recommends: fuse-encfs
%description
%{srcname} is a Qt/C++ GUI front end to encfs,cryfs,gocryptfs and securefs.
%prep
%autosetup -p1 -n%{srcname}-%{version}
# unbundle
pushd src/3rdParty
rm -rv json* lxqt_wallet
popd
sed -i -r 's:".*(json.hpp)":"\1":' CMakeLists.txt
sed -i 's:3rdParty/json:json:' src/%{name}.cpp
%build
mkdir %{_target_platform}
pushd %{_target_platform}
%cmake .. -DQT5=true \
-DNOKDESUPPORT=true -DNOSECRETSUPPORT=false \
-DINTERNAL_LXQT_WALLET=false
%install
%make_install -C %{_target_platform}
%find_lang %{name} --with-qt --all-name
%check
appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*.appdata.xml
desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
%files -f %{name}.lang
%license LICENSE COPYRIGHT GPLv*
%doc README.md ABOUT* changelog
%{_bindir}/%{name}*
%{_datadir}/applications/%{name}.desktop
%dir %{_datadir}/%{name}
%dir %{_datadir}/%{name}/translations
%{_datadir}/icons/hicolor/*/apps/%{name}.png
%{_datadir}/icons/%{name}.png
%{_datadir}/pixmaps/%{name}.png
%{_datadir}/polkit-1/actions/*.policy
%{_datadir}/metainfo/*.appdata.xml
%{_mandir}/man1/%{name}*.1*
%changelog
* Wed Feb 07 2018 Raphael Groner <projects.rg@smart.ms> - 1.3.2-2
- drop obsolete scriptlets
- drop explicit file permission
- include upstreamed patches
* Sat Jan 13 2018 Raphael Groner <projects.rg@smart.ms> - 1.3.2-1
- new version
- drop BSD because unbundled json
- unbundle lxqt_wallet
* Tue Jul 11 2017 Raphael Groner <projects.rg@smart.ms> - 1.2.9-1
- new version
- unbundle json
* Mon Jun 12 2017 Raphael Groner <projects.rg@smart.ms> - 1.2.7.1.20170611git
- new version
- use git snapshot to include latest upstream patches
- include upstream patch to get full path of su binary
- distribute additonal files
- drop workaround for duplicated readme files
- fix length of line in description
* Sun Jun 04 2017 Raphael Groner <projects.rg@smart.ms> - 1.2.5-2
- fix duplication of license documentation files
- reorder explicit ownership of folders
- fix file attributes of desktop file
- add weak dependency to fuse-encfs
* Wed Mar 01 2017 Raphael Groner <projects.rg@smart.ms> - 1.2.5-1
- adopt for Fedora

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (SiriKali-1.3.2.tar.xz) = 6c7bb1fc724e1fc534688f5e03d77bc6923c5f914c9420048b572da1267dcba3e56a318493c1a5a8d0e0c49358fd30bc9181a40ccb8627ba0bba90b0445d6323