Update to 0.4
This commit is contained in:
parent
b03890160e
commit
00ae24516c
@ -1,29 +1,29 @@
|
|||||||
From 75f6469dd9b9944124d5e1981458dc275dbc1123 Mon Sep 17 00:00:00 2001
|
From 5a82ef99c8ff146280cb4134d84ee242d3bdb98d Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Thu, 30 May 2013 17:23:19 -0400
|
Date: Thu, 30 May 2013 17:23:19 -0400
|
||||||
Subject: [PATCH] EFI_PXE_BASE_CODE_DHCPV6_PACKET is in gnu-efi-3.0t
|
Subject: [PATCH] EFI_PXE_BASE_CODE_DHCPV6_PACKET is in gnu-efi-3.0t
|
||||||
|
|
||||||
---
|
---
|
||||||
netboot.c | 9 ---------
|
netboot.c | 9 +++++++++
|
||||||
1 file changed, 9 deletions(-)
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
diff --git a/netboot.c b/netboot.c
|
diff --git b/netboot.c a/netboot.c
|
||||||
index 90fb9cb..c44aeac 100644
|
index c44aeac..90fb9cb 100644
|
||||||
--- a/netboot.c
|
--- b/netboot.c
|
||||||
+++ b/netboot.c
|
+++ a/netboot.c
|
||||||
@@ -56,15 +56,6 @@ static EFI_IP_ADDRESS tftp_addr;
|
@@ -56,6 +56,15 @@ static EFI_IP_ADDRESS tftp_addr;
|
||||||
static char *full_path;
|
static char *full_path;
|
||||||
|
|
||||||
|
|
||||||
-/*
|
+/*
|
||||||
- * Not in the EFI header set yet, so I have to declare it here
|
+ * Not in the EFI header set yet, so I have to declare it here
|
||||||
- */
|
+ */
|
||||||
-typedef struct {
|
+typedef struct {
|
||||||
- UINT32 MessageType:8;
|
+ UINT32 MessageType:8;
|
||||||
- UINT32 TransactionId:24;
|
+ UINT32 TransactionId:24;
|
||||||
- UINT8 DhcpOptions[1024];
|
+ UINT8 DhcpOptions[1024];
|
||||||
-} EFI_PXE_BASE_CODE_DHCPV6_PACKET;
|
+} EFI_PXE_BASE_CODE_DHCPV6_PACKET;
|
||||||
-
|
+
|
||||||
typedef struct {
|
typedef struct {
|
||||||
UINT16 OpCode;
|
UINT16 OpCode;
|
||||||
UINT16 Length;
|
UINT16 Length;
|
||||||
|
15
shim.spec
15
shim.spec
@ -1,6 +1,6 @@
|
|||||||
Name: shim
|
Name: shim
|
||||||
Version: 0.3
|
Version: 0.4
|
||||||
Release: 2%{?dist}
|
Release: 0.1%{?dist}
|
||||||
Summary: First-stage UEFI bootloader
|
Summary: First-stage UEFI bootloader
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -23,9 +23,9 @@ Source2: http://www.codon.org.uk/~mjg59/mokutil/mokutil-%{mokutilver}.tar.bz2
|
|||||||
Source3: dbx.esl
|
Source3: dbx.esl
|
||||||
|
|
||||||
Patch0: 0001-Fix-grub-path.patch
|
Patch0: 0001-Fix-grub-path.patch
|
||||||
Patch1: 0001-Don-t-use-MMX-and-SSE-registers-they-aren-t-initiali.patch
|
Patch1: mokutil-correct-moklistrt-size.patch
|
||||||
Patch2: mokutil-correct-moklistrt-size.patch
|
Patch2: 0001-Don-t-use-shim_cert-for-verifying-MoK-fedora-will-do.patch
|
||||||
#Patch3: 0001-EFI_PXE_BASE_CODE_DHCPV6_PACKET-is-in-gnu-efi-3.0t.patch
|
Patch3: 0001-EFI_PXE_BASE_CODE_DHCPV6_PACKET-is-in-gnu-efi-3.0t.patch
|
||||||
|
|
||||||
BuildRequires: gnu-efi git openssl-devel openssl
|
BuildRequires: gnu-efi git openssl-devel openssl
|
||||||
BuildRequires: pesign >= 0.106-1
|
BuildRequires: pesign >= 0.106-1
|
||||||
@ -80,7 +80,7 @@ git am %{patches} </dev/null
|
|||||||
%build
|
%build
|
||||||
MAKEFLAGS=""
|
MAKEFLAGS=""
|
||||||
if [ -f "%{SOURCE1}" ]; then
|
if [ -f "%{SOURCE1}" ]; then
|
||||||
MAKEFLAGS="VENDOR_CERT_FILE=%{SOURCE1}"
|
MAKEFLAGS="VENDOR_CERT_FILE=%{SOURCE1} VENDOR_DBX_FILE=%{SOURCE3}"
|
||||||
fi
|
fi
|
||||||
make ${MAKEFLAGS} shim.efi MokManager.efi fallback.efi
|
make ${MAKEFLAGS} shim.efi MokManager.efi fallback.efi
|
||||||
cd mokutil-%{mokutilver}
|
cd mokutil-%{mokutilver}
|
||||||
@ -115,6 +115,9 @@ install -m 0644 MokManager.efi.debug $RPM_BUILD_ROOT/usr/lib/debug/%{_datadir}/s
|
|||||||
/usr/share/man/man1/mokutil.1.gz
|
/usr/share/man/man1/mokutil.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 11 2013 Peter Jones <pjones@redhat.com> - 0.4-0.1
|
||||||
|
- Update to 0.4
|
||||||
|
|
||||||
* Fri Jun 07 2013 Peter Jones <pjones@redhat.com> - 0.3-2
|
* Fri Jun 07 2013 Peter Jones <pjones@redhat.com> - 0.3-2
|
||||||
- Require gnu-efi-3.0q for now.
|
- Require gnu-efi-3.0q for now.
|
||||||
- Don't allow mmx or sse during compilation.
|
- Don't allow mmx or sse during compilation.
|
||||||
|
Loading…
Reference in New Issue
Block a user