sevmgr/sevmgr.spec

111 lines
2.9 KiB
RPMSpec

#
%global mydocs __tmp_docdir
#
Name: sevmgr
Version: 1.00.4
Release: 1%{?dist}
Summary: C++ Simulation-Oriented Discrete Event Management Library
License: LGPLv2+
URL: http://github.com/airsim/%{name}
Source0: https://github.com/airsim/%{name}/archive/%{name}-%{version}.tar.gz
BuildRequires: gcc-c++
BuildRequires: cmake, python3-devel
BuildRequires: boost-devel, soci-mysql-devel, soci-sqlite3-devel
BuildRequires: boost-python3-devel
BuildRequires: readline-devel
BuildRequires: stdair-devel
%description
%{name} is a C++ library of discrete event queue management classes and
functions, exclusively targeting simulation purposes.
%{name} makes an extensive use of existing open-source libraries for
increased functionality, speed and accuracy. In particular the
Boost (C++ Standard Extensions: http://www.boost.org) library is used.
Install the %{name} package if you need a library of basic C++ objects
for the discrete event queue management of your simulation project.
%package devel
Summary: Header files, libraries and development helper tools for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: pkgconfig
# The cmake files have Python version backed in them
Requires: (python(abi) = %{python3_version} if python3-devel)
%description devel
This package contains the header files, shared libraries and
development helper tools for %{name}. If you would like to develop
programs using %{name}, you will need to install %{name}-devel.
%package doc
Summary: HTML documentation for the %{name} library
BuildArch: noarch
BuildRequires: tex(latex)
BuildRequires: doxygen
BuildRequires: ghostscript
%description doc
This package contains HTML pages, as well as a PDF reference manual,
for %{name}. All that documentation is generated thanks to Doxygen
(http://doxygen.org). The content is the same as what can be browsed
online (http://%{name}.org).
%prep
%autosetup -n %{name}-%{name}-%{version}
%build
%cmake .
%make_build
%install
%make_install
mkdir -p %{mydocs}
mv $RPM_BUILD_ROOT%{_docdir}/%{name}/html %{mydocs}
rm -f %{mydocs}/html/installdox
# Remove additional documentation files (those files are already available
# in the project top directory)
rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/{NEWS,README.md,AUTHORS}
%check
#ctest
%files
%doc AUTHORS ChangeLog COPYING NEWS README.md
%{_bindir}/%{name}
%{_bindir}/%{name}_demo
%{_libdir}/lib%{name}.so.*
%{_mandir}/man1/%{name}.1.*
%{_mandir}/man1/%{name}_demo.1.*
%files devel
%{_includedir}/%{name}
%{_bindir}/%{name}-config
%{_libdir}/lib%{name}.so
%{_libdir}/pkgconfig/%{name}.pc
%{_datadir}/aclocal/%{name}.m4
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/CMake
%{_mandir}/man1/%{name}-config.1.*
%{_mandir}/man3/%{name}-library.3.*
%files doc
%doc %{mydocs}/html
%doc COPYING
%changelog
* Mon Oct 28 2019 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.00.4-1
- First build on EPEL 8