setroubleshoot/0014-framework-Allow-to-specify-setup.py-install-prefix-v.patch
Petr Lautrbach e8f87acc6c Backport fixes from 3.3.12
Do not backport string changes since we are after string freeze phase

- Don't stop when the plugin directory is empty
- Fix missing margins on Troubleshoot window
- Resize all solutions panels horizontally
- Fix missing priority color for proposed solutions
- Set translation domain for Gtk.Builder() object to have strings
  correctly translated
- Make labels on GtkButtons translatable
- Handla all exceptions from do_analyze_logfile()
- Fix semi-translated messages
- Do not catch POSIX signals (rhbz#1366004, rhbz#1419245)
2017-09-15 10:56:05 +02:00

32 lines
1.0 KiB
Diff

From a176d587b7d66ba37f07e9f122be4b6664553e92 Mon Sep 17 00:00:00 2001
From: Petr Lautrbach <plautrba@redhat.com>
Date: Thu, 14 Sep 2017 07:50:26 +0200
Subject: [PATCH 14/19] framework: Allow to specify 'setup.py install --prefix'
via $PREFIX variable
In recent Fedora, there's a change which makes default prefix to be
/usr/local and we need to use /usr
Usage: make PREFIX=/usr/ install
---
framework/src/Makefile.am | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/framework/src/Makefile.am b/framework/src/Makefile.am
index b0e87da..725cb96 100644
--- a/framework/src/Makefile.am
+++ b/framework/src/Makefile.am
@@ -107,7 +107,8 @@ python-build:
$(PYTHON) setup.py build
install-exec-hook:
- $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+ $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` \
+ `test -n "$(PREFIX)" && echo --prefix $(PREFIX)`
uninstall-hook:
$(PYTHON) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
--
2.14.1