setools/setools-rhat.patch

118 lines
3.5 KiB
Diff

--- setools-1.1.1/libapol/Makefile.rhat 2003-11-05 09:55:44.000000000 -0500
+++ setools-1.1.1/libapol/Makefile 2004-01-09 15:08:43.599401736 -0500
@@ -1,5 +1,7 @@
# libapol and lipapol-tcl
+LIBDIR = $(DESTDIR)/usr/lib
+INCLUDEDIR = $(DESTDIR)/usr/include/selinux/apol
LIB-OBJ = policy.o policy-query.o policy-io.o queue.o util.o clone.o
LIB-OBJ += y.tab.o lex.yy.o avl-util.o policy-avl.o render.o analysis.o
LIB-OBJ += perm-map.o cond.o
@@ -30,6 +32,10 @@
../lib:
mkdir -p $@
+install: libapol
+ install -m 644 ../lib/libapol.a $(LIBDIR)
+ install -m 644 *.h $(INCLUDEDIR)
+
clean:
rm -f *.o core y.tab.c y.tab.h lex.yy.c *~
--- setools-1.1.1/libseuser/Makefile.rhat 2003-12-29 12:27:01.000000000 -0500
+++ setools-1.1.1/libseuser/Makefile 2004-01-09 15:10:51.634505763 -0500
@@ -1,5 +1,8 @@
# libseuser and libseuser-tcl
+LIBDIR = $(DESTDIR)/usr/lib
+INCLUDEDIR = $(DESTDIR)/usr/include/selinux/apol
+
LIB-OBJ = seuser_db.o
LIB-OBJ-TCL = $(LIB-OBJ) seuser_tcl.o
@@ -9,6 +12,10 @@
libseuser-tcl: ../lib/libseuser-tcl.a
+install: libseuser libseuser-tcl
+ install -m 644 ../lib/libseuser.a $(LIBDIR)
+ install -m 644 *.h $(INCLUDEDIR)
+
../lib/libseuser.a: ../lib $(LIB-OBJ)
ar cr $@ $(LIB-OBJ)
--- setools-1.1.1/packages/Makefile.rhat 2003-12-08 16:04:19.000000000 -0500
+++ setools-1.1.1/packages/Makefile 2004-01-09 15:08:43.628398362 -0500
@@ -3,10 +3,11 @@
# by Kevin Carr kcarr@tresys.com
# Make sure INSTALL_PATH is set properly for your system!
-INSTALL_PATH=/usr/share/tcl8.3/
+INSTALL_PATH=$(DESTDIR)/usr/share/tcl8.3/
install:
+ mkdir -p $(INSTALL_PATH)
tar -zxvf BWidget-1.4.1.tar.gz
mv BWidget-1.4.1 $(INSTALL_PATH)
@@ -20,4 +21,4 @@
rm -rf BWidget-1.4.1/
bare:
- clean
\ No newline at end of file
+ clean
--- setools-1.1.1/Makefile.rhat 2003-12-30 10:58:17.000000000 -0500
+++ setools-1.1.1/Makefile 2004-01-09 15:12:51.410570671 -0500
@@ -4,10 +4,9 @@
MAKE = make
LIBS = -lfl -lm
-TCLVER = 8.3
TCL_INCLUDE = -I/usr/include
TCL_LIBINC = -L/usr/lib
-TCL_LIBS = -ltk$(TCLVER) -ltcl$(TCLVER) -ldl $(LIBS)
+TCL_LIBS = -ltk -ltcl -ldl $(LIBS)
LINKFLAGS =
CC = gcc
@@ -85,6 +84,8 @@
@echo " install-seuserx: build and install seuser and seuserx (selinux required)"
@echo " install-secmds: build and install command line tools (selinux not required)"
@echo " install-seaudit: build and install seaudit (selinux not required)"
+ @echo " install-bwidget: build and install BWidget (selinux not required)"
+ @echo " install-libraries: build and install libraries"
@echo " "
@echo " all: build everything, but don't install"
@echo " all-nogui: only build non-GUI tools and libraries"
@@ -147,6 +148,15 @@
install-awish: $(INSTALL_LIBDIR)
cd awish; $(MAKE) install
+install-libseuser:
+ cd libseuser; $(MAKE) install
+
+install-libapol:
+ cd libapol; $(MAKE) install
+
+install-libraries: install-libseuser install-libapol
+ cd libseuser; $(MAKE) install
+
# installs both GUI and non-GUI versions
install-seuserx: $(INSTALL_LIBDIR)
cd seuser; $(MAKE) install
@@ -166,8 +176,11 @@
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
+install-bwidget:
+ cd packages; make
-install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit
+
+install: install-apol install-seuser install-seuserx install-sepcut install-awish install-secmds install-seaudit install-bwidget install-libraries
# Next four targets are to support installation as part of a system
# install. These targets are deprecated.