setools/setools-rhat.patch

62 lines
1.9 KiB
Diff

--- setools-3.0/configure.ac.rhat 2006-10-13 14:59:34.000000000 -0400
+++ setools-3.0/configure.ac 2006-10-30 13:26:43.000000000 -0500
@@ -19,7 +19,7 @@
libseaudit_version=3.0.0
-setoolsdir='${prefix}/share/setools-3.0'
+setoolsdir='${prefix}/share/setools'
version_min_sepol_major=1
version_min_sepol_minor=12
@@ -84,6 +84,7 @@
fi
AC_MSG_RESULT(disabled)
fi
+AC_SUBST(YFLAGS)
AC_SUBST(DEBUGCFLAGS)
AC_SUBST(DEBUGLDFLAGS)
QPOL_CFLAGS='-I$(top_srcdir)/libqpol/include'
@@ -220,7 +221,10 @@
AC_SUBST(BWIDGET_DESTDIR)
fi
else
- copy_bwidget=no
+
+ BWIDGET_DESTDIR="\$(DESTDIR)/\${datadir}/tcl8.4/"
+ AC_SUBST(BWIDGET_DESTDIR)
+ copy_bwidget=yes
bwidget_ver=1.8
fi
@@ -249,17 +253,21 @@
AC_ARG_WITH(sepol-devel,
AC_HELP_STRING([--with-sepol-devel],
[prefix where sepol development files are installed]),
- sepol_devel="$withval",
- sepol_devel="/usr")
+ sepol_devel_incdir="${withval}/include"
+ sepol_devel_libdir="${withval}/lib"
+ ,
+ sepol_devel_incdir="/usr/include"
+ sepol_devel_libdir="${libdir}"
+ )
AC_ARG_WITH(selinux-devel,
AC_HELP_STRING([--with-selinux-devel],
[prefix where SELinux development files are installed]),
- selinux_devel="$withval",
- selinux_devel="/usr")
-sepol_devel_incdir="${sepol_devel}/include"
-sepol_devel_libdir="${sepol_devel}/lib"
-selinux_devel_incdir="${selinux_devel}/include"
-selinux_devel_libdir="${selinux_devel}/lib"
+ selinux_devel_incdir="${withval}/include"
+ selinux_devel_libdir="${withval}/lib"
+ ,
+ selinux_devel_incdir="/usr/include"
+ selinux_devel_libdir="${libdir}"
+ )
AC_MSG_CHECKING([for sepol/sepol.h])
selinux_save_CFLAGS="${CFLAGS}"
SELINUX_LIB_FLAG="-L${sepol_devel_libdir} -L${selinux_devel_libdir}"