setools/setools-rhat.patch

122 lines
3.9 KiB
Diff

--- setools-3.1/packages/Makefile.am.rhat 2007-02-06 15:43:29.000000000 -0500
+++ setools-3.1/packages/Makefile.am 2007-02-15 11:20:09.000000000 -0500
@@ -8,7 +8,7 @@
tar jxf BWidget-1.8.0.tar.bz2
test -z "$(bwidget_destdir)" || $(mkdir_p) "$(bwidget_destdir)"
cd BWidget-1.8.0 && find . -type d -exec $(mkdir_p) "$(bwidget_destdir)/{}" \;
- cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir) \;
+ cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir)/'{}'\;
uninstall-local:
-rm -rf $(bwidget_destdir)/BWidget-1.8.0
--- setools-3.1/packages/Makefile.in.rhat 2007-02-15 11:21:11.000000000 -0500
+++ setools-3.1/packages/Makefile.in 2007-02-15 11:21:24.000000000 -0500
@@ -381,7 +381,7 @@
tar jxf BWidget-1.8.0.tar.bz2
test -z "$(bwidget_destdir)" || $(mkdir_p) "$(bwidget_destdir)"
cd BWidget-1.8.0 && find . -type d -exec $(mkdir_p) "$(bwidget_destdir)/{}" \;
- cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir) \;
+ cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir)/'{}' \;
uninstall-local:
-rm -rf $(bwidget_destdir)/BWidget-1.8.0
--- setools-3.1/libqpol/src/policy_parse.y.rhat 2007-02-06 15:43:26.000000000 -0500
+++ setools-3.1/libqpol/src/policy_parse.y 2007-02-15 11:19:06.000000000 -0500
@@ -1098,11 +1098,11 @@
ret = hashtab_insert(policydbp->p_commons.table,
(hashtab_key_t) id, (hashtab_datum_t) comdatum);
- if (ret == HASHTAB_PRESENT) {
+ if (ret == SEPOL_EEXIST) {
yyerror("duplicate common definition");
goto bad;
}
- if (ret == HASHTAB_OVERFLOW) {
+ if (ret == SEPOL_ENOMEM) {
yyerror("hash table overflow");
goto bad;
}
@@ -1130,14 +1130,14 @@
(hashtab_key_t) perm,
(hashtab_datum_t) perdatum);
- if (ret == HASHTAB_PRESENT) {
+ if (ret == SEPOL_EEXIST) {
sprintf(errormsg,
"duplicate permission %s in common %s", perm,
id);
yyerror(errormsg);
goto bad_perm;
}
- if (ret == HASHTAB_OVERFLOW) {
+ if (ret == SEPOL_ENOMEM) {
yyerror("hash table overflow");
goto bad_perm;
}
@@ -1259,12 +1259,12 @@
(hashtab_key_t) id,
(hashtab_datum_t) perdatum);
- if (ret == HASHTAB_PRESENT) {
+ if (ret == SEPOL_EEXIST) {
sprintf(errormsg, "duplicate permission %s", id);
yyerror(errormsg);
goto bad;
}
- if (ret == HASHTAB_OVERFLOW) {
+ if (ret == SEPOL_ENOMEM) {
yyerror("hash table overflow");
goto bad;
}
--- setools-3.1/libqpol/src/policy_extend.c.rhat 2007-02-07 14:16:52.000000000 -0500
+++ setools-3.1/libqpol/src/policy_extend.c 2007-02-15 11:19:06.000000000 -0500
@@ -167,7 +167,7 @@
retv = hashtab_insert(db->p_types.table, (hashtab_key_t) tmp_name, (hashtab_datum_t) tmp_type);
if (retv) {
- if (retv == HASHTAB_OVERFLOW)
+ if (retv == SEPOL_ENOMEM)
error = db->p_types.table ? ENOMEM : EINVAL;
else
error = EEXIST;
@@ -243,7 +243,7 @@
retv = hashtab_insert(db->p_types.table, (hashtab_key_t) tmp_name, (hashtab_datum_t) tmp_type);
if (retv) {
- if (retv == HASHTAB_OVERFLOW)
+ if (retv == SEPOL_ENOMEM)
error = db->p_types.table ? ENOMEM : EINVAL;
else
error = EEXIST;
--- setools-3.1/configure.ac.rhat 2007-02-07 10:48:44.000000000 -0500
+++ setools-3.1/configure.ac 2007-02-15 11:19:06.000000000 -0500
@@ -20,7 +20,7 @@
libseaudit_version=4.0.0
libseaudit_soname=libseaudit.so.4
-setoolsdir='${prefix}/share/setools-3.1'
+setoolsdir='${prefix}/share/setools'
version_min_sepol_major=1
version_min_sepol_minor=12
@@ -88,6 +88,7 @@
fi
AC_MSG_RESULT(disabled)
fi
+AC_SUBST(YFLAGS)
AC_SUBST(DEBUGCFLAGS)
AC_SUBST(DEBUGLDFLAGS)
QPOL_CFLAGS='-I$(top_srcdir)/libqpol/include'
@@ -227,7 +228,10 @@
AC_SUBST(BWIDGET_DESTDIR)
fi
else
- copy_bwidget=no
+
+ BWIDGET_DESTDIR="\$(DESTDIR)/\${datadir}/tcl8.4/BWidget-1.8.0"
+ AC_SUBST(BWIDGET_DESTDIR)
+ copy_bwidget=yes
bwidget_ver=1.8
fi