setools/setools-rhat.patch

44 lines
1.6 KiB
Diff

--- setools-2.3/apol/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
+++ setools-2.3/apol/Makefile 2006-01-31 16:15:53.000000000 -0500
@@ -85,7 +85,7 @@
$(MAKE) -C .. libsefs
install: apol apol.tcl
- install -m 755 apol $(BINDIR)
+ install -m 755 apol $(SBINDIR)
@if [ -n $(INSTALL_LIBDIR) ]; then \
for file in $(TCL-FILES); do \
if [ -f $(INSTALL_LIBDIR)/$$file ]; then \
--- setools-2.3/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
+++ setools-2.3/Makefile 2006-01-31 16:18:43.000000000 -0500
@@ -12,7 +12,7 @@
PREFIX ?= $(DESTDIR)/usr
INCLUDE_DIR = $(PREFIX)/include
-SHARED_LIB_INSTALL_DIR = $(PREFIX)/lib
+SHARED_LIB_INSTALL_DIR = $(DESTDIR)$(LIBDIR)
STATIC_LIB_INSTALL_DIR = $(SHARED_LIB_INSTALL_DIR)
#SETOOLS_INCLUDE = $(INCLUDE_DIR)/setools-$(SETOOLS_VER)
TCLVER = $(shell env tclsh tcl_vars)
@@ -37,7 +37,7 @@
# instead of "/usr/share/setools/". This probably needs to become more
# robust in the future.
#
-INSTALL_LIBDIR = $(PREFIX)/share/setools-$(SETOOLS_VER)
+INSTALL_LIBDIR = $(PREFIX)/share/setools
# all apps that have a te/fc file need to be listed here
POLICYINSTALLDIRS =
# Help files here
--- setools-2.3/sediff/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
+++ setools-2.3/sediff/Makefile 2006-01-31 16:15:53.000000000 -0500
@@ -22,7 +22,8 @@
install -m 644 ../man/sediff.1 $(MANDIR)/man1
install: all
- install -m 755 sediff sediffx $(BINDIR);
+ install -m 755 sediff $(BINDIR);
+ install -m 755 sediffx $(SBINDIR);
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
install -m 644 sediff_help.txt $(INSTALL_HELPDIR)