setools/0001-Do-not-use-Werror-during-build.patch
Vit Mojzis b2c4c6ff83 setools-4.2.0-0.1.beta
- New upstream release
-- Replaced the Python/SWIG/static-linked-libsepol policyrep module with
    a Cython implementation. This will have performance and memory-usage
    improvements and breaks the static linking to libsepol.
-- Significant memory usage reduction in sediff (approximately 60%,
    depending on the policies).
-- Added support for SCTP portcons
-- Updated permission maps
-- Support for Python 2.7 was dropped

- Drop python2 subpackage (4.2.0 no longer supports python2)
2018-08-10 10:34:03 +02:00

28 lines
1.0 KiB
Diff

From 42e691b12c03aac388e39071f4b8d76cbc40e5c5 Mon Sep 17 00:00:00 2001
From: Vit Mojzis <vmojzis@redhat.com>
Date: Fri, 29 Jun 2018 10:34:14 +0200
Subject: [PATCH 1/2] Do not use -Werror during build
There are new warnings when setools are built with gcc 7 therefore we
want to suppress -Werror for now
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index aa4f14b..e4da575 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,7 @@ ext_py_mods = [Extension('setools.policyrep.libpolicyrep', ['setools/policyrep/l
library_dirs=lib_dirs,
runtime_library_dirs=lib_dirs,
define_macros=macros,
- extra_compile_args=['-Werror', '-Wextra',
+ extra_compile_args=['-Wextra',
'-Waggregate-return',
'-Wfloat-equal',
'-Wformat', '-Wformat=2',
--
2.14.3