setools/1001-Do-not-use-Werror-duri...

28 lines
1.0 KiB
Diff

From 8ef1a20824c2055cc16b66b56018a95e30b9a73c Mon Sep 17 00:00:00 2001
From: Vit Mojzis <vmojzis@redhat.com>
Date: Mon, 1 Oct 2018 15:50:09 +0200
Subject: [PATCH 1/2] Do not use -Werror during build
There are new warnings when setools are built with gcc 7 therefore we
want to suppress -Werror for now
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 0530d59..027d315 100644
--- a/setup.py
+++ b/setup.py
@@ -105,7 +105,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
libraries=['selinux', 'sepol'],
library_dirs=lib_dirs,
define_macros=macros,
- extra_compile_args=['-Werror', '-Wextra',
+ extra_compile_args=['-Wextra',
'-Waggregate-return',
'-Wfloat-equal',
'-Wformat', '-Wformat=2',
--
2.17.1