4db8a2fbe8
Thu Jun 10 2004 Dan Walsh <dwalsh@redhat.com> 1.4-2 - Fix install locations of policy_src_dir
254 lines
7.7 KiB
Diff
254 lines
7.7 KiB
Diff
--- setools-1.4/seuser/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
|
+++ setools-1.4/seuser/Makefile 2004-06-02 15:57:20.000000000 -0400
|
|
@@ -22,10 +22,10 @@
|
|
SHELL = /bin/sh
|
|
|
|
seuser: $(CMD-OBJ)
|
|
- $(CC) -o $@ $(CMD-OBJ) $(LINKFLAGS) $(LIBS)
|
|
+ $(CC) -o $@ $(CMD-OBJ) $(LINKFLAGS) $(LIBS) -lselinux
|
|
|
|
seuserx: $(GUI-OBJ) se_user.tcl
|
|
- $(CC) $(GUI_CFLAGS) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS)
|
|
+ $(CC) $(GUI_CFLAGS) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
|
|
|
|
se_user.tcl: $(TCL-FILES)
|
|
cat $(TCL-FILES) | \
|
|
--- setools-1.4/awish/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
|
+++ setools-1.4/awish/Makefile 2004-06-02 15:57:20.000000000 -0400
|
|
@@ -4,7 +4,7 @@
|
|
AWISH_OBJ = awish.o $(LIBSEUSER-TCL) $(LIBAPOL-TCL)
|
|
|
|
awish: $(AWISH_OBJ)
|
|
- $(CC) $(TCL_LIBINC) -o $@ $(AWISH_OBJ) $(LINKFLAGS) $(TCL_LIBS)
|
|
+ $(CC) $(TCL_LIBINC) -o $@ $(AWISH_OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
|
|
|
|
|
|
%.o: %.c
|
|
@@ -12,16 +12,16 @@
|
|
|
|
../lib/libapol.a:
|
|
cd ../ ; $(MAKE) libapol
|
|
-
|
|
+
|
|
../lib/libapol-tcl.a:
|
|
cd ../ ; $(MAKE) libapol-tcl
|
|
|
|
../lib/libseuser-tcl.a:
|
|
cd ../ ; $(MAKE) libseuser-tcl
|
|
-
|
|
+
|
|
../lib/libseuser.a:
|
|
cd ../ ; $(MAKE) libseuser
|
|
-
|
|
+
|
|
install: awish
|
|
install -m 755 awish $(BINDIR)
|
|
|
|
--- setools-1.4/libseuser/seuser_db.c.rhat 2004-06-02 13:44:13.000000000 -0400
|
|
+++ setools-1.4/libseuser/seuser_db.c 2004-06-02 15:57:20.000000000 -0400
|
|
@@ -17,6 +17,7 @@
|
|
#include <pwd.h>
|
|
#include <sys/types.h>
|
|
#include <unistd.h>
|
|
+#include <limits.h>
|
|
#include "seuser_db.h"
|
|
|
|
/* apol lib */
|
|
@@ -788,8 +789,10 @@
|
|
}
|
|
free(full_config);
|
|
|
|
-
|
|
- db->policy_conf = get_config_var("policy.conf", fp);
|
|
+ /* db->policy_conf = get_config_var("policy.conf", fp);*/
|
|
+ db->policy_conf = malloc(PATH_MAX);
|
|
+ snprintf(db->policy_conf, PATH_MAX, "%s/src/policy/policy.conf",
|
|
+ selinux_policy_root());
|
|
if(db->policy_conf == NULL) {
|
|
fclose(fp);
|
|
free_conf_info(db);
|
|
@@ -804,7 +807,9 @@
|
|
return 4;
|
|
}
|
|
|
|
- db->policy_dir = get_config_var("policy_dir", fp);
|
|
+ /* db->policy_dir = get_config_var("policy_dir", fp);*/
|
|
+ db->policy_dir = malloc(PATH_MAX);
|
|
+ snprintf(db->policy_dir, PATH_MAX, "%s/src/policy", selinux_policy_root());
|
|
if(db->policy_dir == NULL) {
|
|
fclose(fp);
|
|
free_conf_info(db);
|
|
@@ -819,7 +824,9 @@
|
|
return 6;
|
|
}
|
|
|
|
- db->user_file = get_config_var("user_file", fp);
|
|
+ /* db->user_file = get_config_var("user_file", fp);*/
|
|
+ db->user_file = malloc(PATH_MAX);
|
|
+ snprintf(db->user_file, PATH_MAX, "%s/src/policy/users", selinux_policy_root());
|
|
if(db->user_file == NULL) {
|
|
fclose(fp);
|
|
free_conf_info(db);
|
|
@@ -828,7 +835,8 @@
|
|
}
|
|
/* users file may not exist which is ok, so we won't check read access. */
|
|
|
|
- db->file_contexts_file = get_config_var("file_contexts_file", fp);
|
|
+ /* db->file_contexts_file = get_config_var("file_contexts_file", fp);*/
|
|
+ db->file_contexts_file = strdup(selinux_file_context_path());
|
|
if(db->file_contexts_file == NULL) {
|
|
fclose(fp);
|
|
free_conf_info(db);
|
|
--- setools-1.4/libseuser/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
|
+++ setools-1.4/libseuser/Makefile 2004-06-02 15:57:20.000000000 -0400
|
|
@@ -11,8 +11,12 @@
|
|
|
|
libseuser-tcl: ../lib/libseuser-tcl.a
|
|
|
|
+install: libseuser libseuser-tcl
|
|
+ install -m 644 ../lib/libseuser.a $(INSTALL_LIBDIR)
|
|
+ install -m 644 *.h $(INCLUDEDIR)
|
|
+
|
|
../lib/libseuser.a: ../lib $(LIB-OBJ)
|
|
- ar cr $@ $(LIB-OBJ)
|
|
+ ar cr $@ $(LIB-OBJ) -lselinux
|
|
|
|
../lib/libseuser-tcl.a: ../lib $(LIB-OBJ-TCL)
|
|
ar cr $@ $(LIB-OBJ-TCL)
|
|
@@ -20,7 +24,7 @@
|
|
%.o: %.c
|
|
$(CC) $(CFLAGS) -c $<
|
|
|
|
-
|
|
+
|
|
../lib:
|
|
mkdir -p $@
|
|
|
|
--- setools-1.4/packages/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
|
+++ setools-1.4/packages/Makefile 2004-06-02 16:03:28.000000000 -0400
|
|
@@ -4,9 +4,10 @@
|
|
|
|
# INSTALL_PATH is set based upon your current
|
|
# version of tcl using the tcl_vars script.
|
|
-INSTALL_PATH=$(shell env tclsh ../tcl_vars tcl_library)
|
|
+INSTALL_PATH=$(DESTDIR)/$(shell env tclsh ../tcl_vars tcl_library)
|
|
|
|
install:
|
|
+ mkdir -p $(INSTALL_PATH)
|
|
tar -zxvf BWidget-1.4.1.tar.gz
|
|
mv BWidget-1.4.1 $(INSTALL_PATH)
|
|
|
|
@@ -19,4 +20,4 @@
|
|
clean:
|
|
rm -rf BWidget-1.4.1/
|
|
|
|
-bare: clean
|
|
\ No newline at end of file
|
|
+bare: clean
|
|
--- setools-1.4/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
|
+++ setools-1.4/Makefile 2004-06-10 14:56:04.354591984 -0400
|
|
@@ -21,8 +21,9 @@
|
|
# File location defaults; used in various places in code
|
|
# Change these if you want different defaults
|
|
SELINUX_DIR = $(DESTDIR)/selinux
|
|
-POLICY_INSTALL_DIR = $(DESTDIR)/etc/security/selinux
|
|
-POLICY_SRC_DIR = $(DESTDIR)$(POLICY_INSTALL_DIR)/src/policy
|
|
+SELINUX_POLICY_DIR = $(DESTDIR)/etc/selinux/strict/
|
|
+POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/policy
|
|
+POLICY_SRC_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/src/policy
|
|
POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
|
|
DEFAULT_LOG_FILE = /var/log/messages
|
|
|
|
@@ -120,7 +121,7 @@
|
|
echo "Could not build awish."; \
|
|
echo "Tcl library is not built or not in expected location(s)."; \
|
|
fi
|
|
-
|
|
+
|
|
seuser: selinux_tool
|
|
cd seuser; $(MAKE) seuser
|
|
|
|
@@ -141,9 +142,9 @@
|
|
|
|
secmds: selinux_tool
|
|
cd secmds; $(MAKE) all
|
|
-
|
|
+
|
|
libapol: selinux_tool
|
|
- cd libapol; $(MAKE) libapol
|
|
+ cd libapol; $(MAKE) libapol
|
|
|
|
libapol-tcl: selinux_tool
|
|
cd libapol;
|
|
@@ -215,17 +216,23 @@
|
|
|
|
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
|
|
|
|
+install-bwidget:
|
|
+ cd packages; make
|
|
+
|
|
+install-docs: docs
|
|
+ install -m 755 -d $(INSTALL_HELPDIR)
|
|
+ cd docs-src; $(MAKE) install INSTALL_HELPDIR=$(INSTALL_HELPDIR)
|
|
|
|
-install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit
|
|
+install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit install-bwidget install-docs
|
|
|
|
# Install the policy - this is a separate step to better support systems with
|
|
# non-standard policies.
|
|
install-seuser-policy: $(INSTALL_LIBDIR)
|
|
cd seuser; $(MAKE) install-policy
|
|
-
|
|
+
|
|
install-secmds-policy: $(INSTALL_LIBDIR)
|
|
cd secmds; $(MAKE) install-policy
|
|
-
|
|
+
|
|
install-policy: install-seuser-policy install-secmds-policy
|
|
|
|
# Next four targets are to support installation as part of a system
|
|
--- setools-1.4/docs-src/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
|
|
+++ setools-1.4/docs-src/Makefile 2004-06-02 15:57:20.000000000 -0400
|
|
@@ -55,3 +55,14 @@
|
|
for file in $(TOP-DOCS); do \
|
|
rm -f ../$$file; \
|
|
done
|
|
+
|
|
+install:
|
|
+ for file in KNOWN-BUGS README; do \
|
|
+ cat $$file.in | sed -e 's/RELEASE_VERSION/$(shell cat ../VERSION)/g' | \
|
|
+ sed -e 's/MOD_DATE/$(shell date '+%B %d, %G')/g' > ${INSTALL_HELPDIR}/$$file; \
|
|
+ done
|
|
+ install -m 644 ../seaudit/seaudit_help.txt ${INSTALL_HELPDIR}
|
|
+ install -m 644 ../seuser/seuser_help.txt ${INSTALL_HELPDIR}
|
|
+ install -m 644 ../sepct/sepcut_help.txt ${INSTALL_HELPDIR}
|
|
+ install -m 644 ../apol/*.txt ${INSTALL_HELPDIR}
|
|
+
|
|
--- setools-1.4/apol/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
|
|
+++ setools-1.4/apol/Makefile 2004-06-02 15:57:20.000000000 -0400
|
|
@@ -11,14 +11,14 @@
|
|
APOL_HELP_FILES = apol_help.txt dta_help.txt iflow_help.txt obj_perms_help.txt
|
|
APOL_PERM_MAPS = apol_perm_mapping_ver12 apol_perm_mapping_ver15 \
|
|
apol_perm_mapping_ver16 apol_perm_mapping_ver17
|
|
-
|
|
+
|
|
APOL_DFLT_PMAP = apol_perm_mapping_ver16
|
|
LIBAPOL = ../lib/libapol-tcl.a ../lib/libapol.a
|
|
GUI-OBJ = apol_gui.o $(LIBAPOL)
|
|
CFLAGS += -DSTARTUP_SCRIPT='"$(APOL_STARTUP_SCRIPT)"'
|
|
|
|
apol: $(GUI-OBJ) apol.tcl
|
|
- $(CC) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS)
|
|
+ $(CC) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
|
|
|
|
|
|
apol.tcl: $(TCL-FILES)
|
|
@@ -55,6 +55,7 @@
|
|
done \
|
|
fi
|
|
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR)
|
|
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
|
|
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
|
|
|
|
clean:
|