29 lines
1.2 KiB
Diff
29 lines
1.2 KiB
Diff
diff -up setools-3.3.7/libqpol/swig/java/Makefile.am.seaudit setools-3.3.7/libqpol/swig/java/Makefile.am
|
|
--- setools-3.3.7/libqpol/swig/java/Makefile.am.seaudit 2010-05-03 12:37:54.000000000 -0400
|
|
+++ setools-3.3.7/libqpol/swig/java/Makefile.am 2012-09-28 10:15:56.408912525 -0400
|
|
@@ -48,7 +48,6 @@ BUILT_SOURCES = qpol_wrap.c \
|
|
qpol_type_t.java \
|
|
qpol_user_t.java \
|
|
qpol_validatetrans_t.java \
|
|
- SWIGTYPE_p_int.java \
|
|
SWIGTYPE_p_unsigned_int.java \
|
|
SWIGTYPE_p_void.java
|
|
|
|
diff -up setools-3.3.7/seaudit/progress.c.seaudit setools-3.3.7/seaudit/progress.c
|
|
--- setools-3.3.7/seaudit/progress.c.seaudit 2007-08-02 17:16:33.000000000 -0400
|
|
+++ setools-3.3.7/seaudit/progress.c 2012-09-28 10:15:56.407912521 -0400
|
|
@@ -99,10 +99,11 @@ void progress_hide(progress_t * progress
|
|
|
|
int progress_wait(progress_t * progress)
|
|
{
|
|
- GTimeVal wait_time = { 0, 50000 };
|
|
+ gint64 end_time;
|
|
g_mutex_lock(progress->mutex);
|
|
while (!progress->done) {
|
|
- g_cond_timed_wait(progress->cond, progress->mutex, &wait_time);
|
|
+ end_time = g_get_monotonic_time () + 50000; // need to be set before each wait
|
|
+ g_cond_wait_until(progress->cond, progress->mutex,end_time);
|
|
if (progress->s != NULL) {
|
|
gtk_label_set_text(GTK_LABEL(progress->label2), progress->s);
|
|
free(progress->s);
|