SETools 4.2.1 release

This commit is contained in:
Vit Mojzis 2019-05-07 16:27:17 +02:00
parent 522fb13c60
commit d0560d2da2
5 changed files with 54 additions and 27 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@ setools-3.3.8-f1e5b20.tar.bz2
/4.2.0-beta.tar.gz
/4.2.0-rc.tar.gz
/4.2.0.tar.gz
/4.2.1.tar.gz

View File

@ -1,16 +1,38 @@
From 8ef1a20824c2055cc16b66b56018a95e30b9a73c Mon Sep 17 00:00:00 2001
From: Vit Mojzis <vmojzis@redhat.com>
Date: Mon, 1 Oct 2018 15:50:09 +0200
From 617c3ae83c1c72ead627a57e1529724c62df807f Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Thu, 23 Feb 2017 08:17:07 +0100
Subject: [PATCH 1/2] Do not use -Werror during build
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
There are new warnings when setools are built with gcc 7 therefore we
want to suppress -Werror for now
Fixes:
libqpol/policy_extend.c: In function policy_extend:
libqpol/policy_extend.c:161:27: error: %04zd directive output may be truncated writing between 4 and 10 bytes into a region of size 5 [-Werror=format-truncation=]
snprintf(buff, 9, "@ttr%04zd", i + 1);
^~~~~
libqpol/policy_extend.c:161:22: note: directive argument in the range [1, 4294967295]
snprintf(buff, 9, "@ttr%04zd", i + 1);
^~~~~~~~~~~
In file included from /usr/include/stdio.h:939:0,
from /usr/include/sepol/policydb/policydb.h:53,
from libqpol/policy_extend.c:29:
/usr/include/bits/stdio2.h:64:10: note: __builtin___snprintf_chk output between 9 and 15 bytes into a destination of size 9
return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1,
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
__bos (__s), __fmt, __va_arg_pack ());
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
error: command 'gcc' failed with exit status 1
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 0530d59..027d315 100644
index 2ca44c9..9319bf6 100644
--- a/setup.py
+++ b/setup.py
@@ -105,7 +105,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
@ -23,5 +45,5 @@ index 0530d59..027d315 100644
'-Wfloat-equal',
'-Wformat', '-Wformat=2',
--
2.17.1
2.9.3

View File

@ -1,7 +1,7 @@
From 7a38c92583b5b6d6b14b43ba9b8c56d4e04b0b82 Mon Sep 17 00:00:00 2001
From: Vit Mojzis <vmojzis@redhat.com>
Date: Mon, 1 Oct 2018 17:16:28 +0200
Subject: [PATCH 2/2] Do not export/use setools.InfoFlowAnalysis and
From 2ac3a2236e827087097c63478be302ddc627a42b Mon Sep 17 00:00:00 2001
From: Petr Lautrbach <plautrba@redhat.com>
Date: Tue, 26 Mar 2019 12:06:57 +0100
Subject: [PATCH] Do not export/use setools.InfoFlowAnalysis and
setools.DomainTransitionAnalysis
dta and infoflow modules require networkx which brings lot of dependencies.
@ -14,27 +14,27 @@ sedta and seinfoflow to require python3-networkx
---
sedta | 4 ++--
seinfoflow | 4 ++--
setools/__init__.py | 4 ++--
setools/__init__.py | 4 ----
setoolsgui/apol/dta.py | 2 +-
setoolsgui/apol/infoflow.py | 2 +-
tests/dta.py | 2 +-
tests/infoflow.py | 2 +-
7 files changed, 10 insertions(+), 10 deletions(-)
7 files changed, 8 insertions(+), 12 deletions(-)
diff --git a/sedta b/sedta
index 10cf43a..b75b4e1 100755
index 60861ca..41e38a2 100755
--- a/sedta
+++ b/sedta
@@ -21,7 +21,7 @@ import sys
import argparse
@@ -22,7 +22,7 @@ import argparse
import logging
import signal
-import setools
+import setools.dta
def print_transition(trans):
@@ -111,7 +111,7 @@ else:
@@ -114,7 +114,7 @@ else:
try:
p = setools.SELinuxPolicy(args.policy)
@ -44,7 +44,7 @@ index 10cf43a..b75b4e1 100755
if args.shortest_path or args.all_paths:
if args.shortest_path:
diff --git a/seinfoflow b/seinfoflow
index 3ec05ca..32a9a3e 100755
index 97b14ba..e7f965d 100755
--- a/seinfoflow
+++ b/seinfoflow
@@ -17,7 +17,7 @@
@ -56,7 +56,7 @@ index 3ec05ca..32a9a3e 100755
import argparse
import sys
import logging
@@ -78,7 +78,7 @@ else:
@@ -81,7 +81,7 @@ else:
try:
p = setools.SELinuxPolicy(args.policy)
m = setools.PermissionMap(args.map)
@ -66,10 +66,10 @@ index 3ec05ca..32a9a3e 100755
if args.shortest_path or args.all_paths:
if args.shortest_path:
diff --git a/setools/__init__.py b/setools/__init__.py
index 7b70f5e..020be31 100644
index 7b70f5e..5a5f7fe 100644
--- a/setools/__init__.py
+++ b/setools/__init__.py
@@ -73,11 +73,11 @@ from .pcideviceconquery import PcideviceconQuery
@@ -73,12 +73,8 @@ from .pcideviceconquery import PcideviceconQuery
from .devicetreeconquery import DevicetreeconQuery
# Information Flow Analysis
@ -77,12 +77,12 @@ index 7b70f5e..020be31 100644
+# from .infoflow import InfoFlowAnalysis
from .permmap import PermissionMap
# Domain Transition Analysis
-# Domain Transition Analysis
-from .dta import DomainTransitionAnalysis
+# from .dta import DomainTransitionAnalysis
-
# Policy difference
from .diff import PolicyDifference
diff --git a/setoolsgui/apol/dta.py b/setoolsgui/apol/dta.py
index 4608b9d..2cde44c 100644
--- a/setoolsgui/apol/dta.py
@ -136,5 +136,5 @@ index aa0e44a..fca2848 100644
from setools.exception import InvalidType
from setools.permmap import PermissionMap
--
2.17.1
2.21.0

View File

@ -1,11 +1,12 @@
# % global setools_pre_ver rc
# % global gitver f1e5b20
%global sepol_ver 2.8-1
%global selinux_ver 2.8-1
%global sepol_ver 2.9-1
%global selinux_ver 2.9-1
Name: setools
Version: 4.2.0
Version: 4.2.1
Release: 1%{?setools_pre_ver:.%{setools_pre_ver}}%{?dist}
Summary: Policy analysis tools for SELinux
@ -140,6 +141,9 @@ CFLAGS="%{optflags}" %{__python3} setup.py build
%{_mandir}/man1/apol*
%changelog
* Tue Mar 26 2019 Petr Lautrbach <plautrba@redhat.com> - 4.2.1-1
- - SETools 4.2.1 release
* Wed Nov 14 2018 Vit Mojzis <vmojzis@redhat.com> - 4.2.0-1
- Update source to SETools 4.2.0 release

View File

@ -1 +1 @@
SHA512 (4.2.0.tar.gz) = b51f458f7f2d1b569f63478f53709268615f711104915cc2d5031b2049435e4f43a103ebe50c9797ebe4b2645bf1974c73c2f53e7f602ae03c47221edb89d680
SHA512 (4.2.1.tar.gz) = 7d00295fe7ff16e96e15266807f8e0a67cc2978f9051cd85afb9ee71ca7fad16ccf7421a4a163bb793950bc20a44f3cbb8409b4e0642d0f96cf7a3df7bc59c31