mgrepl patch to Fix swig coding style for structures related to SWIG changes

This commit is contained in:
Dan Walsh 2012-07-11 15:08:27 -04:00
parent b606c9e8b9
commit cfe6f2a173
3 changed files with 13 additions and 31 deletions

View File

@ -1,22 +0,0 @@
diff -up setools-3.3.7/libqpol/swig/java/Makefile.am~ setools-3.3.7/libqpol/swig/java/Makefile.am
--- setools-3.3.7/libqpol/swig/java/Makefile.am~ 2010-05-03 12:37:54.000000000 -0400
+++ setools-3.3.7/libqpol/swig/java/Makefile.am 2012-07-11 14:00:59.592367094 -0400
@@ -48,7 +48,6 @@ BUILT_SOURCES = qpol_wrap.c \
qpol_type_t.java \
qpol_user_t.java \
qpol_validatetrans_t.java \
- SWIGTYPE_p_int.java \
SWIGTYPE_p_unsigned_int.java \
SWIGTYPE_p_void.java
diff -up setools-3.3.7/libqpol/swig/java/Makefile.in~ setools-3.3.7/libqpol/swig/java/Makefile.in
--- setools-3.3.7/libqpol/swig/java/Makefile.in~ 2010-05-12 10:01:08.000000000 -0400
+++ setools-3.3.7/libqpol/swig/java/Makefile.in 2012-07-11 14:01:15.124459866 -0400
@@ -396,7 +396,6 @@ BUILT_SOURCES = qpol_wrap.c \
qpol_type_t.java \
qpol_user_t.java \
qpol_validatetrans_t.java \
- SWIGTYPE_p_int.java \
SWIGTYPE_p_unsigned_int.java \
SWIGTYPE_p_void.java

View File

@ -5,7 +5,7 @@
Name: setools
Version: %{setools_maj_ver}.%{setools_min_ver}
Release: 24%{?dist}
Release: 26%{?dist}
License: GPLv2
URL: http://oss.tresys.com/projects/setools
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@ -22,8 +22,8 @@ Patch5: 0005-Fix-sepol-calls-to-work-with-latest-libsepol.patch
Patch6: 0006-Changes-to-support-named-file_trans-rules.patch
Patch7: 0007-Remove-unused-variables.patch
Patch8: 0008-Fix-output-to-match-policy-lines.patch
Patch9: 0009-selinux_current_policy_path.patch
Patch10: 0010-missing-SWIGTYPE_p_int.java.patch
Patch9: 0009-Fix-swig-coding-style-for-structures.patch
Patch10: 0010-selinux_current_policy_path.patch
Summary: Policy analysis tools for SELinux
Group: System Environment/Base
@ -204,8 +204,8 @@ This package includes the following graphical tools:
%patch6 -p 1 -b .filenametrans
%patch7 -p 1 -b .unused
%patch8 -p 1 -b .fixoutput
%patch9 -p 1 -b .current
%patch10 -p 1 -b .swig
%patch9 -p 1 -b .fixswig
%patch10 -p 1 -b .current
%ifarch sparc sparcv9 sparc64 s390 s390x
for file in `find . -name Makefile.am`; do
@ -221,7 +221,6 @@ autoconf
%build
%configure --libdir=%{_libdir} --disable-bwidget-check --disable-selinux-check \
--enable-swig-python --enable-swig-java --enable-swig-tcl --with-java-prefix=/usr/lib/jvm/java
# work around issue with gcc 4.3 + gnu99 + swig-generated code:
sed -i -e 's:$(CC):gcc -std=gnu89:' libseaudit/swig/python/Makefile
make %{?_smp_mflags}
@ -373,10 +372,15 @@ rm -rf ${RPM_BUILD_ROOT}
%postun libs-tcl -p /sbin/ldconfig
%changelog
* Wed Jul 11 2012 Dan Walsh <dwalsh@redhat.com> - 3.3.7-24
- Fix to build with latest swig
* Wed Jul 11 2012 Dan Walsh <dwalsh@redhat.com> - 3.3.7-26
- mgrepl patch to Fix swig coding style for structures related to SWIG changes
* Wed Jul 4 2012 Dan Walsh <dwalsh@redhat.com> - 3.3.7-25
- Fix swig coding style for structures related to SWIG changes
* Wed May 2 2012 Dan Walsh <dwalsh@redhat.com> - 3.3.7-24
- Revert setools current patch
* Mon Apr 23 2012 Dan Walsh <dwalsh@redhat.com> - 3.3.7-23
- Rebuild to get latest libsepol which fixes the file_name transition problems
- Use selinux_current_policy_path to read by default policy