setools: bump to upstream bugfix release 3.3.4, which fixes gcc 4.3, glibc

2.7, tcl 8.5, and libsepol 2.0.20 issues.
This commit is contained in:
Chris PeBenito 2008-04-02 13:34:41 +00:00
parent 388a574fc9
commit a3b839f0d7
4 changed files with 10 additions and 125 deletions

View File

@ -1 +1 @@
setools-3.3.2.tar.gz
setools-3.3.4.tar.gz

View File

@ -1,121 +0,0 @@
--- setools-3.1/packages/Makefile.am.rhat 2007-02-06 15:43:29.000000000 -0500
+++ setools-3.1/packages/Makefile.am 2007-02-15 11:20:09.000000000 -0500
@@ -8,7 +8,7 @@
tar jxf BWidget-1.8.0.tar.bz2
test -z "$(bwidget_destdir)" || $(mkdir_p) "$(bwidget_destdir)"
cd BWidget-1.8.0 && find . -type d -exec $(mkdir_p) "$(bwidget_destdir)/{}" \;
- cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir) \;
+ cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir)/'{}'\;
uninstall-local:
-rm -rf $(bwidget_destdir)/BWidget-1.8.0
--- setools-3.1/packages/Makefile.in.rhat 2007-02-15 11:21:11.000000000 -0500
+++ setools-3.1/packages/Makefile.in 2007-02-15 11:21:24.000000000 -0500
@@ -381,7 +381,7 @@
tar jxf BWidget-1.8.0.tar.bz2
test -z "$(bwidget_destdir)" || $(mkdir_p) "$(bwidget_destdir)"
cd BWidget-1.8.0 && find . -type d -exec $(mkdir_p) "$(bwidget_destdir)/{}" \;
- cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir) \;
+ cd BWidget-1.8.0 && find . -type f -exec $(INSTALL_DATA) '{}' $(bwidget_destdir)/'{}' \;
uninstall-local:
-rm -rf $(bwidget_destdir)/BWidget-1.8.0
--- setools-3.1/libqpol/src/policy_parse.y.rhat 2007-02-06 15:43:26.000000000 -0500
+++ setools-3.1/libqpol/src/policy_parse.y 2007-02-15 11:19:06.000000000 -0500
@@ -1098,11 +1098,11 @@
ret = hashtab_insert(policydbp->p_commons.table,
(hashtab_key_t) id, (hashtab_datum_t) comdatum);
- if (ret == HASHTAB_PRESENT) {
+ if (ret == SEPOL_EEXIST) {
yyerror("duplicate common definition");
goto bad;
}
- if (ret == HASHTAB_OVERFLOW) {
+ if (ret == SEPOL_ENOMEM) {
yyerror("hash table overflow");
goto bad;
}
@@ -1130,14 +1130,14 @@
(hashtab_key_t) perm,
(hashtab_datum_t) perdatum);
- if (ret == HASHTAB_PRESENT) {
+ if (ret == SEPOL_EEXIST) {
sprintf(errormsg,
"duplicate permission %s in common %s", perm,
id);
yyerror(errormsg);
goto bad_perm;
}
- if (ret == HASHTAB_OVERFLOW) {
+ if (ret == SEPOL_ENOMEM) {
yyerror("hash table overflow");
goto bad_perm;
}
@@ -1259,12 +1259,12 @@
(hashtab_key_t) id,
(hashtab_datum_t) perdatum);
- if (ret == HASHTAB_PRESENT) {
+ if (ret == SEPOL_EEXIST) {
sprintf(errormsg, "duplicate permission %s", id);
yyerror(errormsg);
goto bad;
}
- if (ret == HASHTAB_OVERFLOW) {
+ if (ret == SEPOL_ENOMEM) {
yyerror("hash table overflow");
goto bad;
}
--- setools-3.1/libqpol/src/policy_extend.c.rhat 2007-02-07 14:16:52.000000000 -0500
+++ setools-3.1/libqpol/src/policy_extend.c 2007-02-15 11:19:06.000000000 -0500
@@ -167,7 +167,7 @@
retv = hashtab_insert(db->p_types.table, (hashtab_key_t) tmp_name, (hashtab_datum_t) tmp_type);
if (retv) {
- if (retv == HASHTAB_OVERFLOW)
+ if (retv == SEPOL_ENOMEM)
error = db->p_types.table ? ENOMEM : EINVAL;
else
error = EEXIST;
@@ -243,7 +243,7 @@
retv = hashtab_insert(db->p_types.table, (hashtab_key_t) tmp_name, (hashtab_datum_t) tmp_type);
if (retv) {
- if (retv == HASHTAB_OVERFLOW)
+ if (retv == SEPOL_ENOMEM)
error = db->p_types.table ? ENOMEM : EINVAL;
else
error = EEXIST;
--- setools-3.1/configure.ac.rhat 2007-02-07 10:48:44.000000000 -0500
+++ setools-3.1/configure.ac 2007-02-15 11:19:06.000000000 -0500
@@ -20,7 +20,7 @@
libseaudit_version=4.0.0
libseaudit_soname=libseaudit.so.4
-setoolsdir='${prefix}/share/setools-3.1'
+setoolsdir='${prefix}/share/setools'
version_min_sepol_major=1
version_min_sepol_minor=12
@@ -88,6 +88,7 @@
fi
AC_MSG_RESULT(disabled)
fi
+AC_SUBST(YFLAGS)
AC_SUBST(DEBUGCFLAGS)
AC_SUBST(DEBUGLDFLAGS)
QPOL_CFLAGS='-I$(top_srcdir)/libqpol/include'
@@ -227,7 +228,10 @@
AC_SUBST(BWIDGET_DESTDIR)
fi
else
- copy_bwidget=no
+
+ BWIDGET_DESTDIR="\$(DESTDIR)/\${datadir}/tcl8.4/BWidget-1.8.0"
+ AC_SUBST(BWIDGET_DESTDIR)
+ copy_bwidget=yes
bwidget_ver=1.8
fi

View File

@ -1,11 +1,11 @@
%define setools_maj_ver 3.3
%define setools_min_ver 2
%define setools_min_ver 4
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: setools
Version: %{setools_maj_ver}.%{setools_min_ver}
Release: 3%{?dist}
Release: 1%{?dist}
License: GPLv2
URL: http://oss.tresys.com/projects/setools
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@ -188,6 +188,8 @@ This package includes the following graphical tools:
%build
%configure --libdir=%{_libdir} --disable-bwidget-check --disable-selinux-check --enable-swig-python --enable-swig-java --enable-swig-tcl
# work around issue with gcc 4.3 + gnu99 + swig-generated code:
sed -i -e 's:$(CC):gcc -std=gnu89:' libseaudit/swig/python/Makefile
make %{?_smp_mflags}
%install
@ -335,6 +337,10 @@ rm -rf ${RPM_BUILD_ROOT}
%postun libs-tcl -p /sbin/ldconfig
%changelog
* Wed Feb 27 2008 Chris PeBenito <cpebenito@tresys.com> 3.3.4-1
- Fixes gcc 4.3, glibc 2.7, tcl 8.5, and libsepol 2.0.20 issues.
- Fix policy loading when policy on disk is higher version than the kernel.
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.3.2-3
- Autorebuild for GCC 4.3

View File

@ -1 +1 @@
17c1bec7fb4ad62fbb6177eb34b8e4a1 setools-3.3.2.tar.gz
a5fecca4f0a12a5d2a42f9e7e63c78d1 setools-3.3.4.tar.gz