- Update from upstream

added new MLS components tab for sensitivities, levels, and categories.
    Changed users tab to support ranges and default levels. added range
    transition tab for searching range Transition rules. added new tab for
    network context components. added new tab for file system context
    components.
added binpol support for MLS, network contexts, and file system contexts.
added command line options for MLS components. added command line options
    for network contexts and file system contexts.
added command line option for searching for rules by conditional boolean
    name.
added new column in the log view for the 'comm' field found in auditd log
    files. added filters for the 'comm' field and 'message' field.
added manpages for all tools.
This commit is contained in:
Daniel J Walsh 2006-01-31 21:28:38 +00:00
parent 9bdee1b17f
commit 841888fb2a
4 changed files with 95 additions and 68 deletions

View File

@ -7,3 +7,4 @@ setools-2.1.1.tar.bz2
setools-2.1.2.tar.bz2 setools-2.1.2.tar.bz2
setools-2.1.3.tar.bz2 setools-2.1.3.tar.bz2
setools-2.2.tar.bz2 setools-2.2.tar.bz2
setools-2.3.tar.bz2

View File

@ -1,19 +1,6 @@
--- setools-2.2/seaudit/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400 --- setools-2.3/apol/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
+++ setools-2.2/seaudit/Makefile 2005-12-14 09:34:28.000000000 -0500 +++ setools-2.3/apol/Makefile 2006-01-31 16:15:53.000000000 -0500
@@ -60,8 +60,8 @@ @@ -85,7 +85,7 @@
$(CC) $(CFLAGS) $(GTK_CFLAGS) $(LIBXML_FLAGS) $(INCLUDE) -c $<
install: seaudit seaudit-report
- install -m 755 seaudit $(BINDIR)
- install -m 755 seaudit-report $(BINDIR)
+ install -m 755 seaudit $(SBINDIR)
+ install -m 755 seaudit-report $(SBINDIR)
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
install -m 644 seaudit_help.txt $(INSTALL_LIBDIR)
install -m 444 dot_seaudit $(INSTALL_LIBDIR)
--- setools-2.2/apol/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
+++ setools-2.2/apol/Makefile 2005-12-14 09:34:28.000000000 -0500
@@ -80,7 +80,7 @@
$(MAKE) -C .. libsefs $(MAKE) -C .. libsefs
install: apol apol.tcl install: apol apol.tcl
@ -22,51 +9,35 @@
@if [ -n $(INSTALL_LIBDIR) ]; then \ @if [ -n $(INSTALL_LIBDIR) ]; then \
for file in $(TCL-FILES); do \ for file in $(TCL-FILES); do \
if [ -f $(INSTALL_LIBDIR)/$$file ]; then \ if [ -f $(INSTALL_LIBDIR)/$$file ]; then \
@@ -89,6 +89,7 @@ --- setools-2.3/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
done \ +++ setools-2.3/Makefile 2006-01-31 16:18:43.000000000 -0500
fi @@ -12,7 +12,7 @@
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR) PREFIX ?= $(DESTDIR)/usr
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
clean: INCLUDE_DIR = $(PREFIX)/include
--- setools-2.2/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400 -SHARED_LIB_INSTALL_DIR = $(PREFIX)/lib
+++ setools-2.2/Makefile 2005-12-14 09:34:28.000000000 -0500
@@ -10,7 +10,7 @@
LIBS = -lfl -lm
INCLUDE_DIR = $(DESTDIR)/usr/include
-SHARED_LIB_INSTALL_DIR = $(DESTDIR)/usr/lib
+SHARED_LIB_INSTALL_DIR = $(DESTDIR)$(LIBDIR) +SHARED_LIB_INSTALL_DIR = $(DESTDIR)$(LIBDIR)
STATIC_LIB_INSTALL_DIR = $(SHARED_LIB_INSTALL_DIR) STATIC_LIB_INSTALL_DIR = $(SHARED_LIB_INSTALL_DIR)
SETOOLS_INCLUDE = $(INCLUDE_DIR)/setools #SETOOLS_INCLUDE = $(INCLUDE_DIR)/setools-$(SETOOLS_VER)
TCLVER = $(shell env tclsh tcl_vars) TCLVER = $(shell env tclsh tcl_vars)
@@ -28,6 +28,7 @@ @@ -37,7 +37,7 @@
# Install directories
# Binaries go here
BINDIR = $(DESTDIR)/usr/bin
+SBINDIR = $(DESTDIR)/usr/sbin
# The code uses the specified path below. If you change this, DO NOT add
# a trailing path seperator ("/"). For example, use "/usr/share/setools"
# instead of "/usr/share/setools/". This probably needs to become more # instead of "/usr/share/setools/". This probably needs to become more
@@ -111,7 +112,7 @@ # robust in the future.
export SHARED_LIB_INSTALL_DIR STATIC_LIB_INSTALL_DIR #
export SELINUX_DIR POLICY_INSTALL_DIR POLICY_SRC_DIR DEFAULT_LOG_FILE -INSTALL_LIBDIR = $(PREFIX)/share/setools-$(SETOOLS_VER)
export POLICY_SRC_DIR POLICY_SRC_FILE +INSTALL_LIBDIR = $(PREFIX)/share/setools
-export BINDIR INSTALL_LIBDIR INSTALL_HELPDIR POLICYINSTALLDIR # all apps that have a te/fc file need to be listed here
+export SBINDIR BINDIR INSTALL_LIBDIR INSTALL_HELPDIR POLICYINSTALLDIR POLICYINSTALLDIRS =
# Help files here
# Top Level Targets --- setools-2.3/sediff/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
all: all-libs all-nogui all-gui +++ setools-2.3/sediff/Makefile 2006-01-31 16:15:53.000000000 -0500
--- setools-2.2/sediff/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400 @@ -22,7 +22,8 @@
+++ setools-2.2/sediff/Makefile 2005-12-14 09:34:28.000000000 -0500 install -m 644 ../man/sediff.1 $(MANDIR)/man1
@@ -24,7 +24,8 @@
install -m 755 sediff $(BINDIR);
install: all install: all
- install -m 755 sediff sediffx $(BINDIR); - install -m 755 sediff sediffx $(BINDIR);
+ install -m 755 sediff $(BINDIR); + install -m 755 sediff $(BINDIR);
+ install -m 755 sediffx $(SBINDIR); + install -m 755 sediffx $(SBINDIR);
install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR) install -m 644 $(GLADE_FILES) $(INSTALL_LIBDIR)
install -m 644 sediff_help.txt $(INSTALL_LIBDIR) install -m 644 sediff_help.txt $(INSTALL_HELPDIR)

View File

@ -1,7 +1,7 @@
Summary: SELinux tools for managing policy Summary: SELinux tools for managing policy
Name: setools Name: setools
Version: 2.2 Version: 2.3
Release: 4.1 Release: 1
License: GPL License: GPL
Group: System Environment/Base Group: System Environment/Base
URL: http://www.tresys.com/ URL: http://www.tresys.com/
@ -100,6 +100,10 @@ rm -f ${RPM_BUILD_ROOT}/usr/bin/findcon
rm -f ${RPM_BUILD_ROOT}/usr/bin/replcon rm -f ${RPM_BUILD_ROOT}/usr/bin/replcon
rm -f ${RPM_BUILD_ROOT}/usr/bin/searchcon rm -f ${RPM_BUILD_ROOT}/usr/bin/searchcon
rm -f ${RPM_BUILD_ROOT}/usr/bin/indexcon rm -f ${RPM_BUILD_ROOT}/usr/bin/indexcon
rm -f ${RPM_BUILD_ROOT}/usr/share/man/man1/searchcon.1
rm -f ${RPM_BUILD_ROOT}/usr/share/man/man1/indexcon.1
rm -f ${RPM_BUILD_ROOT}/usr/share/man/man1/replcon.1
rm -f ${RPM_BUILD_ROOT}/usr/share/man/man1/findcon.1
install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/apol install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/apol
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/seaudit install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/seaudit
@ -149,9 +153,11 @@ rm -rf ${RPM_BUILD_ROOT}
/usr/share/doc/setools-%{version}/flow_assertion_help.txt /usr/share/doc/setools-%{version}/flow_assertion_help.txt
/usr/share/doc/setools-%{version}/iflow_help.txt /usr/share/doc/setools-%{version}/iflow_help.txt
/usr/share/doc/setools-%{version}/obj_perms_help.txt /usr/share/doc/setools-%{version}/obj_perms_help.txt
/usr/share/doc/setools-2.3/sechecker_help.txt
/usr/share/doc/setools-2.3/sediff_help.txt
%dir /usr/share/setools %dir /usr/share/setools
/usr/share/setools/apol.tcl /usr/share/setools/apol.tcl
/usr/share/setools/apol_help.txt
/usr/share/setools/apol_perm_mapping /usr/share/setools/apol_perm_mapping
/usr/share/setools/apol_perm_mapping_ver12 /usr/share/setools/apol_perm_mapping_ver12
/usr/share/setools/apol_perm_mapping_ver15 /usr/share/setools/apol_perm_mapping_ver15
@ -162,25 +168,20 @@ rm -rf ${RPM_BUILD_ROOT}
/usr/share/setools/apol_perm_mapping_ver20 /usr/share/setools/apol_perm_mapping_ver20
/usr/share/setools/customize_filter_window.glade /usr/share/setools/customize_filter_window.glade
/usr/share/setools/dot_seaudit /usr/share/setools/dot_seaudit
/usr/share/setools/dta_help.txt
/usr/share/setools/filter_window.glade /usr/share/setools/filter_window.glade
/usr/share/setools/iflow_help.txt
/usr/share/setools/multifilter_window.glade /usr/share/setools/multifilter_window.glade
/usr/share/setools/obj_perms_help.txt
/usr/share/setools/prefer_window.glade /usr/share/setools/prefer_window.glade
/usr/share/setools/query_window.glade /usr/share/setools/query_window.glade
/usr/share/setools/report_window.glade /usr/share/setools/report_window.glade
/usr/share/setools/seaudit-report.conf /usr/share/setools/seaudit-report.conf
/usr/share/setools/seaudit-report.css /usr/share/setools/seaudit-report.css
/usr/share/setools/seaudit.glade /usr/share/setools/seaudit.glade
/usr/share/setools/seaudit_help.txt
%attr(755,root,root) %dir /usr/share/setools/sechecker
%attr(755,root,root) %dir /usr/share/setools/sechecker/profiles
/usr/share/setools/sechecker/profiles/all-checks.sechecker
/usr/share/setools/sechecker/profiles/analysis-checks.sechecker
/usr/share/setools/sechecker/profiles/devel-checks.sechecker
/usr/share/setools/sediff.glade /usr/share/setools/sediff.glade
/usr/share/setools/sediff_help.txt
%{_mandir}/man1/apol.1.gz
%{_mandir}/man1/sediffx.1.gz
%{_mandir}/man8/seaudit.8.gz
%{_mandir}/man8/seaudit-report.8.gz
%package devel %package devel
Summary: Development environment for SETools Summary: Development environment for SETools
@ -192,8 +193,13 @@ Headers, static libraries and API docs for SETools.
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%{_includedir}/setools %{_includedir}/libapol
%{_libdir}/lib* %{_includedir}/libseaudit
%{_includedir}/libsefs
%{_includedir}/selinux/apol
%{_libdir}/libsefs.a
%{_libdir}/libapol.a
%{_libdir}/libseaudit.a
%post devel -p /sbin/ldconfig %post devel -p /sbin/ldconfig
@ -208,8 +214,57 @@ Headers, static libraries and API docs for SETools.
%dir /usr/share/doc/setools-%{version} %dir /usr/share/doc/setools-%{version}
/usr/share/doc/setools-%{version}/KNOWN-BUGS /usr/share/doc/setools-%{version}/KNOWN-BUGS
/usr/share/doc/setools-%{version}/README /usr/share/doc/setools-%{version}/README
%{_mandir}/man1/sechecker.1.gz
%{_mandir}/man1/seinfo.1.gz
%{_mandir}/man1/sediff.1.gz
%{_mandir}/man1/sesearch.1.gz
%attr(755,root,root) %dir /usr/share/setools/sechecker
%attr(755,root,root) %dir /usr/share/setools/sechecker/profiles
/usr/share/setools/sechecker/profiles/all-checks.sechecker
/usr/share/setools/sechecker/profiles/analysis-checks.sechecker
/usr/share/setools/sechecker/profiles/devel-checks.sechecker
%{_libdir}/libapol.so
%{_libdir}/libapol.so.1
%{_libdir}/libapol.so.2.2.0
%{_libdir}/libseaudit.so
%{_libdir}/libseaudit.so.1
%{_libdir}/libseaudit.so.1.2.6
%{_libdir}/libsefs.so
%{_libdir}/libsefs.so.1
%{_libdir}/libsefs.so.1.2.1
%changelog %changelog
* Tue Jan 31 2006 Dan Walsh <dwalsh@redhat.com> 2.3-1
- Update from upstream
* apol:
added new MLS components tab for sensitivities,
levels, and categories.
Changed users tab to support ranges and default
levels.
added range transition tab for searching range
Transition rules.
added new tab for network context components.
added new tab for file system context components.
* libapol:
added binpol support for MLS, network contexts,
and file system contexts.
* seinfo:
added command line options for MLS components.
added command line options for network contexts
and file system contexts.
* sesearch:
added command line option for searching for rules
by conditional boolean name.
* seaudit:
added new column in the log view for the 'comm'
field found in auditd log files.
added filters for the 'comm' field and 'message'
field.
* manpages:
added manpages for all tools.
* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com> * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt for new gcj - rebuilt for new gcj

View File

@ -1 +1 @@
accd87390ffc48740e3e53a4a1e27649 setools-2.3.tar.bz2 713d61ccfc3390049d6ba5e0f88e7b22 setools-2.3.tar.bz2