auto-import changelog data from setools-1.4.1-1.src.rpm

Thu Jul 08 2004 Dan Walsh <dwalsh@redhat.com> 1.4.1-1
- Latest from Tresys
This commit is contained in:
cvsdist 2004-09-09 12:17:03 +00:00
parent 825424a9ee
commit 47d492b9e2
4 changed files with 96 additions and 178 deletions

View File

@ -1 +1 @@
setools-1.4.tgz
setools-1.4.1.tgz

View File

@ -1,60 +1,22 @@
--- setools-1.4/seuser/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
+++ setools-1.4/seuser/Makefile 2004-06-02 15:57:20.000000000 -0400
@@ -22,10 +22,10 @@
SHELL = /bin/sh
seuser: $(CMD-OBJ)
- $(CC) -o $@ $(CMD-OBJ) $(LINKFLAGS) $(LIBS)
+ $(CC) -o $@ $(CMD-OBJ) $(LINKFLAGS) $(LIBS) -lselinux
seuserx: $(GUI-OBJ) se_user.tcl
- $(CC) $(GUI_CFLAGS) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS)
+ $(CC) $(GUI_CFLAGS) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
se_user.tcl: $(TCL-FILES)
cat $(TCL-FILES) | \
--- setools-1.4/awish/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
+++ setools-1.4/awish/Makefile 2004-06-02 15:57:20.000000000 -0400
@@ -4,7 +4,7 @@
AWISH_OBJ = awish.o $(LIBSEUSER-TCL) $(LIBAPOL-TCL)
awish: $(AWISH_OBJ)
- $(CC) $(TCL_LIBINC) -o $@ $(AWISH_OBJ) $(LINKFLAGS) $(TCL_LIBS)
+ $(CC) $(TCL_LIBINC) -o $@ $(AWISH_OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
%.o: %.c
@@ -12,16 +12,16 @@
../lib/libapol.a:
cd ../ ; $(MAKE) libapol
-
+
../lib/libapol-tcl.a:
cd ../ ; $(MAKE) libapol-tcl
../lib/libseuser-tcl.a:
cd ../ ; $(MAKE) libseuser-tcl
-
+
../lib/libseuser.a:
cd ../ ; $(MAKE) libseuser
-
+
install: awish
install -m 755 awish $(BINDIR)
--- setools-1.4/libseuser/seuser_db.c.rhat 2004-06-02 13:44:13.000000000 -0400
+++ setools-1.4/libseuser/seuser_db.c 2004-06-02 15:57:20.000000000 -0400
@@ -17,6 +17,7 @@
--- setools-1.4.1/libseuser/seuser_db.c.rhat 2004-07-07 16:37:39.000000000 -0400
+++ setools-1.4.1/libseuser/seuser_db.c 2004-07-08 12:15:29.906712667 -0400
@@ -17,8 +17,15 @@
#include <pwd.h>
#include <sys/types.h>
#include <unistd.h>
+#include <limits.h>
#include "seuser_db.h"
+/*
+ defined in selinux/selinux.h
+ but conflicts with policy.h
+*/
+extern char *selinux_file_context_path(void);
+
/* apol lib */
@@ -788,8 +789,10 @@
#include "../libapol/policy.h"
#include "../libapol/policy-io.h"
@@ -789,8 +796,10 @@
}
free(full_config);
@ -67,7 +29,7 @@
if(db->policy_conf == NULL) {
fclose(fp);
free_conf_info(db);
@@ -804,7 +807,9 @@
@@ -805,7 +814,9 @@
return 4;
}
@ -78,7 +40,7 @@
if(db->policy_dir == NULL) {
fclose(fp);
free_conf_info(db);
@@ -819,7 +824,9 @@
@@ -820,7 +831,9 @@
return 6;
}
@ -89,7 +51,7 @@
if(db->user_file == NULL) {
fclose(fp);
free_conf_info(db);
@@ -828,7 +835,8 @@
@@ -829,7 +842,8 @@
}
/* users file may not exist which is ok, so we won't check read access. */
@ -99,33 +61,71 @@
if(db->file_contexts_file == NULL) {
fclose(fp);
free_conf_info(db);
--- setools-1.4/libseuser/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
+++ setools-1.4/libseuser/Makefile 2004-06-02 15:57:20.000000000 -0400
@@ -11,8 +11,12 @@
libseuser-tcl: ../lib/libseuser-tcl.a
+install: libseuser libseuser-tcl
+ install -m 644 ../lib/libseuser.a $(INSTALL_LIBDIR)
+ install -m 644 *.h $(INCLUDEDIR)
+
../lib/libseuser.a: ../lib $(LIB-OBJ)
--- setools-1.4.1/libseuser/Makefile.rhat 2004-07-07 16:37:38.000000000 -0400
+++ setools-1.4.1/libseuser/Makefile 2004-07-08 12:02:22.124320696 -0400
@@ -19,7 +19,7 @@
$(CC) $(LDFLAGS) -shared -o $(LIBSO) $(LIB-OBJ) -Wl,-soname,$(SONAME)
libseuser.a: $(LIB-OBJ)
- ar cr $@ $(LIB-OBJ)
+ ar cr $@ $(LIB-OBJ) -lselinux
../lib/libseuser-tcl.a: ../lib $(LIB-OBJ-TCL)
libseuser-tcl.a: $(LIB-OBJ-TCL)
ar cr $@ $(LIB-OBJ-TCL)
@@ -20,7 +24,7 @@
--- setools-1.4.1/apol/Makefile.rhat 2004-07-07 16:37:38.000000000 -0400
+++ setools-1.4.1/apol/Makefile 2004-07-08 12:02:22.125320586 -0400
@@ -17,7 +17,7 @@
CFLAGS += -DSTARTUP_SCRIPT='"$(APOL_STARTUP_SCRIPT)"'
apol: $(GUI-OBJ) apol.tcl
- $(CC) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS)
+ $(CC) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
apol.tcl: $(TCL-FILES)
@@ -54,6 +54,7 @@
done \
fi
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR)
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
clean:
--- setools-1.4.1/awish/Makefile.rhat 2004-07-07 16:37:39.000000000 -0400
+++ setools-1.4.1/awish/Makefile 2004-07-08 12:02:22.125320586 -0400
@@ -4,7 +4,7 @@
AWISH_OBJ = awish.o $(LIBSEUSER-TCL) $(LIBAPOL-TCL)
awish: $(AWISH_OBJ)
- $(CC) $(TCL_LIBINC) -o $@ $(AWISH_OBJ) $(LINKFLAGS) $(TCL_LIBS)
+ $(CC) $(TCL_LIBINC) -o $@ $(AWISH_OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
%.o: %.c
$(CC) $(CFLAGS) -c $<
--- setools-1.4.1/Makefile.rhat 2004-07-08 12:18:16.143697579 -0400
+++ setools-1.4.1/Makefile 2004-07-08 12:19:05.458057985 -0400
@@ -25,8 +25,8 @@
# File location defaults; used in various places in code
# Change these if you want different defaults
SELINUX_DIR = $(DESTDIR)/selinux
-SELINUX_POLICY_DIR = $(DESTDIR)/etc/security/selinux
-POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)
+SELINUX_POLICY_DIR = $(DESTDIR)/etc/selinux/strict/
+POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/policy
POLICY_SRC_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/src/policy
POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
DEFAULT_LOG_FILE = /var/log/messages
@@ -224,7 +224,7 @@
-
+
../lib:
mkdir -p $@
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
--- setools-1.4/packages/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
+++ setools-1.4/packages/Makefile 2004-06-02 16:03:28.000000000 -0400
-install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit
+install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit install-bwidget install-docs
# Install the libraries
install-libseuser:
--- setools-1.4.1/packages/Makefile.rhat 2004-07-07 16:37:38.000000000 -0400
+++ setools-1.4.1/packages/Makefile 2004-07-08 12:02:22.127320366 -0400
@@ -4,9 +4,10 @@
# INSTALL_PATH is set based upon your current
@ -145,76 +145,30 @@
-bare: clean
\ No newline at end of file
+bare: clean
--- setools-1.4/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
+++ setools-1.4/Makefile 2004-06-10 14:56:04.354591984 -0400
@@ -21,8 +21,9 @@
# File location defaults; used in various places in code
# Change these if you want different defaults
SELINUX_DIR = $(DESTDIR)/selinux
-POLICY_INSTALL_DIR = $(DESTDIR)/etc/security/selinux
-POLICY_SRC_DIR = $(DESTDIR)$(POLICY_INSTALL_DIR)/src/policy
+SELINUX_POLICY_DIR = $(DESTDIR)/etc/selinux/strict/
+POLICY_INSTALL_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/policy
+POLICY_SRC_DIR = $(DESTDIR)$(SELINUX_POLICY_DIR)/src/policy
POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
DEFAULT_LOG_FILE = /var/log/messages
--- setools-1.4.1/seuser/Makefile.rhat 2004-07-07 16:37:39.000000000 -0400
+++ setools-1.4.1/seuser/Makefile 2004-07-08 12:02:22.128320256 -0400
@@ -22,10 +22,10 @@
SHELL = /bin/sh
@@ -120,7 +121,7 @@
echo "Could not build awish."; \
echo "Tcl library is not built or not in expected location(s)."; \
fi
-
+
seuser: selinux_tool
cd seuser; $(MAKE) seuser
seuser: $(CMD-OBJ)
- $(CC) -o $@ $(CMD-OBJ) $(LINKFLAGS) $(LIBS)
+ $(CC) -o $@ $(CMD-OBJ) $(LINKFLAGS) $(LIBS) -lselinux
@@ -141,9 +142,9 @@
seuserx: $(GUI-OBJ) se_user.tcl
- $(CC) $(GUI_CFLAGS) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS)
+ $(CC) $(GUI_CFLAGS) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
secmds: selinux_tool
cd secmds; $(MAKE) all
-
+
libapol: selinux_tool
- cd libapol; $(MAKE) libapol
+ cd libapol; $(MAKE) libapol
libapol-tcl: selinux_tool
cd libapol;
@@ -215,17 +216,23 @@
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
+install-bwidget:
+ cd packages; make
+
+install-docs: docs
+ install -m 755 -d $(INSTALL_HELPDIR)
+ cd docs-src; $(MAKE) install INSTALL_HELPDIR=$(INSTALL_HELPDIR)
-install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit
+install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit install-bwidget install-docs
# Install the policy - this is a separate step to better support systems with
# non-standard policies.
install-seuser-policy: $(INSTALL_LIBDIR)
cd seuser; $(MAKE) install-policy
-
+
install-secmds-policy: $(INSTALL_LIBDIR)
cd secmds; $(MAKE) install-policy
-
+
install-policy: install-seuser-policy install-secmds-policy
# Next four targets are to support installation as part of a system
--- setools-1.4/docs-src/Makefile.rhat 2004-06-02 13:44:13.000000000 -0400
+++ setools-1.4/docs-src/Makefile 2004-06-02 15:57:20.000000000 -0400
@@ -55,3 +55,14 @@
se_user.tcl: $(TCL-FILES)
cat $(TCL-FILES) | \
--- setools-1.4.1/docs-src/Makefile.rhat 2004-07-07 16:37:39.000000000 -0400
+++ setools-1.4.1/docs-src/Makefile 2004-07-08 12:21:10.492761493 -0400
@@ -55,3 +55,15 @@
for file in $(TOP-DOCS); do \
rm -f ../$$file; \
done
+
+install:
+ mkdir -p ${INSTALL_HELPDIR}
+ for file in KNOWN-BUGS README; do \
+ cat $$file.in | sed -e 's/RELEASE_VERSION/$(shell cat ../VERSION)/g' | \
+ sed -e 's/MOD_DATE/$(shell date '+%B %d, %G')/g' > ${INSTALL_HELPDIR}/$$file; \
@ -224,42 +178,3 @@
+ install -m 644 ../sepct/sepcut_help.txt ${INSTALL_HELPDIR}
+ install -m 644 ../apol/*.txt ${INSTALL_HELPDIR}
+
--- setools-1.4/apol/Makefile.rhat 2004-06-02 13:44:12.000000000 -0400
+++ setools-1.4/apol/Makefile 2004-06-02 15:57:20.000000000 -0400
@@ -11,14 +11,14 @@
APOL_HELP_FILES = apol_help.txt dta_help.txt iflow_help.txt obj_perms_help.txt
APOL_PERM_MAPS = apol_perm_mapping_ver12 apol_perm_mapping_ver15 \
apol_perm_mapping_ver16 apol_perm_mapping_ver17
-
+
APOL_DFLT_PMAP = apol_perm_mapping_ver16
LIBAPOL = ../lib/libapol-tcl.a ../lib/libapol.a
GUI-OBJ = apol_gui.o $(LIBAPOL)
CFLAGS += -DSTARTUP_SCRIPT='"$(APOL_STARTUP_SCRIPT)"'
apol: $(GUI-OBJ) apol.tcl
- $(CC) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS)
+ $(CC) $(TCL_LIBINC) -o $@ $(GUI-OBJ) $(LINKFLAGS) $(TCL_LIBS) -lselinux
apol.tcl: $(TCL-FILES)
@@ -55,6 +55,7 @@
done \
fi
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR)
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
clean:
diff -u -r1.1 -r1.2
--- setools/libapol/binpol/binpol.c 4 Jun 2004 19:33:57 -0000 1.1
+++ setools/libapol/binpol/binpol.c 22 Jun 2004 18:57:04 -0000 1.2
@@ -1452,6 +1452,7 @@
policy_ver = buf[0];
switch(policy_ver) {
+ case POLICYDB_VERSION_IPV6 + 1:
case POLICYDB_VERSION_IPV6 :
if(set_policy_version(POL_VER_17, policy) != 0)
{ rt = -4; goto err_return; }

View File

@ -1,7 +1,7 @@
Summary: SELinux tools for managing policy
Name: setools
Version: 1.4
Release: 5
Version: 1.4.1
Release: 1
License: GPL
Group: System Environment/Base
Source: http://www.tresys.com/Downloads/selinux-tools/setools-%{version}.tgz
@ -126,6 +126,9 @@ rm -rf ${RPM_BUILD_ROOT}
/usr/share/doc/setools-%{version}/*
%changelog
* Thu Jul 8 2004 Dan Walsh <dwalsh@redhat.com> 1.4.1-1
- Latest from Tresys
* Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 1.4-5
- Add build requires libselinux

View File

@ -1 +1 @@
ee3e7a28eea7ba7bb9956abab738cbde setools-1.4.tgz
6afb10ee33873892772cdaa7f04a136a setools-1.4.1.tgz