- Fix dessktop files

- Apply fixes from bkyoung
This commit is contained in:
Daniel J Walsh 2005-12-14 14:47:13 +00:00
parent 33f896871d
commit 0863078317
5 changed files with 57 additions and 37 deletions

View File

@ -7,6 +7,6 @@ Exec=/usr/bin/apol
Type=Application
Terminal=false
Encoding=UTF-8
Categories=System;X-Red-Hat-Base;X-Red-Hat-ServerConfig;
Categories=Application;SystemSetup;X-Red-Hat-Base;
X-Desktop-File-Install-Version=0.2
StartupNotify=true

View File

@ -7,6 +7,6 @@ Exec=/usr/bin/seaudit
Type=Application
Terminal=false
Encoding=UTF-8
Categories=System;X-Red-Hat-Base;X-Red-Hat-ServerConfig;
Categories=Application;SystemSetup;X-Red-Hat-Base;
X-Desktop-File-Install-Version=0.2
StartupNotify=true

View File

@ -6,6 +6,6 @@ Exec=/usr/bin/sediffx
Type=Application
Terminal=false
Encoding=UTF-8
Categories=System;X-Red-Hat-Base;X-Red-Hat-ServerConfig;
Categories=Application;SystemSetup;X-Red-Hat-Base;
X-Desktop-File-Install-Version=0.2
StartupNotify=true

View File

@ -1,5 +1,5 @@
--- setools-2.2/seaudit/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
+++ setools-2.2/seaudit/Makefile 2005-11-03 17:16:42.000000000 -0500
+++ setools-2.2/seaudit/Makefile 2005-12-14 09:34:28.000000000 -0500
@@ -60,8 +60,8 @@
$(CC) $(CFLAGS) $(GTK_CFLAGS) $(LIBXML_FLAGS) $(INCLUDE) -c $<
@ -12,7 +12,7 @@
install -m 644 seaudit_help.txt $(INSTALL_LIBDIR)
install -m 444 dot_seaudit $(INSTALL_LIBDIR)
--- setools-2.2/apol/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
+++ setools-2.2/apol/Makefile 2005-11-03 17:16:42.000000000 -0500
+++ setools-2.2/apol/Makefile 2005-12-14 09:34:28.000000000 -0500
@@ -80,7 +80,7 @@
$(MAKE) -C .. libsefs
@ -31,7 +31,7 @@
clean:
--- setools-2.2/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
+++ setools-2.2/Makefile 2005-11-03 17:57:13.000000000 -0500
+++ setools-2.2/Makefile 2005-12-14 09:34:28.000000000 -0500
@@ -10,7 +10,7 @@
LIBS = -lfl -lm
@ -59,7 +59,7 @@
# Top Level Targets
all: all-libs all-nogui all-gui
--- setools-2.2/sediff/Makefile.rhat 2005-10-28 18:12:32.000000000 -0400
+++ setools-2.2/sediff/Makefile 2005-11-03 17:16:42.000000000 -0500
+++ setools-2.2/sediff/Makefile 2005-12-14 09:34:28.000000000 -0500
@@ -24,7 +24,8 @@
install -m 755 sediff $(BINDIR);

View File

@ -1,9 +1,10 @@
Summary: SELinux tools for managing policy
Name: setools
Version: 2.2
Release: 3.1
Release: 4
License: GPL
Group: System Environment/Base
URL: http://www.tresys.com/
Source: http://www.tresys.com/Downloads/selinux-tools/setools-%{version}.tar.bz2
Source1: setools.pam
Source2: apol.console
@ -14,7 +15,7 @@ Source8: sediffx.console
Source9: sediffx.desktop
Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-buildroot
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: checkpolicy, policycoreutils, tcl >= 8.3
Buildrequires: tk-devel >= 8.3, tcl-devel >= 8.3
BuildRequires: gtk2-devel, libglade2-devel
@ -26,11 +27,15 @@ Patch0: setools-rhat.patch
%description
Security-enhanced Linux is a patch of the Linux kernel and a number of
utilities with enhanced security functionality designed to add mandatory access
utilities with enhanced security functionality designed to add
mandatory access
controls to Linux. The Security-enhanced Linux kernel contains new
architectural components originally developed to improve the security of the Flask
operating system. These architectural components provide general support for the
enforcement of many kinds of mandatory access control policies, including those
architectural components originally developed to improve the security
of the Flask
operating system. These architectural components provide general
support for the
enforcement of many kinds of mandatory access control policies, including
those
based on the concepts of Type Enforcement, Role-based Access Control, and
Multi-level Security.
@ -46,15 +51,19 @@ tools.
Summary: Graphical tools for handling SETools
Group: System Environment/Base
Requires: %{name} = %{version}-%{release}
Requires: tk >= 8.3, libglade2
Requires: tk >= 8.3, libglade2 > 2, usermode
%description gui
Security-enhanced Linux is a patch of the Linux kernel and a number of
utilities with enhanced security functionality designed to add mandatory access
utilities with enhanced security functionality designed to add
mandatory access
controls to Linux. The Security-enhanced Linux kernel contains new
architectural components originally developed to improve the security of the Flask
operating system. These architectural components provide general support for the
enforcement of many kinds of mandatory access control policies, including those
architectural components originally developed to improve
the security of the Flask
operating system. These architectural components provide
general support for the
enforcement of many kinds of mandatory access control policies,
including those
based on the concepts of Type Enforcement, Role-based Access Control, and
Multi-level Security.
@ -73,8 +82,9 @@ tools.
%prep
%setup -q
%patch0 -p1 -b .rhat
%build
make clean
make LIBDIR=%{_libdir} all
%install
@ -90,15 +100,18 @@ rm -f ${RPM_BUILD_ROOT}/usr/bin/findcon
rm -f ${RPM_BUILD_ROOT}/usr/bin/replcon
rm -f ${RPM_BUILD_ROOT}/usr/bin/searchcon
rm -f ${RPM_BUILD_ROOT}/usr/bin/indexcon
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/apol
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/seaudit
install -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/sediffx
install -D %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/apol
install -D %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/seaudit
install -D %{SOURCE8} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/sediffx
install -D %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/applications/apol.desktop
install -D %{SOURCE7} ${RPM_BUILD_ROOT}%{_datadir}/applications/seaudit.desktop
install -D %{SOURCE9} ${RPM_BUILD_ROOT}%{_datadir}/applications/sediffx.desktop
install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/apol
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/seaudit
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/pam.d/sediffx
install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps
install -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/apol
install -m 644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/seaudit
install -m 644 %{SOURCE8} ${RPM_BUILD_ROOT}%{_sysconfdir}/security/console.apps/sediffx
install -d -m 755 ${RPM_BUILD_ROOT}%{_datadir}/applications
install -m 664 %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/applications/apol.desktop
install -m 664 %{SOURCE7} ${RPM_BUILD_ROOT}%{_datadir}/applications/seaudit.desktop
install -m 664 %{SOURCE9} ${RPM_BUILD_ROOT}%{_datadir}/applications/sediffx.desktop
cd $RPM_BUILD_ROOT/%{_bindir}/
ln -sf consolehelper apol
ln -sf consolehelper seaudit
@ -122,13 +135,12 @@ rm -rf ${RPM_BUILD_ROOT}
%{_datadir}/applications/apol.desktop
%{_datadir}/applications/seaudit.desktop
%{_datadir}/applications/sediffx.desktop
%config %{_sysconfdir}/pam.d/apol
%config %{_sysconfdir}/pam.d/seaudit
%config %{_sysconfdir}/pam.d/sediffx
%config %{_sysconfdir}/security/console.apps/apol
%config %{_sysconfdir}/security/console.apps/seaudit
%config %{_sysconfdir}/security/console.apps/sediffx
%dir /usr/share/doc/setools-%{version}
%config(noreplace) %{_sysconfdir}/pam.d/apol
%config(noreplace) %{_sysconfdir}/pam.d/seaudit
%config(noreplace) %{_sysconfdir}/pam.d/sediffx
%config(noreplace) %{_sysconfdir}/security/console.apps/apol
%config(noreplace) %{_sysconfdir}/security/console.apps/seaudit
%config(noreplace) %{_sysconfdir}/security/console.apps/sediffx
/usr/share/doc/setools-%{version}/apol*
/usr/share/doc/setools-%{version}/seaudit_help.txt
/usr/share/doc/setools-%{version}/types_relation_help.txt
@ -162,8 +174,8 @@ rm -rf ${RPM_BUILD_ROOT}
/usr/share/setools/seaudit-report.css
/usr/share/setools/seaudit.glade
/usr/share/setools/seaudit_help.txt
/usr/share/setools/sechecker
/usr/share/setools/sechecker/profiles
%attr(755,root,root) %dir /usr/share/setools/sechecker
%attr(755,root,root) %dir /usr/share/setools/sechecker/profiles
/usr/share/setools/sechecker/profiles/all-checks.sechecker
/usr/share/setools/sechecker/profiles/analysis-checks.sechecker
/usr/share/setools/sechecker/profiles/devel-checks.sechecker
@ -183,6 +195,10 @@ Headers, static libraries and API docs for SETools.
%{_includedir}/setools
%{_libdir}/lib*
%post devel -p /sbin/ldconfig
%postun devel -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/seinfo
@ -194,6 +210,10 @@ Headers, static libraries and API docs for SETools.
/usr/share/doc/setools-%{version}/README
%changelog
* Wed Dec 14 2005 Dan Walsh <dwalsh@redhat.com> 2.2-4
- Fix dessktop files
- Apply fixes from bkyoung
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt