New version

Resolves: rhbz#1994268
This commit is contained in:
Jaroslav Škarvada 2021-08-18 22:47:47 +02:00
parent 855408363c
commit 69b40b053b
14 changed files with 123 additions and 151 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/sendmail.8.15.1.tar.gz
/sendmail.8.15.2.tar.gz
/sendmail.8.16.1.tar.gz
/sendmail.8.17.1.tar.gz

View File

@ -1,46 +0,0 @@
--- sendmail-8.14.4/devtools/OS/Linux 2010-01-03 22:55:35.000000000 +0100
+++ sendmail-8.14.4/devtools/OS/Linux.dynamic 2010-01-03 22:59:03.000000000 +0100
@@ -7,7 +7,7 @@
define(`confCCOPTS_SO', `-fPIC')
define(`confSM_OS_HEADER', `sm_os_linux')
define(`confMANROOT', `/usr/share/man/man')
-define(`confLIBS', `-ldl')
+define(`confLIBS', `-pie -ldl')
define(`confEBINDIR', `/usr/sbin')
APPENDDEF(`confLIBSEARCH', `crypt nsl')
@@ -22,19 +22,19 @@
ifelse(confBLDVARIANT, `DEBUG',
dnl Debug build
`
- define(`confOPTIMIZE',`-g -Wall')
+ define(`confOPTIMIZE',`-g -Wall -fpie')
',
dnl Optimized build
confBLDVARIANT, `OPTIMIZED',
`
- define(`confOPTIMIZE',`-O2')
+ define(`confOPTIMIZE',`-O2 -fpie')
',
dnl Purify build
confBLDVARIANT, `PURIFY',
`
- define(`confOPTIMIZE',`-g')
+ define(`confOPTIMIZE',`-g -fpie')
',
dnl default
`
- define(`confOPTIMIZE',`-O2')
+ define(`confOPTIMIZE',`-O2 -fpie')
')
--- sendmail-8.14.4/libsm/Makefile.m4 2006-08-16 23:06:31.000000000 +0200
+++ sendmail-8.14.4/libsm/Makefile.m4.dynamic 2010-01-03 23:01:36.000000000 +0100
@@ -6,7 +6,7 @@
define(`confREQUIRE_SM_OS_H', `true')
PREPENDDEF(`confENVDEF', `confMAPDEF')
bldPRODUCT_START(`library', `libsm')
-define(`bldSOURCES', ` assert.c debug.c errstring.c exc.c heap.c match.c rpool.c strdup.c strerror.c strl.c clrerr.c fclose.c feof.c ferror.c fflush.c fget.c fpos.c findfp.c flags.c fopen.c fprintf.c fpurge.c fput.c fread.c fscanf.c fseek.c fvwrite.c fwalk.c fwrite.c get.c makebuf.c put.c refill.c rewind.c setvbuf.c smstdio.c snprintf.c sscanf.c stdio.c strio.c ungetc.c vasprintf.c vfprintf.c vfscanf.c vprintf.c vsnprintf.c wbuf.c wsetup.c string.c stringf.c xtrap.c strto.c test.c strcasecmp.c strrevcmp.c signal.c clock.c config.c shm.c sem.c mbdb.c strexit.c cf.c ldap.c niprop.c mpeix.c memstat.c util.c inet6_ntop.c notify.c ')
+define(`bldSOURCES', ` assert.c debug.c errstring.c exc.c heap.c match.c rpool.c strdup.c strl.c clrerr.c fclose.c feof.c ferror.c fflush.c fget.c fpos.c findfp.c flags.c fopen.c fprintf.c fpurge.c fput.c fread.c fscanf.c fseek.c fvwrite.c fwalk.c fwrite.c get.c makebuf.c put.c refill.c rewind.c setvbuf.c smstdio.c snprintf.c sscanf.c stdio.c strio.c ungetc.c vasprintf.c vfprintf.c vfscanf.c vprintf.c vsnprintf.c wbuf.c wsetup.c string.c stringf.c xtrap.c strto.c test.c strcasecmp.c strrevcmp.c signal.c clock.c config.c shm.c sem.c mbdb.c strexit.c cf.c ldap.c niprop.c mpeix.c memstat.c util.c inet6_ntop.c notify.c ')
bldPRODUCT_END
dnl msg.c
dnl syslogio.c

View File

@ -1,19 +0,0 @@
diff --git a/sendmail/tls.c b/sendmail/tls.c
index 696d32f..b8527c4 100644
--- a/sendmail/tls.c
+++ b/sendmail/tls.c
@@ -29,7 +29,13 @@ SM_RCSID("@(#)$Id: tls.c,v 8.127 2013-11-27 02:51:11 gshapiro Exp $")
# ERROR: OpenSSL version OPENSSL_VERSION_NUMBER is unsupported.
# endif
-# if OPENSSL_VERSION_NUMBER >= 0x10100000L && OPENSSL_VERSION_NUMBER < 0x20000000L
+/*
+ ** *SSL version numbers:
+ ** OpenSSL 0.9 - 1.1 (so far), 3.0 (in alpha)
+ ** LibreSSL 2.0 (0x20000000L - part of "These will never change")
+ */
+
+# if (OPENSSL_VERSION_NUMBER >= 0x10100000L && OPENSSL_VERSION_NUMBER < 0x20000000L) || OPENSSL_VERSION_NUMBER >= 0x30000000L
# define MTA_HAVE_DH_set0_pqg 1
# define MTA_HAVE_DSA_GENERATE_EX 1

View File

@ -1,13 +0,0 @@
diff --git a/sendmail/conf.c b/sendmail/conf.c
index 63c545c..e9fa42c 100644
--- a/sendmail/conf.c
+++ b/sendmail/conf.c
@@ -1039,7 +1039,7 @@ switch_map_find(service, maptype, mapreturn)
if (p != NULL)
*p = '\0';
#ifndef SM_NSSWITCH_DELIMS
-# define SM_NSSWITCH_DELIMS " \t"
+# define SM_NSSWITCH_DELIMS " \t:"
#endif
p = strpbrk(buf, SM_NSSWITCH_DELIMS);
if (p != NULL)

View File

@ -1,8 +1,8 @@
diff --git a/cf/m4/cfhead.m4 b/cf/m4/cfhead.m4
index 6d12e85..15af608 100644
index c30fad0..492882e 100644
--- a/cf/m4/cfhead.m4
+++ b/cf/m4/cfhead.m4
@@ -269,7 +269,7 @@ ifdef(`MAIL_SETTINGS_DIR', , `define(`MAIL_SETTINGS_DIR', `/etc/mail/')')
@@ -275,7 +275,7 @@ ifdef(`MAIL_SETTINGS_DIR', , `define(`MAIL_SETTINGS_DIR', `/etc/mail/')')
define(`DATABASE_MAP_TYPE', `hash')
# set up default values for options
@ -12,10 +12,10 @@ index 6d12e85..15af608 100644
define(`confFROM_LINE', `From $g $d')
define(`confOPERATORS', `.:%@!^/[]+')
diff --git a/sendmail/aliases.0 b/sendmail/aliases.0
index ba855d4..edb3b19 100644
index 64d439c..1db4fd6 100644
--- a/sendmail/aliases.0
+++ b/sendmail/aliases.0
@@ -63,7 +63,7 @@ ALIASES(5) ALIASES(5)
@@ -63,7 +63,7 @@ DDEESSCCRRIIPPTTIIOONN
the list of users defined in that file.
This is only the raw data file; the actual aliasing information is
@ -25,48 +25,48 @@ index ba855d4..edb3b19 100644
time the aliases file is changed for the change to take effect.
diff --git a/sendmail/aliases.5 b/sendmail/aliases.5
index f09b49c..7b16db2 100644
index cb67508..52e5124 100644
--- a/sendmail/aliases.5
+++ b/sendmail/aliases.5
@@ -23,7 +23,7 @@ ID
aliases used by
aliases used by
sendmail.
The file resides in
-/etc/mail
The file resides in
-/etc/mail
+/etc
and
and
is formatted as a series of lines of the form
.IP
@@ -96,7 +96,7 @@ list of users defined in that file.
.PP
This is only the raw data file; the actual aliasing information is
placed into a binary format in the file
placed into a binary format in the file
-/etc/mail/aliases.db
+/etc/aliases.db
using the program
newaliases(1).
A
using the program
newaliases(1).
A
diff --git a/sendmail/newaliases.0 b/sendmail/newaliases.0
index 49ff2b0..247a276 100644
index d8952ee..0be8986 100644
--- a/sendmail/newaliases.0
+++ b/sendmail/newaliases.0
@@ -10,7 +10,7 @@ NEWALIASES(1) NEWALIASES(1)
@@ -10,7 +10,7 @@ SSYYNNOOPPSSIISS
DESCRIPTION
Newaliases rebuilds the random access data base for the mail aliases
DDEESSCCRRIIPPTTIIOONN
NNeewwaalliiaasseess rebuilds the random access data base for the mail aliases
- file /etc/mail/aliases. It must be run each time this file is changed
+ file /etc/aliases. It must be run each time this file is changed
in order for the change to take effect.
Newaliases is identical to ``sendmail -bi''.
@@ -22,7 +22,7 @@ NEWALIASES(1) NEWALIASES(1)
sendmail.
NNeewwaalliiaasseess is identical to ``sendmail -bi''.
@@ -22,7 +22,7 @@ DDEESSCCRRIIPPTTIIOONN
sseennddmmaaiill..
FILES
FFIILLEESS
- /etc/mail/aliases The mail aliases file
+ /etc/aliases The mail aliases file
SEE ALSO
SSEEEE AALLSSOO
aliases(5), sendmail(8)
diff --git a/sendmail/newaliases.1 b/sendmail/newaliases.1
index 59dc0de..9ba8752 100644
@ -91,13 +91,13 @@ index 59dc0de..9ba8752 100644
.SH SEE ALSO
aliases(5), sendmail(8)
diff --git a/sendmail/sendmail.0 b/sendmail/sendmail.0
index 60ab1cd..5f3bf93 100644
index 8eceedd..24a17da 100644
--- a/sendmail/sendmail.0
+++ b/sendmail/sendmail.0
@@ -434,10 +434,10 @@ SENDMAIL(8) SENDMAIL(8)
@@ -433,10 +433,10 @@ FFIILLEESS
names are all specified in _/_e_t_c_/_m_a_i_l_/_s_e_n_d_m_a_i_l_._c_f. Thus, these values
are only approximations.
- /etc/mail/aliases
+ /etc/aliases
raw data for alias names
@ -108,10 +108,10 @@ index 60ab1cd..5f3bf93 100644
/etc/mail/sendmail.cf
diff --git a/sendmail/sendmail.8 b/sendmail/sendmail.8
index 0356839..1258c26 100644
index 26685d0..60e7b64 100644
--- a/sendmail/sendmail.8
+++ b/sendmail/sendmail.8
@@ -711,10 +711,10 @@ Thus,
@@ -716,10 +716,10 @@ Thus,
these values are only approximations.
.PP
.TP

View File

@ -0,0 +1,35 @@
--- sendmail-8.14.4/devtools/OS/Linux 2010-01-03 22:55:35.000000000 +0100
+++ sendmail-8.14.4/devtools/OS/Linux.dynamic 2010-01-03 22:59:03.000000000 +0100
@@ -7,7 +7,7 @@
define(`confCCOPTS_SO', `-fPIC')
define(`confSM_OS_HEADER', `sm_os_linux')
define(`confMANROOT', `/usr/share/man/man')
-define(`confLIBS', `-ldl')
+define(`confLIBS', `-pie -ldl')
define(`confEBINDIR', `/usr/sbin')
APPENDDEF(`confLIBSEARCH', `crypt nsl')
@@ -22,19 +22,19 @@
ifelse(confBLDVARIANT, `DEBUG',
dnl Debug build
`
- define(`confOPTIMIZE',`-g -Wall')
+ define(`confOPTIMIZE',`-g -Wall -fpie')
',
dnl Optimized build
confBLDVARIANT, `OPTIMIZED',
`
- define(`confOPTIMIZE',`-O2')
+ define(`confOPTIMIZE',`-O2 -fpie')
',
dnl Purify build
confBLDVARIANT, `PURIFY',
`
- define(`confOPTIMIZE',`-g')
+ define(`confOPTIMIZE',`-g -fpie')
',
dnl default
`
- define(`confOPTIMIZE',`-O2')
+ define(`confOPTIMIZE',`-O2 -fpie')
')

View File

@ -11,7 +11,7 @@ index 8897f5a..0e04120 100644
</TD></TR>
</TABLE>
diff --git a/libmilter/listener.c b/libmilter/listener.c
index 0468a62..72e7a4f 100644
index 25ff895..23cec0a 100644
--- a/libmilter/listener.c
+++ b/libmilter/listener.c
@@ -197,6 +197,11 @@ mi_milteropen(conn, backlog, rmsocket, name)
@ -68,9 +68,9 @@ index 0468a62..72e7a4f 100644
smi_log(SMI_LOG_ERR,
"%s: Unable to bind to port %s: %s",
@@ -818,7 +839,7 @@ mi_listener(conn, dbg, smfi, timeout, backlog)
# ifdef BSD4_4_SOCKADDR
#ifdef BSD4_4_SOCKADDR
cliaddr.sa.sa_len == 0 ||
# endif
#endif
- cliaddr.sa.sa_family != L_family))
+ (L_family != AF_UNSPEC && cliaddr.sa.sa_family != L_family)))
{

View File

@ -1,8 +1,8 @@
diff --git a/cf/m4/proto.m4 b/cf/m4/proto.m4
index 618dde0..8c460ce 100644
index cfd71b3..6a7cf1c 100644
--- a/cf/m4/proto.m4
+++ b/cf/m4/proto.m4
@@ -1910,6 +1910,8 @@ R<@> < $* @ [IPv6:::1] >
@@ -1921,6 +1921,8 @@ R<@> < $* @ [IPv6:::1] >
$: < ? $&{client_name} > < $1 @ [IPv6:::1] >
R<@> < $* @ localhost.$m >
$: < ? $&{client_name} > < $1 @ localhost.$m >

View File

@ -1,8 +1,8 @@
diff --git a/sendmail/sendmail.8 b/sendmail/sendmail.8
index 9e0b9af..0356839 100644
index 6b10fac..26685d0 100644
--- a/sendmail/sendmail.8
+++ b/sendmail/sendmail.8
@@ -729,13 +729,11 @@ collected statistics
@@ -734,13 +734,11 @@ collected statistics
/var/spool/mqueue/*
temp files
.SH SEE ALSO
@ -14,5 +14,5 @@ index 9e0b9af..0356839 100644
mailaddr(7),
-rc(8)
.PP
DARPA
DARPA
Internet Request For Comments

View File

@ -1,5 +1,5 @@
diff --git a/cf/cf/submit.mc b/cf/cf/submit.mc
index b9dfb16..cb325cc 100644
index 6e2b360..45df0e6 100644
--- a/cf/cf/submit.mc
+++ b/cf/cf/submit.mc
@@ -22,6 +22,8 @@ define(`__OSTYPE__',`')dnl dirty hack to keep proto.m4 from complaining
@ -12,10 +12,10 @@ index b9dfb16..cb325cc 100644
dnl define(`confDIRECT_SUBMISSION_MODIFIERS',`C')dnl
FEATURE(`use_ct_file')dnl
diff --git a/cf/m4/proto.m4 b/cf/m4/proto.m4
index 8c460ce..a68ab8d 100644
index 6a7cf1c..fd54e87 100644
--- a/cf/m4/proto.m4
+++ b/cf/m4/proto.m4
@@ -253,6 +253,9 @@ _OPTION(SevenBitInput, `confSEVEN_BIT_INPUT', `False')
@@ -264,6 +264,9 @@ _OPTION(SevenBitInput, `confSEVEN_BIT_INPUT', `False')
# 8-bit data handling
_OPTION(EightBitMode, `confEIGHT_BIT_HANDLING', `pass8')
@ -26,10 +26,10 @@ index 8c460ce..a68ab8d 100644
_OPTION(AliasWait, `confALIAS_WAIT', `5m')
diff --git a/sendmail/conf.c b/sendmail/conf.c
index e9fa42c..fa64b11 100644
index f1bc1b2..ca5dc85 100644
--- a/sendmail/conf.c
+++ b/sendmail/conf.c
@@ -6614,6 +6614,10 @@ char *FFRCompileOptions[] =
@@ -6678,6 +6678,10 @@ char *FFRCompileOptions[] =
/* Check to make sure key fields were read from qf */
"_FFR_QF_PARANOIA",
#endif
@ -41,10 +41,10 @@ index e9fa42c..fa64b11 100644
/* Allow QueueSortOrder per queue group. */
/* XXX: Still need to actually use qgrp->qg_sortorder */
diff --git a/sendmail/daemon.c b/sendmail/daemon.c
index 19a9378..5561cf5 100644
index 5b42e32..c4604f0 100644
--- a/sendmail/daemon.c
+++ b/sendmail/daemon.c
@@ -124,6 +124,10 @@ static int NDaemons = 0; /* actual number of daemons */
@@ -129,6 +129,10 @@ static int NDaemons = 0; /* actual number of daemons */
static time_t NextDiskSpaceCheck = 0;
@ -55,7 +55,7 @@ index 19a9378..5561cf5 100644
/*
** GETREQUESTS -- open mail IPC port and get requests.
**
@@ -1159,6 +1163,16 @@ opendaemonsocket(d, firsttime)
@@ -1173,6 +1177,16 @@ opendaemonsocket(d, firsttime)
(void) setsockopt(d->d_socket, SOL_SOCKET,
SO_KEEPALIVE, (char *)&on, sizeof(on));
@ -72,7 +72,7 @@ index 19a9378..5561cf5 100644
#ifdef SO_RCVBUF
if (d->d_tcprcvbufsize > 0)
{
@@ -2688,6 +2702,16 @@ gothostent:
@@ -2704,6 +2718,16 @@ gothostent:
return EX_TEMPFAIL;
}
@ -90,7 +90,7 @@ index 19a9378..5561cf5 100644
if (ClientSettings[family].d_tcpsndbufsize > 0)
{
diff --git a/sendmail/readcf.c b/sendmail/readcf.c
index e6f6296..adb09da 100644
index 47c9777..bb98dbf 100644
--- a/sendmail/readcf.c
+++ b/sendmail/readcf.c
@@ -24,6 +24,7 @@ SM_RCSID("@(#)$Id: readcf.c,v 8.692 2013-11-22 20:51:56 ca Exp $")
@ -101,7 +101,7 @@ index e6f6296..adb09da 100644
#endif
@@ -2917,8 +2918,8 @@ static struct optioninfo
@@ -2983,8 +2984,8 @@ static struct optioninfo
# define O_RCPTTHROTDELAY 0xe6
{ "BadRcptThrottleDelay", O_RCPTTHROTDELAY, OI_SAFE },
#endif
@ -112,7 +112,7 @@ index e6f6296..adb09da 100644
{ "InetQoS", O_INETQOS, OI_NONE },
#endif
#if STARTTLS && _FFR_FIPSMODE
@@ -2982,6 +2983,77 @@ static struct optioninfo
@@ -3059,6 +3060,77 @@ static struct optioninfo
{ NULL, '\0', OI_NONE }
};
@ -190,9 +190,9 @@ index e6f6296..adb09da 100644
# define CANONIFY(val)
# define SET_OPT_DEFAULT(opt, val) opt = val
@@ -4679,6 +4751,33 @@ setoption(opt, val, safe, sticky, e)
@@ -4795,6 +4867,33 @@ setoption(opt, val, safe, sticky, e)
break;
# endif
#endif
+#ifdef O_INETQOS
+ case O_INETQOS:
@ -225,10 +225,10 @@ index e6f6296..adb09da 100644
if (tTd(37, 1))
{
diff --git a/sendmail/sendmail.h b/sendmail/sendmail.h
index e6cf45d..7f5cf9f 100644
index ae7ed3a..9e34dd9 100644
--- a/sendmail/sendmail.h
+++ b/sendmail/sendmail.h
@@ -2566,6 +2566,15 @@ EXTERN SOCKADDR ConnectOnlyTo; /* override connection address (for testing) */
@@ -2646,6 +2646,15 @@ EXTERN SOCKADDR ConnectOnlyTo; /* override connection address (for testing) */
EXTERN SOCKADDR RealHostAddr; /* address of host we are talking to */
extern const SM_EXC_TYPE_T EtypeQuickAbort; /* type of a QuickAbort exception */

View File

@ -1,19 +1,19 @@
diff --git a/sendmail/usersmtp.c b/sendmail/usersmtp.c
index b4ff5cc..dddbb0a 100644
index 5fe0791..2417558 100644
--- a/sendmail/usersmtp.c
+++ b/sendmail/usersmtp.c
@@ -1346,9 +1346,7 @@ safesaslfile(context, file)
@@ -1374,9 +1374,7 @@ safesaslfile(context, file)
{
long sff;
int r;
-#if SASL <= 10515
-# if SASL <= 10515
size_t len;
-#endif
-# endif
char *p;
if (file == NULL || *file == '\0')
@@ -1386,9 +1384,16 @@ safesaslfile(context, file)
#endif /* SASL <= 10515 */
if (SM_IS_EMPTY(file))
@@ -1414,9 +1414,16 @@ safesaslfile(context, file)
# endif /* SASL <= 10515 */
p = (char *) file;
+ len = strlen(p);

View File

@ -0,0 +1,13 @@
diff --git a/sendmail/conf.c b/sendmail/conf.c
index e7a9615..f1bc1b2 100644
--- a/sendmail/conf.c
+++ b/sendmail/conf.c
@@ -1044,7 +1044,7 @@ switch_map_find(service, maptype, mapreturn)
if (p != NULL)
*p = '\0';
# ifndef SM_NSSWITCH_DELIMS
-# define SM_NSSWITCH_DELIMS " \t"
+# define SM_NSSWITCH_DELIMS " \t:"
# endif
p = strpbrk(buf, SM_NSSWITCH_DELIMS);
if (p != NULL)

View File

@ -28,8 +28,8 @@
Summary: A widely used Mail Transport Agent (MTA)
Name: sendmail
Version: 8.16.1
Release: 8%{?dist}
Version: 8.17.1
Release: 1%{?dist}
License: Sendmail
URL: http://www.sendmail.org/
@ -71,31 +71,29 @@ Patch4: sendmail-8.16.1-smrsh_paths.patch
# fix sm-client.pid path
Patch7: sendmail-8.14.9-pid.patch
# fix sendmail man page
Patch10: sendmail-8.15.1-manpage.patch
Patch10: sendmail-8.17.1-manpage.patch
# compile with -fpie
Patch11: sendmail-8.16.1-dynamic.patch
Patch11: sendmail-8.17.1-dynamic.patch
# fix cyrus path
Patch12: sendmail-8.13.0-cyrus.patch
# fix aliases.db path
Patch13: sendmail-8.16.1-aliases_dir.patch
Patch13: sendmail-8.17.1-aliases_dir.patch
# fix vacation Makefile
Patch14: sendmail-8.14.9-vacation.patch
# remove version information from sendmail helpfile
Patch15: sendmail-8.14.9-noversion.patch
# do not accept localhost.localdomain as valid address from SMTP
Patch16: sendmail-8.16.1-localdomain.patch
Patch16: sendmail-8.17.1-localdomain.patch
# build libmilter as DSO
Patch17: sendmail-8.14.3-sharedmilter.patch
# skip colon separator when parsing service name in ServiceSwitchFile
Patch18: sendmail-8.16.1-switchfile.patch
Patch18: sendmail-8.17.1-switchfile.patch
# silence warning about missing sasl2 config in /usr/lib*, now in /etc/sasl2
Patch23: sendmail-8.16.1-sasl2-in-etc.patch
Patch23: sendmail-8.17.1-sasl2-in-etc.patch
# add QoS support, patch from Philip Prindeville <philipp@fedoraproject.org>
# upstream reserved option ID 0xe7 for testing of this new feature, #576643
Patch25: sendmail-8.16.1-qos.patch
Patch26: sendmail-8.16.1-libmilter-socket-activation.patch
# upstream patch
Patch27: sendmail-8.16.1-openssl-3.0-fix.patch
Patch25: sendmail-8.17.1-qos.patch
Patch26: sendmail-8.17.1-libmilter-socket-activation.patch
BuildRequires: make
BuildRequires: libdb-devel
@ -206,7 +204,6 @@ cp devtools/M4/UNIX/{,shared}library.m4
%patch23 -p1 -b .sasl2-in-etc
%patch25 -p1 -b .qos
%patch26 -p1 -b .libmilter-socket-activation
%patch27 -p1 -b .openssl-3.0-fix
for f in RELEASE_NOTES contrib/etrn.0; do
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
@ -220,7 +217,7 @@ sed -i 's|/usr/local/bin/perl|%{_bindir}/perl|' contrib/*.pl
cat > redhat.config.m4 << EOF
define(\`confMAPDEF', \`-DNEWDB -DCDB %{?nis_cflags} -DMAP_REGEX -DSOCKETMAP -DNAMED_BIND=1')
define(\`confOPTIMIZE', \`\`\`\`${RPM_OPT_FLAGS}'''')
define(\`confENVDEF', \`-I%{_includedir}/libdb -I%{_prefix}/kerberos/include -Wall -DXDEBUG=0 -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1 -D_FFR_LINUX_MHNL -D_FFR_QOS -D_FILE_OFFSET_BITS=64 -DHAS_GETHOSTBYNAME2')
define(\`confENVDEF', \`-I%{_includedir}/libdb -I%{_prefix}/kerberos/include -Wall -DXDEBUG=0 -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1 -D_FFR_LINUX_MHNL -D_FFR_QOS -D_FILE_OFFSET_BITS=64 -DHAS_GETHOSTBYNAME2 -DHASFLOCK')
define(\`confLIBDIRS', \`-L%{_prefix}/kerberos/%{_lib}')
define(\`confLIBS', \`%{?nis_ldadd} -lcrypt -ldb -lcdb -lresolv')
%{?_hardened_build:define(\`confLDOPTS', \`-Xlinker -z -Xlinker relro -Xlinker -z -Xlinker now')}
@ -710,6 +707,10 @@ exit 0
%changelog
* Tue Aug 17 2021 Jaroslav Škarvada <jskarvad@redhat.com> - 8.17.1-1
- New version
Resolves: rhbz#1994268
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 8.16.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (sendmail.8.16.1.tar.gz) = d7d4aac3c6d7505782abdb166204901b8b51cac000d610dfe40eda9eef7441a073af9e8e0b14c8719b07b445f55a1e2c28ac63d663d0daa7f1eafc5a101788b2
SHA512 (sendmail.8.17.1.tar.gz) = ae42343fb06c09f2db5d919d602afc4241914387dfdae0f15e0967dda3be25bf1d3a4637b57266763679646a3cea6aa07e6453266fd9b7358c1a09ec2b627a15