sdformat/sdformat-6.3.1-fixruby.patch
Rich Mattes 21d1609ac1 Update to release 6.3.1
migrated to SPDX license
Fix use of deprecated ruby function
Resolves: rhbz#2165939
2023-07-13 23:02:24 -04:00

63 lines
2.1 KiB
Diff

diff -up ./CMakeLists.txt.fixruby ./CMakeLists.txt
--- ./CMakeLists.txt.fixruby 2021-07-07 08:26:39.000000000 -0400
+++ ./CMakeLists.txt 2023-07-13 22:52:00.441136109 -0400
@@ -70,6 +70,8 @@ set (BIN_INSTALL_DIR ${CMAKE_INSTALL_BIN
set (USE_FULL_RPATH OFF CACHE BOOL "Set to true to enable full rpath")
+set (RUBY_LIB_INSTALL_DIR "lib/ruby" CACHE STRING "Installation directory for ruby scripts (relative to CMAKE_INSTALL_PREFIX)")
+
if (USE_FULL_RPATH)
# use, i.e. don't skip the full RPATH for the build tree
@@ -147,8 +149,8 @@ endif()
#####################################
# Handle CFlags
-unset (CMAKE_C_FLAGS_ALL CACHE)
-unset (CMAKE_CXX_FLAGS CACHE)
+#unset (CMAKE_C_FLAGS_ALL CACHE)
+#unset (CMAKE_CXX_FLAGS CACHE)
# USE_HOST_CFLAGS (default TRUE)
# Will check building host machine for proper cflags
diff -up ./src/cmd/CMakeLists.txt.fixruby ./src/cmd/CMakeLists.txt
--- ./src/cmd/CMakeLists.txt.fixruby 2021-07-07 08:26:39.000000000 -0400
+++ ./src/cmd/CMakeLists.txt 2023-07-13 22:52:00.438136093 -0400
@@ -41,4 +41,4 @@ file(GENERATE
INPUT "${cmd_script_configured}")
# Install the ruby command line library in an unversioned location.
-install(FILES ${cmd_script_generated} DESTINATION lib/ruby/ignition)
+install(FILES ${cmd_script_generated} DESTINATION ${RUBY_LIB_INSTALL_DIR}/ignition)
diff -up ./tools/xmlschema.rb.fixruby ./tools/xmlschema.rb
--- ./tools/xmlschema.rb.fixruby 2023-07-13 22:53:39.023665408 -0400
+++ ./tools/xmlschema.rb 2023-07-13 22:53:48.162714331 -0400
@@ -265,7 +265,7 @@ opt_parser.parse!
if infile.nil?
puts "Missing option -i."
exit
-elsif !File.exists?(infile)
+elsif !File.exist?(infile)
puts "Input file[#{infile}] does not exist\n"
exit
end
@@ -273,7 +273,7 @@ end
if $path.nil?
puts "Missing option -s."
exit
-elsif !Dir.exists?($path)
+elsif !Dir.exist?($path)
puts "SDF source dir[#{$path}] does not exist\n"
exit
end
@@ -281,7 +281,7 @@ end
if outdir.nil?
puts "Missing output directory, option -o."
exit
-elsif !Dir.exists?(outdir)
+elsif !Dir.exist?(outdir)
Dir.mkdir(outdir)
end