Update to release 6.0.0
- Update to release 6.0.0 - Install ruby script into %%{ruby_vendorlibdir} - Remove obsolete %%post and %%postun ldconfig scriptlets
This commit is contained in:
parent
80edd6810a
commit
e21342826a
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
|||||||
/sdformat-4.2.0.tar.bz2
|
/sdformat-4.2.0.tar.bz2
|
||||||
/sdformat-5.1.0.tar.bz2
|
/sdformat-5.1.0.tar.bz2
|
||||||
/sdformat-5.2.0.tar.bz2
|
/sdformat-5.2.0.tar.bz2
|
||||||
|
/sdformat-6.0.0.tar.bz2
|
||||||
|
21
sdformat.ruby-lib-install-dir.patch
Normal file
21
sdformat.ruby-lib-install-dir.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -urN sdformat-6.0.0.orig/CMakeLists.txt sdformat-6.0.0/CMakeLists.txt
|
||||||
|
--- sdformat-6.0.0.orig/CMakeLists.txt 2018-01-25 20:43:24.000000000 +0000
|
||||||
|
+++ sdformat-6.0.0/CMakeLists.txt 2018-11-23 20:04:09.020944630 +0000
|
||||||
|
@@ -61,6 +61,8 @@
|
||||||
|
|
||||||
|
set (USE_FULL_RPATH OFF CACHE BOOL "Set to true to enable full rpath")
|
||||||
|
|
||||||
|
+set (RUBY_LIB_INSTALL_DIR "lib/ruby" CACHE STRING "Installation directory for ruby scripts (relative to CMAKE_INSTALL_PREFIX)")
|
||||||
|
+
|
||||||
|
|
||||||
|
if (USE_FULL_RPATH)
|
||||||
|
# use, i.e. don't skip the full RPATH for the build tree
|
||||||
|
diff -urN sdformat-6.0.0.orig/src/cmd/CMakeLists.txt sdformat-6.0.0/src/cmd/CMakeLists.txt
|
||||||
|
--- sdformat-6.0.0.orig/src/cmd/CMakeLists.txt 2018-01-25 20:43:24.000000000 +0000
|
||||||
|
+++ sdformat-6.0.0/src/cmd/CMakeLists.txt 2018-11-23 20:04:16.367048961 +0000
|
||||||
|
@@ -14,4 +14,4 @@
|
||||||
|
"${CMAKE_CURRENT_BINARY_DIR}/cmdsdformat${SDF_MAJOR_VERSION}.rb" @ONLY)
|
||||||
|
|
||||||
|
# Install the ruby command line library in an unversioned location.
|
||||||
|
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmdsdformat${SDF_MAJOR_VERSION}.rb DESTINATION lib/ruby/ignition)
|
||||||
|
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmdsdformat${SDF_MAJOR_VERSION}.rb DESTINATION ${RUBY_LIB_INSTALL_DIR}/ignition)
|
@ -1,8 +1,9 @@
|
|||||||
%global apiver 5.2
|
%global apiver_major 6
|
||||||
|
%global apiver %{apiver_major}.0
|
||||||
|
|
||||||
Name: sdformat
|
Name: sdformat
|
||||||
Version: 5.2.0
|
Version: 6.0.0
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Simulation Description Format
|
Summary: The Simulation Description Format
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -10,6 +11,8 @@ URL: http://sdformat.org/
|
|||||||
Source0: http://gazebosim.org/distributions/%{name}/releases/%{name}-%{version}.tar.bz2
|
Source0: http://gazebosim.org/distributions/%{name}/releases/%{name}-%{version}.tar.bz2
|
||||||
# Disable doxygen latex documentation
|
# Disable doxygen latex documentation
|
||||||
Patch0: %{name}-2.0.1-latex.patch
|
Patch0: %{name}-2.0.1-latex.patch
|
||||||
|
# Make ruby install path configurable
|
||||||
|
Patch1: %{name}.ruby-lib-install-dir.patch
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: boost-devel
|
BuildRequires: boost-devel
|
||||||
@ -18,7 +21,7 @@ BuildRequires: doxygen
|
|||||||
BuildRequires: graphviz
|
BuildRequires: graphviz
|
||||||
BuildRequires: gtest-devel
|
BuildRequires: gtest-devel
|
||||||
BuildRequires: ignition-math-devel
|
BuildRequires: ignition-math-devel
|
||||||
BuildRequires: ruby >= 1.9
|
BuildRequires: ruby-devel >= 1.9
|
||||||
BuildRequires: /usr/bin/ruby
|
BuildRequires: /usr/bin/ruby
|
||||||
BuildRequires: rubygem-multi_xml
|
BuildRequires: rubygem-multi_xml
|
||||||
BuildRequires: texlive-refman
|
BuildRequires: texlive-refman
|
||||||
@ -55,6 +58,7 @@ The %{name}-doc package contains development documentation for
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0 -b .latex
|
%patch0 -p0 -b .latex
|
||||||
|
%patch1 -p1
|
||||||
# Remove bundled urdf components
|
# Remove bundled urdf components
|
||||||
rm -rf src/urdf
|
rm -rf src/urdf
|
||||||
|
|
||||||
@ -66,6 +70,7 @@ pushd build
|
|||||||
-DCMAKE_C_FLAGS_RELWITHDEBINFO="-std=c++11 %{optflags}" \
|
-DCMAKE_C_FLAGS_RELWITHDEBINFO="-std=c++11 %{optflags}" \
|
||||||
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO="-std=c++11 %{optflags}" \
|
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO="-std=c++11 %{optflags}" \
|
||||||
-DLIB_INSTALL_DIR:STRING=%{_lib} \
|
-DLIB_INSTALL_DIR:STRING=%{_lib} \
|
||||||
|
-DRUBY_LIB_INSTALL_DIR:STRING=%{ruby_vendorlibdir} \
|
||||||
-DUSE_EXTERNAL_URDF=ON \
|
-DUSE_EXTERNAL_URDF=ON \
|
||||||
-DSSE3_FOUND=false \
|
-DSSE3_FOUND=false \
|
||||||
-DSSSE3_FOUND=false \
|
-DSSSE3_FOUND=false \
|
||||||
@ -91,15 +96,12 @@ make -C build install DESTDIR=%{buildroot}
|
|||||||
export GTEST_COLOR=no
|
export GTEST_COLOR=no
|
||||||
make -C build test ARGS="-V -E INTEGRATION_schema_test"
|
make -C build test ARGS="-V -E INTEGRATION_schema_test"
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%license LICENSE COPYING
|
%license LICENSE COPYING
|
||||||
%doc AUTHORS README
|
%doc AUTHORS README.md Changelog.md Migration.md
|
||||||
%exclude %{_datadir}/%{name}/cmake
|
|
||||||
%{_datadir}/%{name}
|
%{_datadir}/%{name}
|
||||||
|
%{_datadir}/ignition/sdformat%{apiver_major}.yaml
|
||||||
|
%{ruby_vendorlibdir}/ignition/cmdsdformat%{apiver_major}.rb
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -113,6 +115,11 @@ make -C build test ARGS="-V -E INTEGRATION_schema_test"
|
|||||||
%doc build/doxygen/html
|
%doc build/doxygen/html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 23 2018 Till Hofmann <thofmann@fedoraproject.org> - 6.0.0-1
|
||||||
|
- Update to release 6.0.0
|
||||||
|
- Install ruby script into %%{ruby_vendorlibdir}
|
||||||
|
- Remove obsolete %%post and %%postun ldconfig scriptlets
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-5
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (sdformat-5.2.0.tar.bz2) = 65df9f0d351ab894af41cc2081dc8ab179336092ceba17979720bed4d58f77e9648863501d83f073ea8478197e7e0a7d7a9f8efd3a54d22ee28d74765cebcee7
|
SHA512 (sdformat-6.0.0.tar.bz2) = 2188de97cb1eb1117a694d54a0a42112bd7e5b5a4b00c04e049de73a10947904940565e36df93ca08ea5910e628983e234d07c57694c463e0794c48e20cedb21
|
||||||
|
Loading…
Reference in New Issue
Block a user